Update from Ubuntu 14.04 to 16.04 and zcs 8.6 to 8.7

Ask questions about your setup or get help installing ZCS server (ZD section below).
Arny80Hexa
Posts: 1
Joined: Thu Feb 16, 2017 4:40 pm

Update from Ubuntu 14.04 to 16.04 and zcs 8.6 to 8.7

Postby Arny80Hexa » Thu Feb 16, 2017 4:55 pm

Hello,

i have have upgraded my Ubuntu 14.04 to 16.04 and now i have some problems in upgrading Zimbra from 8.6 to 8.7.

  • fist i stopped zimbra and delete it from autostart (rc.d)
  • the i have make a "do-release-upgrade" on my ubuntu server
  • after upgrade my system and restart, i downloaded the latest zimbra 8.6 and run ./install.sh witch result in following error:

Code: Select all

Operations logged to /tmp/install.log.8gmKGZf3
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.6.0.GA.1153.UBUNTU14.64
    zimbra-logger...FOUND zimbra-logger-8.6.0.GA.1153.UBUNTU14.64
    zimbra-mta...FOUND zimbra-mta-8.6.0.GA.1153.UBUNTU14.64
    zimbra-dnscache...FOUND zimbra-dnscache-8.6.0.GA.1153.UBUNTU14.64
    zimbra-snmp...FOUND zimbra-snmp-8.6.0.GA.1153.UBUNTU14.64
    zimbra-store...FOUND zimbra-store-8.6.0.GA.1153.UBUNTU14.64
    zimbra-apache...FOUND zimbra-apache-8.6.0.GA.1153.UBUNTU14.64
    zimbra-spell...FOUND zimbra-spell-8.6.0.GA.1153.UBUNTU14.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-8.6.0.GA.1153.UBUNTU14.64
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.6.0.GA.1153.UBUNTU14.64
ZCS upgrade from 8.6.0 to 8.7.2 will be performed.
Checking for existing proxy service in your environment
Error: Unable to contact the LDAP server.

Code: Select all

WARNING: ZCS is currently only supported on Ubuntu Server 12.04 and 14.04 LTS.
You are attempting to install on Ubuntu 16.04.2 LTS which may not work.
Support will not be provided if you choose to continue.


Do you wish to continue? [N] y

Operations logged to /tmp/install.log.3441
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.6.0.GA.1153.UBUNTU14.64
    zimbra-logger...FOUND zimbra-logger-8.6.0.GA.1153.UBUNTU14.64
    zimbra-mta...FOUND zimbra-mta-8.6.0.GA.1153.UBUNTU14.64
    zimbra-dnscache...FOUND zimbra-dnscache-8.6.0.GA.1153.UBUNTU14.64
    zimbra-snmp...FOUND zimbra-snmp-8.6.0.GA.1153.UBUNTU14.64
    zimbra-store...FOUND zimbra-store-8.6.0.GA.1153.UBUNTU14.64
    zimbra-apache...FOUND zimbra-apache-8.6.0.GA.1153.UBUNTU14.64
    zimbra-spell...FOUND zimbra-spell-8.6.0.GA.1153.UBUNTU14.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-8.6.0.GA.1153.UBUNTU14.64
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.6.0.GA.1153.UBUNTU14.64
ZCS upgrade from 8.6.0 to 8.6.0 will be performed.
Validating ldap configuration
Unknown Error: It should be impossible to reach this statement.


What can i do? Thanks
Christoph


User avatar
jorgedlcruz
Elite member
Elite member
Posts: 2347
Joined: Thu May 22, 2014 4:47 pm

Re: Update from Ubuntu 14.04 to 16.04 and zcs 8.6 to 8.7

Postby jorgedlcruz » Fri Feb 17, 2017 12:47 am

What is the exactly message you see on the installation log?

Best regards
Jorge de la Cruz https://jorgedelacruz.es
Product Manager, Zimbra/Synacor https://www.zimbra.com/
A Zetalliance Founder
User avatar
laurens
Posts: 2
Joined: Thu Feb 16, 2017 10:46 am

Re: Update from Ubuntu 14.04 to 16.04 and zcs 8.6 to 8.7

Postby laurens » Thu Feb 23, 2017 11:00 am

Hi,

I had almost the same upgrade, only the updating zimbra version was a lil bit older (8.5.1) and zcs-8.7.3 is out already :)

first shutdown zimbra

Code: Select all

   su - zimbra
   zmcontrol stop


upgrade Ubuntu 14.04 to 16.04

backup your install_history cause it sometimes gets somehow damage uring the update
the installer fails on

Code: Select all

   Upgrading from  to 8.7.3_GA_1750
   ERROR: Upgrading from a ZCS version less than 7.0.0_GA is not supported


where it should come up with

Code: Select all

   Upgrading from 8.5.1_GA_3056 to 8.7.3_GA_1750
   Stopping zimbra services...done.
   This appears to be 8.5.1_GA


so

Code: Select all

cp /opt/zimbra/.install_history /home/zimbra-backup/.


from: viewtopic.php?t=60084 i took the tip to remove de x86_64-linux-gnu-thread-multi, but he has a lil typo in his 'rm' statement

Code: Select all

   rm -rf /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi*
   apt install libdata-uuid-perl libsocket-linux-perl


I needed some more perl fixes

Code: Select all

   apt-get install libxml-parser-perl
   cpan XML::XPath


zimbra needs to run for the update

Code: Select all

   su - zimbra
   zmcontrol start


and although not so much is working, everything should startup at this point.

Starting ldap...Done.
Starting zmconfigd...Done.
Starting dnscache...Done.
Starting logger...Done.
Starting mailbox...Done.
Starting memcached...Done.
Starting proxy...Done.
Starting amavis...Done.
Starting antispam...Done.
Starting antivirus...Done.
Starting opendkim...Done.
Starting snmp...Done.
Starting spell...Done.
Starting mta...Done.
Starting stats...Done.
Starting service webapp...Done.
Starting zimbra webapp...Done.
Starting zimbraAdmin webapp...Done.
Starting zimlet webapp...Done.



start the upgrade with the -s option

Code: Select all

./install.sh -s


remove the broken (symlinked) openldap in /opt/zimbra because that will skrew up the installation with out the -s option. Error message could be similar with mine or nagging about missing back_mdb.la files not found

ZCS upgrade from 8.7.3 to 8.7.3 will be performed.
Validating ldap configuration
Error: Unable to create a successful TLS connection to the ldap masters.
Fix cert configuration prior to upgrading.


from viewtopic.php?f=13&t=60691&start=10#p272114 i took the following solution that worked for me:

this was link broken
lrwxrwxrwx 1 zimbra zimbra 30 Mar 11 2016 openldap -> /opt/zimbra/openldap-2.4.39.2z


Code: Select all

   cd /opt/zimbra
   rm openldap
   mkdir /opt/zimbra/openldap/sbin
   cd /opt/zimbra/openldap/sbin
   ln -s /opt/zimbra/common/libexec/openldap


start the upgrade again without the -s option

Code: Select all

./install.sh


and everything should work fine. When it fails on the

Code: Select all

ERROR: Upgrading from a ZCS version less than 7.0.0_GA is not supported


i just had to restore my .install_history and i was good to go

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 2 guests