[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Ask questions about your setup or get help installing ZCS server (ZD section below).
TheInfinity
Posts: 4
Joined: Fri Sep 12, 2014 11:58 pm

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby TheInfinity » Mon Feb 07, 2011 6:46 pm

Hi everyone,
I made an upgrade this evening - and got a really strange bug. I can send mails to external hosts like before - but any mail to zimbra fails because of "Relay Access denied". If I try to send something via webinterface I get an "mail for vereinlandwege.de loops back to myself" error.
My setup:
- Ubuntu 10.04
- Zimbra OpenSource Edition 7, 64bit
Server:
- internal hostname: sun.vereinlandwege.de
- external hostname: mail.vereinlandwege.de
- mail adresses: name@vereinlandwege.de
If I send to outside it looks like this in target hostname:


Feb  8 00:46:12 lvps83-169-1-219 postfix/smtpd[16090]: connect from mail.vereinlandwege.de[88.79.167.149]

Feb 8 00:46:27 lvps83-169-1-219 postfix/smtpd[16090]: warning: 149.167.79.88.list.dsbl.org: RBL lookup error: Host or domain name not found. Name service error for name=149.167.79.88.list.dsbl.org type=A: Host not found, try againFeb 8 00:46:28 lvps83-169-1-219 postfix/smtpd[16090]: 19085166E19FD: client=mail.vereinlandwege.de[88.79.167.149]Feb 8 00:46:28 lvps83-169-1-219 postfix/cleanup[22216]: 19085166E19FD: message-id=Feb 8 00:46:28 lvps83-169-1-219 postfix/qmgr[2007]: 19085166E19FD: from=, size=811, nrcpt=1 (queue active)Feb 8 00:46:28 lvps83-169-1-219 postfix/smtpd[16090]: disconnect from mail.vereinlandwege.de[88.79.167.149]


mail.vereinlandwege.de looks perfect - and it is perfect, it works. But internally it gets strange. A mail from webinterface to the same account:


Feb  8 01:26:46 sun postfix/smtpd[25565]: connect from localhost[127.0.0.1]

Feb 8 01:26:46 sun postfix/smtpd[25565]: E21AA4C14F4: client=localhost[127.0.0.1]Feb 8 01:26:46 sun postfix/cleanup[25568]: E21AA4C14F4: message-id=

Feb 8 01:26:46 sun postfix/qmgr[21006]: E21AA4C14F4: from=, size=593, nrcpt=1 (queue active)Feb 8 01:26:46 sun postfix/smtpd[25565]: disconnect from localhost[127.0.0.1]

Feb 8 01:26:47 sun postfix/smtp[25569]: E21AA4C14F4: to=, relay=none, delay=0.07, delays=0.05/0.02/0/0, dsn=5.4.6, status=bounced (mail for vereinlandweg

e.de loops back to myself)

Feb 8 01:26:47 sun postfix/cleanup[25568]: 043354C14F6: message-id=

Feb 8 01:26:47 sun postfix/bounce[25571]: E21AA4C14F4: sender non-delivery notification: 043354C14F6

Feb 8 01:26:47 sun postfix/qmgr[21006]: E21AA4C14F4: removed

Feb 8 01:26:47 sun postfix/smtp[25569]: 043354C14F6: to=, relay=none, delay=0.03, delays=0.03/0/0/0, dsn=5.4.6, status=bounced (mail for vereinlandwege.de loops back to myself)

Feb 8 01:26:47 sun postfix/qmgr[21006]: 043354C14F6: removed


This looks strange. It looks even more strange if I try to send a mail from outside:


Feb  8 01:22:51 sun postfix/smtpd[24666]: connect from sectio-aurea.org[83.169.1.219]

Feb 8 01:22:51 sun postfix/smtpd[24666]: NOQUEUE: reject: RCPT from sectio-aurea.org[83.169.1.219]: 554 5.7.1 : Relay access denied; from= to= proto=ESMTP helo=


Why does it not know its own virtual domains?! Because - vereinlandwege.de is active in zimbra admin interface and I can login with vereinlandwege.de users.
/etc/hosts:


192.168.1.1     sun.vereinlandwege.de sun.vereinlandwege.de mail.vereinlandwege.de vereinlandwege.de sun


MX-Records always point to mail.vereinlandwege.de, intern and extern.
So - any ideas where the problem might be? Thanks for any idea!



bku09
Posts: 13
Joined: Sat Sep 13, 2014 12:58 am

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby bku09 » Mon Feb 07, 2011 7:49 pm

I have exactly the same problems since I updated from 6.0.10GA to 7.0.0GA, everything was working fine with 6.0.10GA.
still trying to fix the issue, will keep you updated ...
Bernd
waltholman
Posts: 21
Joined: Sat Sep 13, 2014 12:26 am

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby waltholman » Mon Feb 07, 2011 7:57 pm

Another me too.... I noticed in the /opt/zimbra/postfix/conf directory that the main.cf file was a zero (0) byte file. Re-running zmmtactl stop/start did not create the correct file (yet).
Update: After restoring the old main.cf from my 6.0.10 backup, the system is receiving and delivering mail once again. Glad this was my home server & not work :)
Now, to try and figure out why the main.cf doesn't get created properly....
bku09
Posts: 13
Joined: Sat Sep 13, 2014 12:58 am

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby bku09 » Mon Feb 07, 2011 9:05 pm

jep right, there is definitely something wrong with the main.cf config file generation.
in the meantime you can simply replace the main.cf with the previous version even if you don't have any "real" backups :-)
as root enter:

cd /opt/zimbra/postfix/conf

cp /opt/zimbra/postfix-2.6.7.2z/conf/main.cf . (change 2.6.7.2z to your last version)

su - zimbra -c "zmmtactl restart"
everything should be back to normal now, but still trying to figure out the root cause ...
Bernd
User avatar
quanah
Zimbra Alumni
Zimbra Alumni
Posts: 1667
Joined: Fri Sep 12, 2014 10:33 pm
Contact:

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby quanah » Mon Feb 07, 2011 9:47 pm

The configuration is generated by the command /opt/zimbra/libexec/configrewrite mta
Can someone who is seeing this issue paste the output of running this manually?
--
Quanah Gibson-Mount
Product Architect, Symas http://www.symas.com/
OpenLDAP Core team http://www.openldap.org/project/
bku09
Posts: 13
Joined: Sat Sep 13, 2014 12:58 am

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby bku09 » Mon Feb 07, 2011 9:58 pm

[quote user="quanah"]The configuration is generated by the command /opt/zimbra/libexec/configrewrite mta
Can someone who is seeing this issue paste the output of running this manually?[/QUOTE]
[zimbra@zimbra ~]$ /opt/zimbra/libexec/configrewrite mta

[zimbra@zimbra ~]$
no errors on stdout, no changes to main.cf after this command (tested with user zimbra and root)
Mark L Sung
Posts: 2
Joined: Sat Sep 13, 2014 1:26 am

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby Mark L Sung » Mon Feb 07, 2011 10:06 pm

Guys, I though ZCS7 is still in beta, people just can wait to moving forward. lol
bku09
Posts: 13
Joined: Sat Sep 13, 2014 12:58 am

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby bku09 » Mon Feb 07, 2011 10:08 pm

[quote user="Mark L Sung"]Guys, I though ZCS7 is still in beta, people just can wait to moving forward. lol[/QUOTE]
just go to Zimbra offers Open Source email server software and shared calendar for Linux and the Mac. and read the headline ;) surprise!
User avatar
quanah
Zimbra Alumni
Zimbra Alumni
Posts: 1667
Joined: Fri Sep 12, 2014 10:33 pm
Contact:

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby quanah » Mon Feb 07, 2011 10:08 pm

Does the problem reappear if you run (as zimbra):

postfix stop

postfix start
If it does, then we'll actually have to do the following, since configrewrite squelches its output:
1. postfix stop (as zimbra user)

2. echo REWRITE mta | /bin/nc -w 120 localhost 7171 (as zimbra user)
--Quanah
--
Quanah Gibson-Mount
Product Architect, Symas http://www.symas.com/
OpenLDAP Core team http://www.openldap.org/project/
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

[SOLVED] Zimbra 6 -> 7 - Zimbra does not know its own virtual hosts

Postby 14319KevinH » Mon Feb 07, 2011 10:09 pm

Take a look at this bug. Permissions and sudoers file is important.
https://bugzilla.zimbra.com/show_bug.cgi?id=55541

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 6 guests