Perl API version v5.14.0 of Socket does not match v5.18.0

Ask questions about your setup or get help installing ZCS server (ZD section below).
Broco
Posts: 8
Joined: Sat Sep 13, 2014 3:37 am

Perl API version v5.14.0 of Socket does not match v5.18.0

Postby Broco » Sat Sep 10, 2016 8:57 am

Hello, I just tried to upgrade my Zimbra version from 8.0.5 to 8.7 after I upgraded Ubuntu from 12.04 to 14.04.
I followed this guide: https://wiki.zimbra.com/wiki/Ubuntu_Upgrades but I still got this error: Perl API version v5.14.0 of Socket does not match v5.18.0
And did the following steps (just to reproduce:

1. stopping zimbra (zmcontrol stop as zimbra)
2. updating and upgrading all existing packages: apt-get update && apt-get upgrade
3. Ubuntu Release Upgrade (as disclaimed in the Wiki I always chose the default option, aka kept the original configurations)
4. Checking Ubuntu version: Linux version 3.13.0-95-generic (buildd@lgw01-58) (gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.3) ) #142-Ubuntu SMP Fri Aug 12 17:00:09 UTC 2016
5. Reboot, apt-get update && apt-get upgrade, another rebboot (just to be save)
6. Downloading and unpacking zimbra 8.7 for Ubuntu 14.04 (packagename: zcs-8.7.0_GA_1659.UBUNTU14_64.20160628202701.tgz)
7. installing PERL 5.18: apt-get install libperl5.18
8. ./install.sh -s

After the last step I get the following output:

Code: Select all

root@mail:~/zcs-8.7.0_GA_1659.UBUNTU14_64.20160628202701# ./install.sh -s

Operations logged to /tmp/install.log.H0RNHBEX
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.0.5.GA.5839.UBUNTU12.64
    zimbra-logger...FOUND zimbra-logger-8.0.5.GA.5839.UBUNTU12.64
    zimbra-mta...FOUND zimbra-mta-8.0.5.GA.5839.UBUNTU12.64
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...FOUND zimbra-snmp-8.0.5.GA.5839.UBUNTU12.64
    zimbra-store...FOUND zimbra-store-8.0.5.GA.5839.UBUNTU12.64
    zimbra-apache...FOUND zimbra-apache-8.0.5.GA.5839.UBUNTU12.64
    zimbra-spell...FOUND zimbra-spell-8.0.5.GA.5839.UBUNTU12.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-8.0.5.GA.5839.UBUNTU12.64
    zimbra-proxy...FOUND zimbra-proxy-8.0.5.GA.5839.UBUNTU12.64
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.0.5.GA.5839.UBUNTU12.64
ZCS upgrade from 8.0.5 to 8.7.0 will be performed.
Checking for existing proxy service in your environment
Perl API version v5.14.0 of Socket does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 92.
Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
Compilation failed in require at bin/checkService.pl line 21.
BEGIN failed--compilation aborted at bin/checkService.pl line 21.
Error: Unable to contact the LDAP server.



Any hints on how I can resolve this? I searched the forum but the only suggestion was to download the right package for the Ubuntu version you are using but that is what I'm doing...
The log file in /tmp is empty, too, so no hints from that side.
Thanks in advance.

Edit: I just tried the same just with 8.6 instead of 8.7 and it started installing. Strange. I will see if it works.

Edit2: Ok, I'm rolling back to my backup, this didn't work out:

Code: Select all

Validating ldap configuration
connect: connection refused at bin/zmValidateLdap.pl line 89, <DATA> line 751.
Unknown Error: It should be impossible to reach this statement.


Broco
Posts: 8
Joined: Sat Sep 13, 2014 3:37 am

Re: Perl API version v5.14.0 of Socket does not match v5.18.0

Postby Broco » Fri Sep 16, 2016 3:09 pm

I still would like to know what I did wrong here, trying again this weekend.
User avatar
tonster
Zimbra Employee
Zimbra Employee
Posts: 309
Joined: Fri Feb 21, 2014 10:14 am
Location: Ypsilanti, MI
ZCS/ZD Version: Release 8.7.0_GA_1659.RHEL6_64_2016

Re: Perl API version v5.14.0 of Socket does not match v5.18.0

Postby tonster » Sun Sep 18, 2016 2:14 am

Broco wrote:I still would like to know what I did wrong here, trying again this weekend.


Update to ZCS 8.0.5 / Ubuntu 14, then upgrade to 8.7.0. Yes, that's the same version you're running, but you need to be running the binaries that work on the current OS before you can move forward.
Broco
Posts: 8
Joined: Sat Sep 13, 2014 3:37 am

Re: Perl API version v5.14.0 of Socket does not match v5.18.0

Postby Broco » Tue Sep 27, 2016 9:43 am

Yes, thank you, found that out by now. I was kind of misled by a documentation.

I upgraded to 8.6 though, I wait till 8.7 is out of beta for 16.04 and will then switch to 8.7 on 16.04.

Just for all others:
I upgraded to 8.6 on Ubuntu 12.04, then ugpradeded Ubuntu to 14.04, then installed 8.6 on 14.04 (first with the -s option).

It doesn't matter if you upgrade Ubuntu or Zimbra first, but you always have to reinstall the SAME Zimbra version you had on the old OS on the upgraded OS.
Caifo
Posts: 1
Joined: Wed Nov 14, 2018 7:02 am

Re: Perl API version v5.14.0 of Socket does not match v5.18.0

Postby Caifo » Wed Nov 14, 2018 7:15 am

Sorry for reviving an old post. I'm getting the same error. I'm migrating to a new hardware from Ubuntu 12/Zimbra 8.6 to Ubuntu 14.04/Zimbra 8.6. It happens when I try installing over the migrated files.

Is there any workaround?

I tried installing perl 5.14 manually, but it messes many dependencies.
phoenix
Ambassador
Ambassador
Posts: 25816
Joined: Fri Sep 12, 2014 9:56 pm

Re: Perl API version v5.14.0 of Socket does not match v5.18.0

Postby phoenix » Wed Nov 14, 2018 9:04 am

Caifo wrote:Sorry for reviving an old post,
Then don't do it again, you should start a new thread.

Caifo wrote: I'm getting the same error. I'm migrating to a new hardware from Ubuntu 12/Zimbra 8.6 to Ubuntu 14.04/Zimbra 8.6. It happens when I try installing over the migrated files.

Is there any workaround?
This has been covered many times in these forums, if you want an easy & painless move to a new server then install the current version of ZCS on the new server and use the ZeXtras Migration Tool to move everything to this new server.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 8 guests