[Solved] 8.8.7 upgrade or Install fails

Ask questions about your setup or get help installing ZCS server (ZD section below).
phoenix
Ambassador
Ambassador
Posts: 25347
Joined: Fri Sep 12, 2014 9:56 pm

[Solved] 8.8.7 upgrade or Install fails

Postby phoenix » Fri Mar 09, 2018 12:21 pm

I've just tried upgrading ZCS from 8.8.6 to 8.8.7 and it's failing with the following:


Code: Select all

                          zimbra-core-components is missing.                                    ERROR
                            zimbra-timezone-data will be installed.
                         zimbra-common-mbox-conf will be installed.
                   zimbra-common-mbox-conf-attrs will be installed.
                    zimbra-common-mbox-conf-msgs will be installed.
                  zimbra-common-mbox-conf-rights will be installed.
                           zimbra-common-mbox-db will be installed.
                         zimbra-common-mbox-docs will be installed.
                   zimbra-common-mbox-native-lib will be installed.
                                     zimbra-core will be installed.
                          zimbra-ldap-components is missing.                                    ERROR
                                     zimbra-ldap will be installed.
                                   zimbra-logger will be installed.
                           zimbra-mta-components is missing.                                    ERROR
                                      zimbra-mta will be installed.
                          zimbra-snmp-components is missing.                                    ERROR
                                     zimbra-snmp will be installed.
                         zimbra-store-components is missing.                                    ERROR
                       zimbra-jetty-distribution is missing.                                    ERROR
                                zimbra-mbox-conf will be installed.
                                 zimbra-mbox-war will be installed.
                             zimbra-mbox-service will be installed.
                                    zimbra-store will be installed.
                        zimbra-apache-components is missing.                                    ERROR
                                   zimbra-apache will be installed.
                         zimbra-spell-components is missing.                                    ERROR
                                    zimbra-spell will be installed.
                         zimbra-proxy-components is missing.                                    ERROR
                                zimbra-memcached is missing.                                    ERROR
                                    zimbra-proxy will be installed.

Unable to find missing packages in repository. System is not modified.


It makes no difference if this is an update or a clean install (with complete removal of the /opt/zimbra directory) it still fails with the same error. FWIW, I used the Zimbra repo and the required packages do exist in the repo and it's on a CentOS7 server fully updated to the current release. Is anyone else seeing this?


Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
User avatar
fs.schmidt
Advanced member
Advanced member
Posts: 87
Joined: Sat Sep 13, 2014 3:37 am
Location: Brazil
Contact:

Re: 8.8.7 upgrade or Install fails

Postby fs.schmidt » Fri Mar 09, 2018 1:05 pm

Hi,

Have you looked what was recorded in the "/tmp/install.log" file?

I know that probably you already did it, but I would check the md5 or download the Zimbra installation package again to check if there is something wrong with the downloaded file.

Kind regards.
phoenix
Ambassador
Ambassador
Posts: 25347
Joined: Fri Sep 12, 2014 9:56 pm

Re: 8.8.7 upgrade or Install fails

Postby phoenix » Fri Mar 09, 2018 1:30 pm

Hi Fabio

It finally worked and I I've posted my comments in the other thread.

For anyone that reads this thread, what worked for me was cleaning the yum cache and removing it with " "rm -rf /var/cache/yum" - the install subsequently worked.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
User avatar
fs.schmidt
Advanced member
Advanced member
Posts: 87
Joined: Sat Sep 13, 2014 3:37 am
Location: Brazil
Contact:

Re: [Solved] 8.8.7 upgrade or Install fails

Postby fs.schmidt » Fri Mar 09, 2018 1:32 pm

Hi,

Good to hear that it worked. Thanks for sharing the steps that you did to fix it.

Kind regards.
comradeTJH
Posts: 8
Joined: Tue Jul 04, 2017 12:39 pm

Re: [Solved] 8.8.7 upgrade or Install fails

Postby comradeTJH » Wed Mar 14, 2018 2:58 pm

Btw. a more general question about upgrading 8.8.6 to 8.8.6 - isn't it supposed to show up in the Zimbra Administraton-Page Update? It never seems to show any update there. Am I missing something?

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: Google [Bot] and 2 guests