Stability of version 8.8.x (upgrade)

Ask questions about your setup or get help installing ZCS server (ZD section below).
User avatar
Posts: 34
Joined: Sat Sep 13, 2014 3:18 am

Stability of version 8.8.x (upgrade)

Postby christianrj » Thu Jun 07, 2018 1:04 pm


We currently have OSE version 8.6 (patch 10), with 810 accounts and 13 domains in use. OS is Centos 6.9 (x64).

Browsing this forum, I found a handfull of threads about problems upgrading to version 8.8.x.

What is the current state of Zimbra 8.8 in terms of stability, especially when upgrading from 8.6? It's safe to upgrade or is better to wait? Version 8.6 is stable for us with no problems for a long time.

Thank you!

Posts: 1
Joined: Thu Jun 07, 2018 4:22 pm

Re: Stability of version 8.8.x (upgrade)

Postby cosit » Thu Jun 07, 2018 4:50 pm

We've successfully upgraded Zimbra 8.7.11_GA_2095 to Zimbra 8.8.8_GA_1703 in a test environment.

The upgrade was smooth and without issue however it's difficult to test stability or simulate our production environment. We did test a previous 8.8.x upgrade and ran into a few snags although I don't remember the details, was early this year.

I'd also be interested to hear from anyone running 8.8.8 in production.
User avatar
Advanced member
Advanced member
Posts: 184
Joined: Sat Sep 13, 2014 2:20 am
ZCS/ZD Version: 8.8.15_GA_3829.RHEL7_64_20190718141

Re: Stability of version 8.8.x (upgrade)

Postby axslingr » Thu Jun 07, 2018 8:39 pm

cosit wrote:I'd also be interested to hear from anyone running 8.8.8 in production.

I have a server in production running Release 8.8.8_GA_2009.RHEL7_64_20180322150747 RHEL7_64 NETWORK edition, Patch 8.8.8_P3. No issues.

Posts: 12
Joined: Wed Sep 14, 2016 3:54 pm
ZCS/ZD Version: 8.8.x

Re: Stability of version 8.8.x (upgrade)

Postby Zuser » Thu Jul 12, 2018 3:57 pm

We have recently updated from 8.6.0 patch 8 to 8.8.8 (2009) and then patch 6 (1728) (all Network Edition).

Following this we are experiencing a range of issues:
- random slowdowns are occurring, e.g. logging in on the web UI generates a SearchRequest with elapsed=8900 in mailbox.log, myslow.log shows SQL query which then takes around a second when executed by hand
- various parts of the web admin UI stopped working (e.g. global settings) due to zimbraNetworkModulesNGEnabled set to FALSE by default
- on a test server where the same update from 8.6.0 to 8.8.8 was done with slight differences (uninstalled old ZeXtras version before updating) the Zimbra Network link is missing from the web admin UI altogether so you can't enable/administer NG modules like backup or mobile
- end user web interface may not be compatible with all browsers, Firefox 56 would not load the left navigation pane (folders, preference items) for my own mailbox for a while, unknown what fixed it, also got report about connection error with Firefox 51
- the NG mobile module was not enabled by default which led to contacts going missing from e.g. iPhones (even those in their own Contacts folder)
- the old style backup admin UI is gone, i.e. you need to learn to use zmbackup/zmrestore on the shell if you want to restore legacy backups (i.e. every time a user accidentally deletes mail)
- on every service restart admins get a mail about backup not being initialized, even if you don't intend to use the NG backup module until you have ironed out all the other issues.. (NG backup is incompatible with legacy backup, requires additional parallel storage until old backups rotate out)
- "galsync's Contacts" shared contacts don't appear on either Android or iOS even though 8.8.8 is advertised as supporting shared (contact) folders
- the described option to edit syncing options for shared items is missing from the the end user web UI
- old meeting requests are randomly popping up as overdue for random users
- some users reported losing addresses from "Emailed contacts" in the Zimbra web UI though they can still be found via querying the database manually
- one end user swears high and low they could search the GAL on strings in the middle of names/mails with the older version, now can only search for strings beginning with what the user types (autocomplete does this too)
- random web UI changes like meeting location suggestions moving to a sub option confusing end users
- random new errors like someone not being able to send messages to a distribution list (Outlook generates popup with "unknown error"), although this might be down to old (8.6.0) ZCO
- no server side setting to disable ZCO popups for end users regarding finding a new version, those who try to update fail lacking admin privileges, end users confused (found out after the fact you can patch the ZCO msi)
- many thousands of "no valid authtoken present" lines in mailbox.log (batches of 24 each time, tried ... to_ZCS_8.6, no difference, logging out with Firefox/Chrome generates a batch of 67 or so lines like this within a few hundred milliseconds)
- seeing a load spike every 10 minutes, tried ... _100perCPU, seems to make little to no difference apart from the web admin UI increasingly missing statistics (was under the impression the changes don't disable stats collection, only compilation frequency/resolution, though /opt/zimbra/log/cpu.csv for example is still updated every 30 seconds) but after two days also reporting all services with a red cross (zmcontrol status reports everything running)
- one user couldn't delete a meeting that was part of a series (RMB option to edit either single or all of the series missing), selecting delete again got rid of it with no questions asked (without impacting rest of series)
- changes to zimbra user's crontab get silently overwritten on update, so if you increased log retention before the update your older than 8 days logs are now gone
- changes to postfix get silently overwritten, e.g. if you have defined custom transports they are silently gone
- if you used e.g. the /usr/bin/mailq command for external monitoring you have to manually relink it to its new location in /opt/zimbra/common/sbin/
- there are a whole bunch of dangling symlinks in /opt/zimbra again due to stuff moving around (common dir), some leftover conf files from the old structure and the like
- if you want to upgrade the OS, since there is no 8.6.0 for Ubuntu 16.04, you also need to upgrade Zimbra to 8.8.x (8.8.9 now). If you do update the OS from without updating 8.6.0 you are left with a non-working Zimbra installation that cannot be updated with the installer for 8.8.x/16.04 since that requires a working Zimbra installation itself
- when you are upgrading Ubuntu from 14.04 to 16.04 the Zimbra repo gets disabled, consequently a number of Zimbra packages get deinstalled during the OS upgrade unless you edit the apt config manually during the update itself
- if you edit the repo in mid install to prevent that, OS packages and Zimbra packages get updated in what amounts to a random order, introducing an element of luck to dependency resolution (perhaps this may also explain some of the differences we are seeing between the test and production server).

I'm probably forgetting some stuff but that's about one week's worth so far. At some point you don't have a choice though, 8.6.0 is supported until September and for example Ubuntu 14.04 until next April.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: MSN [Bot] and 5 guests