Zimbra 8.6 Single Server upgrade - upgrade failure

Ask questions about your setup or get help installing ZCS server (ZD section below).
Kevin.Greene
Posts: 2
Joined: Mon Aug 27, 2018 7:46 pm

Zimbra 8.6 Single Server upgrade - upgrade failure

Postby Kevin.Greene » Mon Aug 27, 2018 8:39 pm

Hello Group.

As Ubuntu 12.04 LTS is not supported any longer, we did an upgrade to 14.04 LTS.
We followed the directions to back the system up and then disable the mail server.
We did the Ubuntu upgrade and that went well.

We then tried to start the mail server and got the following.

zimbra@xray:~/zimbramon/lib$ zmcontrol start
Perl API version v5.14.0 of Socket does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 117.
Compilation failed in require at /usr/lib/perl/5.18/Sys/Syslog.pm line 10.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/Sys/Syslog.pm line 10.
Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 23.
BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 23.
Compilation failed in require at /opt/zimbra/bin/zmcontrol line 27.
BEGIN failed--compilation aborted at /opt/zimbra/bin/zmcontrol line 27.

We then downloaded the 8.6 version for 14.04 LTS and tried to install it. Again it would not allow us to do the update.

root@xray:/home/kgreene/zcs-8.6.0_GA_1153.UBUNTU14_64.20141215151116# ./install.sh

Operations logged to /tmp/install.log.4840
Checking for existing installation...
zimbra-ldap...FOUND zimbra-ldap-8.6.0.GA.1153.UBUNTU12.64
zimbra-logger...FOUND zimbra-logger-8.6.0.GA.1153.UBUNTU12.64
zimbra-mta...FOUND zimbra-mta-8.6.0.GA.1153.UBUNTU12.64
zimbra-dnscache...FOUND zimbra-dnscache-8.6.0.GA.1153.UBUNTU12.64
zimbra-snmp...FOUND zimbra-snmp-8.6.0.GA.1153.UBUNTU12.64
zimbra-store...FOUND zimbra-store-8.6.0.GA.1153.UBUNTU12.64
zimbra-apache...FOUND zimbra-apache-8.6.0.GA.1153.UBUNTU12.64
zimbra-spell...FOUND zimbra-spell-8.6.0.GA.1153.UBUNTU12.64
zimbra-convertd...NOT FOUND
zimbra-memcached...FOUND zimbra-memcached-8.6.0.GA.1153.UBUNTU12.64
zimbra-proxy...FOUND zimbra-proxy-8.6.0.GA.1153.UBUNTU12.64
zimbra-archiving...NOT FOUND
zimbra-core...FOUND zimbra-core-8.6.0.GA.1153.UBUNTU12.64
ZCS upgrade from 8.6.0 to 8.6.0 will be performed.
Validating ldap configuration
Perl API version v5.14.0 of Socket does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 117.
Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
Compilation failed in require at bin/zmValidateLdap.pl line 23.
BEGIN failed--compilation aborted at bin/zmValidateLdap.pl line 23.
Error: Unable to bind to the LDAP server as the root LDAP user.
This is required to upgrade.

I did look what Perl is actually running on the updated host and it is 5.18. I then did a search for the Perl Socket and found that the host had two different ones.

/opt/zimbra/zimbramon/lib/IO/Socket
/opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Socket
/opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/IO/Socket
/opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/Socket
/opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/IO/Socket
/usr/local/lib/perl/5.18.2/auto/Socket
/usr/share/perl/5.18.2/IO/Socket
/usr/lib/perl/5.18.2/auto/Socket
/usr/lib/perl/5.18.2/IO/Socket
/usr/bin/perl-5.14.0/ext/Socket
/usr/bin/perl-5.14.0/dist/IO/lib/IO/Socket

At this point, we are unsure what to do. Our thought is try to go back to 12.04 LTS.

To get mail working, we elevated our test platform to production use so people could send & receive mail. However, we would like the old one running so we can transfer all the mail across from the old platform to the new platform (using a variety of tools available). This is pretty important to us.

Any help would be great!!!!!!!!

We really need help on this.

Thanks.

Kevin


axslingr
Advanced member
Advanced member
Posts: 76
Joined: Sat Sep 13, 2014 2:20 am
ZCS/ZD Version: Release 8.8.9.GA.3019.UBUNTU14.64

Re: Zimbra 8.6 Single Server upgrade - upgrade failure

Postby axslingr » Tue Aug 28, 2018 12:24 am

At this point, I'd backup /opt/zimbra and any other data needed, and do a fresh install of Ubuntu 14.04. Be sure the hostname and ip address remain the same.

After Ubuntu is installed and /opt/zimbra is restored, rename /opt/zimbra to /opt/zimbra.live and run the Zimbra 8.6 installer for 14.04 with the -s option(./install.sh -s)

Once the installer is finished, delete the resulting /opt/zimbra directory and rename /opt/zimbra.live to /opt/zimbra

Run the installer again in normal mode and finish. Should get you back up and running in no time.

Lance
Kevin.Greene
Posts: 2
Joined: Mon Aug 27, 2018 7:46 pm

Re: Zimbra 8.6 Single Server upgrade - upgrade failure

Postby Kevin.Greene » Tue Aug 28, 2018 12:52 am

axslingr wrote:At this point, I'd backup /opt/zimbra and any other data needed, and do a fresh install of Ubuntu 14.04. Be sure the hostname and ip address remain the same.

After Ubuntu is installed and /opt/zimbra is restored, rename /opt/zimbra to /opt/zimbra.live and run the Zimbra 8.6 installer for 14.04 with the -s option(./install.sh -s)

Once the installer is finished, delete the resulting /opt/zimbra directory and rename /opt/zimbra.live to /opt/zimbra

Run the installer again in normal mode and finish. Should get you back up and running in no time.

Lance


Thanks.
I just started a new backup per your instructions. Not too bad. About 55 GB of /opt/zimba.
Might take 2-4 hours to get it back to life.
What does the -s often do? I can try to look on Google for it.
Thanks again.

Kevin
phoenix
Ambassador
Ambassador
Posts: 25703
Joined: Fri Sep 12, 2014 9:56 pm

Re: Zimbra 8.6 Single Server upgrade - upgrade failure

Postby phoenix » Tue Aug 28, 2018 5:32 am

Kevin.Greene wrote:As Ubuntu 12.04 LTS is not supported any longer, we did an upgrade to 14.04 LTS
That, in my book, is always a big risk as you never know what changes in a major version upgrade will do to your system and should never be done. FWIW, you should build a new server, install the latest release of your chosen distribution and install ZCS then move your ZCS install to the new server using the ZeXtras Migration Tool. It works, it's easy, it's free to use - what else would you need? :)

Kevin.Greene wrote:What does the -s often do? I can try to look on Google for it.
You could also search the forums for that, it's been covered many times. For info:

Code: Select all

 ./install.sh --help
./install.sh [-r <dir> -l <file> -a <file> -u -s -c type -x -h] [defaultsfile]

-h|--help               Usage
-l|--license <file>     License file to install.
-a|--activation <file>  License activation file to install. [Upgrades only]
-r|--restore <dir>      Restore contents of <dir> to localconfig
-s|--softwareonly       Software only installation.
-u|--uninstall          Uninstall ZCS
-x|--skipspacecheck     Skip filesystem capacity checks.
--beta-support          Allows installer to upgrade Network Edition Betas.
--platform-override     Allows installer to continue on an unknown OS.
--skip-activation-check Allows installer to continue if license activation checks fail.
--skip-upgrade-check    Allows installer to skip upgrade validation checks.
--force-upgrade         Force upgrade to be set to YES. Used if there is package installation failure for remote packages.
[defaultsfile]          File containing default install values.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 13 guests