Page 1 of 1

Zimbra Live Sync Error

Posted: Wed Apr 10, 2019 1:41 pm
by tarlan
Hi Dear members,

We had Zimbra version 8.8.10 until yesterday. All was OK except live sync. When we used live sync we were faced following error.

Exception in thread "main" java.lang.NoClassDefFoundError: graphql/GraphQLError
at com.zimbra.graphql.resources.GQLExtension.init(GQLExtension.java:49)
at com.zimbra.cs.extension.ExtensionUtil.initAllMatching(ExtensionUtil.java:128)
at com.zimbra.cs.extension.ExtensionUtil.initAll(ExtensionUtil.java:154)
at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:266)
at com.zimbra.cs.util.Zimbra.startupCLI(Zimbra.java:184)
at com.zimbra.cs.redolog.util.PlaybackUtil.setup(PlaybackUtil.java:394)
at com.zimbra.cs.redolog.util.PlaybackUtil.main(PlaybackUtil.java:369)
Caused by: java.lang.ClassNotFoundException: graphql.GraphQLError
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)

So, we decided upgrade Zimbra to 8.8.12 and upgraded all sucessfully. But problem with live sync not solved. We faced with another error when execute live sync script:

Djava.ext.dirs=/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home/lib/ext:/opt/zimbra/mailboxd/lib:/opt/zimbra/mailboxd/common/lib:/opt/zimbra/lib/jars:/opt/zimbra/lib/ext-common:/opt/zimbra/lib/ext/onlyoffice:/opt/zimbra/lib/ext/com_zimbra_bulkprovision:/opt/zimbra/lib/ext/com_zimbra_cert_manager:/opt/zimbra/lib/ext/com_zimbra_clientuploader:/opt/zimbra/lib/ext/com_zimbra_ssdb_ephemeral_store:/opt/zimbra/lib/ext/clamscanner:/opt/zimbra/lib/ext/mitel:/opt/zimbra/lib/ext/nginx-lookup:/opt/zimbra/lib/ext/openidconsumer:/opt/zimbra/lib/ext/twofactorauth:/opt/zimbra/lib/ext/zimbra-freebusy:/opt/zimbra/lib/ext/zimbra-license:/opt/zimbra/lib/ext/zimbraadminversioncheck:/opt/zimbra/lib/ext/zimbraldaputils:/opt/zimbra/lib/ext/zm-gql:/opt/zimbra/lib/ext/zm-oauth-social:/opt/zimbra/lib/ext/openchat is not supported. Use -classpath instead.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

We increased java heap size to 5120 but nothing same error. Out environment redhat7.6 , RAM 16G

Has anyone faced this problem?
Thanks

Re: Zimbra Live Sync Error

Posted: Thu Apr 11, 2019 1:37 pm
by andrey.ivanov
Hi, concerning the 8.8.10 exception i may have a fix for you. Actually we have the same exception if we run the zmplayredo utility to replay logs (we use it for our disaster recovery plan with snapshots of the disk). Zimbra support has given us a fix to avoid the exception (java.lang.NoClassDefFoundError: graphql/GraphQLError) - you need simply to remove the contents of a folder :

Code: Select all

mv /opt/zimbra/lib/ext/zm-gql /tmp/backup/

It fixes the zmplayredo problem and i think it will fix your live sync exception in 8.8.10. According to Zimbra, GraphQL library is an experimental feature they have added in some tools but it is not yet production-ready.

Re: Zimbra Live Sync Error

Posted: Wed May 08, 2019 10:52 pm
by sempiterna
Unfortunately i'm also facing a zmplayredo error after upgrading to 8.8.12.

The log shows:

Wed May 8 23:40:32 CEST 2019 :Replaying redologs...
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
Wed May 8 23:40:32 CEST 2019 :Replay of redolog failed
Wed May 8 23:40:32 CEST 2019 :Replaying redologs done


I already removed the zm-gql directory, but the error persisted. Then I changed the live_syncd script so that errors are not suppressed, after which this shows up:

Thu May 9 00:42:51 CEST 2019 :Replaying redologs...
mailboxd is not running.
-Djava.ext.dirs=/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home/lib/ext:/opt/zimbra/mailboxd/lib:/opt/zimbra/mailboxd/common/lib:/opt/zimbra/lib/jars:/opt/zimbra/lib/ext-common:/opt/zimbra/lib/ext/zimbra-freebusy:/opt/zimbra/lib/ext/zextras:/opt/zimbra/lib/ext/DocConvert:/opt/zimbra/lib/ext/clamscanner:/opt/zimbra/lib/ext/OCS:/opt/zimbra/lib/ext/accountHistory:/opt/zimbra/lib/ext/openidconsumer:/opt/zimbra/lib/ext/zimbraldaputils:/opt/zimbra/lib/ext/ownCloud:/opt/zimbra/lib/ext/zm-oauth-social:/opt/zimbra/lib/ext/nginx-lookup:/opt/zimbra/lib/ext/com_zimbra_clientuploader:/opt/zimbra/lib/ext/openchat:/opt/zimbra/lib/ext/com_zimbra_cert_manager:/opt/zimbra/lib/ext/zimbraadminversioncheck:/opt/zimbra/lib/ext/com_zimbra_ssdb_ephemeral_store:/opt/zimbra/lib/ext/AccountHistoryAdmin:/opt/zimbra/lib/ext/com_zimbra_bulkprovision:/opt/zimbra/lib/ext/zimbra-license:/opt/zimbra/lib/ext/mitel:/opt/zimbra/lib/ext/twofactorauth is not supported. Use -classpath instead.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
Thu May 9 00:42:52 CEST 2019 :Replay of redolog failed
Thu May 9 00:42:52 CEST 2019 :Replaying redologs done


I then proceeded to remove more and more directories, but it persists in complaining that something is not supported. I am not a java programmer, so I don't quite know how to interprete these errors. What could be causing this?

Re: Zimbra Live Sync Error

Posted: Thu May 16, 2019 10:55 am
by andrey.ivanov
Yes, zmplayredo worked in 8.8.10 with removing graphql folder but it does not work in 8.8.12 because they changed the jvm version from java 8 to java 11. I've made a ticket (Support Case 00834458) :

Code: Select all

Problem:

Since the upgrade to 8.8.12 (from 8.8.10_P8) zmplayredo does not start. Apparently it is the consequence of migration from java 8 to java 11. The error message seems to say that Java11 does not understand "-Djava.ext.dirs" switch used in zmplayredo and it wants the code to "Use -classpath instead."

Our backup and restore strategy is based on virtual machine snapshots and replaying redo logs, so zmplayredo is critical for our disaster recovery plan to work.

Action:

[zimbra@zimbra-dev ~]$ ~/bin/zmplayredo
mailboxd is not running.
-Djava.ext.dirs=/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home/lib/ext:/opt/zimbra/mailboxd/lib:/opt/zimbra/mailboxd/common/lib:/opt/zimbra/lib/jars:/opt/zimbra/lib/ext-common:/opt/zimbra/lib/ext/com_zimbra_cert_manager:/opt/zimbra/lib/ext/zimbraadminversioncheck:/opt/zimbra/lib/ext/nginx-lookup:/opt/zimbra/lib/ext/com_zimbra_xmbxsearch:/opt/zimbra/lib/ext/twofactorauth:/opt/zimbra/lib/ext/smime:/opt/zimbra/lib/ext/mitel:/opt/zimbra/lib/ext/com_zimbra_ssdb_ephemeral_store:/opt/zimbra/lib/ext/zm-oauth-social:/opt/zimbra/lib/ext/voice:/opt/zimbra/lib/ext/zm-gql:/opt/zimbra/lib/ext/clamscanner:/opt/zimbra/lib/ext/zimbra-license:/opt/zimbra/lib/ext/zimbra-archive:/opt/zimbra/lib/ext/com_zimbra_oo:/opt/zimbra/lib/ext/backup:/opt/zimbra/lib/ext/com_zimbra_bulkprovision:/opt/zimbra/lib/ext/zimbrahsm:/opt/zimbra/lib/ext/com_zimbra_clientuploader:/opt/zimbra/lib/ext/zimbraldaputils:/opt/zimbra/lib/ext/network-modules-ng:/opt/zimbra/lib/ext/zimbrasync:/opt/zimbra/lib/ext/network:/opt/zimbra/lib/ext/cisco:/opt/zimbra/lib/ext/convertd:/opt/zimbra/lib/ext/openidconsumer:/opt/zimbra/lib/ext/zimbra-freebusy:/opt/zimbra/lib/ext/zimbraews is not supported. Use -classpath instead.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.


At first they tried to say they do not support legacy backup tools but i explained that zmplayredo is not a legacy backup tool but a utility to replay redo logs. They have said that they have submitted my concern to the dev team but there are no more updates on the ticket since May 6th.

Re: Zimbra Live Sync Error

Posted: Sat May 18, 2019 6:17 pm
by sempiterna
Thank you for the clarification. This means it's not something in my specific installation.

Zmplayredo is part of zimbra, so i wouldnt see why this would be a legacy backup tool. There's nothing in the installation notes about it either. I think it may have been something that's been unintentionally missed by the dev team when they upgraded the jvm.

I hope they fix it, as I can't use my "hot standby" zimbra server now in case something happens.

Re: Zimbra Live Sync Error

Posted: Mon Jun 17, 2019 10:46 am
by andrey.ivanov
I have finally received a solution to make zmplayredo work on Zimbra v8.8.12_P* from Zimbra support.

Here is the procedure :

Extract attached "jars.zip" attached to this message and follow below steps :

1. mv /opt/zimbra/lib/ext/zm-gql /tmp/backup/
2. Copy and overwrite with attached zmplayredo to /opt/zimbra/bin/ [fixed/integrated in 8.8.12_P3]
3. Copy attached 'resolver-20050927.jar' to /opt/zimbra/lib/jars [fixed/integrated in 8.8.12_P3]
4. Copy attached 'saaj-impl-1.5.1.jar' to /opt/zimbra/lib/ext-common [still NOT fixed/integrated in 8.8.12_P3]

After these actions zmplayredo works in 8.8.12_P2 & P3 with some warnings.

Re: Zimbra Live Sync Error

Posted: Tue Jul 02, 2019 2:33 pm
by alogicking
The jars.zip file is not available for download. Can you please provide it again.

I am having the same issue.

Thanks in advance.