Relaying mail from Postfix servers via Zimbra

Ask questions about your setup or get help installing ZCS server (ZD section below).
Hussain
Posts: 6
Joined: Fri May 25, 2018 1:07 pm

Relaying mail from Postfix servers via Zimbra

Postby Hussain » Sat May 18, 2019 6:39 am

I have setup Zimbra 8 on a CentOS 7 server. Configured this & that and everything is working fine. Normal users can send and receive via webmail and Outlook.

There are other servers for the same domain (application1, application2, etc.) from which I need to send cron job emails.

I cannot send outgoing emails directly from those servers because ISP hasn't added PTR records for them so email get rejected from GMail, HotMail, et al. So I am trying to relay them via the Zimbra server.

I added the IP's of the other servers in Zimbra's mynetworks using zmprov ms command.

Then added relayhost on appserver1.mydomain.com's /etc/postfix/main.cf. Enabled SMTP authentication. Added credentials to /etc/postfix/sasl_passwd

Sending email from root user gets rejected with a FROM error. I created an account called 'relay' on zimbra. From appserver1, I used: mail -r relay user@gmail.com, etc...

Still getting the message on appserver1:

May 18 11:20:54 server1 postfix/qmgr[10241]: 2CD754027FC93: from=<relay@mydomain.com>, size=485, nrcpt=1 (queue active)

May 18 11:20:56 server1 postfix/smtp[25191]: 2CD754027FC93: to=<user@gmail.com>, relay=zimbra.mydomain.com[123.45.12.99]:587, delay=5274, delays=5272/0.04/2.1/0.19, dsn=4.3.0, status=deferred (host zimbra.mydomain.com[123.45.12.99] said: 451 4.3.0 Temporary lookup error (in reply to MAIL FROM command))

The FROM address is the mailbox I created, so what am I doing wrong?


Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 8 guests