Upgrade from 8.8.9 to 8.8.12 - clarification needed

Ask questions about your setup or get help installing ZCS server (ZD section below).
shodan
Posts: 6
Joined: Wed Feb 21, 2018 8:09 am

Upgrade from 8.8.9 to 8.8.12 - clarification needed

Postby shodan » Thu Jul 18, 2019 9:51 am

Hi all,
I need some clarification on the correct update procedure from Zimbra Community Edition 8.8.8 to 8.8.12.

From my understanding, the supported update steps are the ones listed on https://zimbra.github.io/installguides/latest/upgrade.html, which basically revolves around running "install.sh"

However, I seem to remember that Zimbra now has its own repository for integrated package updates - ie by the virtue of running "yum update"
This seems to be confirmed by the notes I can read here https://www.zimbra.com/downloads/zimbra-collaboration-open-source/archives/ and by the instructions found here https://wiki.zimbra.com/wiki/Zimbra_Releases/8.8.11/P5#installation

So, I have some questions:
- are repo update only available/supported for *patch* installation?
- can you confirm that the correct update path from 8.8.8 to 8.8.12 is the one using "install.sh"?

Thanks.


shodan
Posts: 6
Joined: Wed Feb 21, 2018 8:09 am

Re: Upgrade from 8.8.9 to 8.8.12 - clarification needed

Postby shodan » Fri Jul 19, 2019 7:21 pm

Well, after some tests, I can reply myself and share tha reply with the community.
A "yum update" on, say, Zimbra Community 8.8.8 brings it to the latest patch level, while a full "install.sh" is needed to upgrade to, say, 8.8.12.
Maybe this is common knowledge, but I feel as sharing it can be useful.
Thanks.
User avatar
gabrieles
Advanced member
Advanced member
Posts: 99
Joined: Tue Feb 14, 2017 9:40 am

Re: Upgrade from 8.8.9 to 8.8.12 - clarification needed

Postby gabrieles » Mon Jul 22, 2019 10:59 am

shodan wrote:- are repo update only available/supported for *patch* installation?

technically no, the repo system has been developed to upgrade vital packages with frequent release.
LIke, for example, the clamav issues on 8.6: if you install zcs 8.6 you will have clamav 0.98.4. Clamav releases signatures compatible only with the two latest versions. If you want a newer/compatible version of clamav you need to upgrade the entire ZCS.
With the repo system you will upgrade only the relative package: zimbra-clamav-0.99.4-1zimbra8.7b1.el7.x86_64

shodan wrote:- can you confirm that the correct update path from 8.8.8 to 8.8.12 is the one using "install.sh"?

yes
shodan
Posts: 6
Joined: Wed Feb 21, 2018 8:09 am

Re: Upgrade from 8.8.9 to 8.8.12 - clarification needed

Postby shodan » Sat Jul 27, 2019 7:56 am

@gabrieles excellent, thank you very much!

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 10 guests