Unable to update to 8.8.12p5 on Ubuntu 14

Ask questions about your setup or get help installing ZCS server (ZD section below).
jered
Posts: 19
Joined: Sat Sep 13, 2014 12:35 am

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Postby jered » Mon Sep 09, 2019 4:57 pm

This seems to have finally been fixed.


tmowbray
Posts: 9
Joined: Tue Sep 30, 2014 8:42 am

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Postby tmowbray » Thu Sep 12, 2019 1:21 am

adgi wrote:Hello,

In CentOS 7.x, I removed existing package zimbra-timezone-data by:
rpm -e zimbra-timezone-data --nodeps

Next time, I install from downloaded repository zcs-8.8.15_GA_3829.RHEL7_64.20190718141144 package zimbra-timezone-data by
cd zcs-8.8.15_GA_3829.RHEL7_64.20190718141144/packages/
rpm -ivh zimbra-timezone-data-1.0.1+1562147505-1.r7.x86_64.rpm

Next time: ./install.sh


But i think it is not supported.


Thanks -- Having this same issue on CentOS 6, also going from 8.8.12 to 8.8.15. Had to abort to roll-back to a pre-upgrade snapshot. I will test this solution and try again...but (sigh) will have to wait for another maintenance window as I did not find this solution in time.
KevinDelatorre89
Posts: 1
Joined: Fri Sep 13, 2019 11:51 am

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Postby KevinDelatorre89 » Fri Sep 13, 2019 11:55 am

This is the same problem I read. However I installed another version instead of Ubuntu 14. Then there was no problem. You can also try installing another version of Ubuntu. Thanks.
User avatar
L. Mark Stone
Elite member
Elite member
Posts: 2007
Joined: Wed Oct 09, 2013 11:35 am
Location: Portland, Maine
ZCS/ZD Version: 8.8.12 Network Edition
Contact:

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Postby L. Mark Stone » Fri Sep 13, 2019 5:18 pm

I had this same problem last night when updating a customer's system from 8.8.12 to 8.8.15, on Ubuntu 16.

The upgrade to 8.8.15 completed OK, but the installer did not update 8.8.15 to Patch 1 level. Zimbra was running fine, but zmcontrol -v reported 8.8.15 only.

I solved this first by looking at the Release Notes for 8.8.15 Patch 1 to see what version of the timezone-data package is expected to be installed. I then manually installed that version of the package from the repos (apt install package=version).

After that, I ran apt-get update && apt-get dist-upgrade and got all of the Patch1 and related packages. zmcontrol restart and then zmcontrol -v reported the server was at 8.8.15 P1.

Hope that helps,
Mark
___________________________________
L. Mark Stone
Mission Critical Email - Zimbra VAR/BSP/Training Partner https://www.missioncriticalemail.com/
Zeta Alliance http://www.zetalliance.org/
axslingr
Advanced member
Advanced member
Posts: 169
Joined: Sat Sep 13, 2014 2:20 am
ZCS/ZD Version: Release 8.8.11.GA.3737.UBUNTU16.64

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Postby axslingr » Fri Sep 13, 2019 6:42 pm

I ended up opening a support ticket on this. Response is below. The workaround did work for me.



We have a know bug to upgrade 8.8.12.p5 to 8.8..15.

The workaround is:

This can only happen when upgrade from 8.8.12.p5 to 8.8..15 .

After untar the zcs-8.8.15-xxxx.tgz delete the zimbra-timezone-data rpm/deb file from

rm -f packages/zimbra-timezone-data*.*

rerun the installer.
Labsy
Outstanding Member
Outstanding Member
Posts: 377
Joined: Sat Sep 13, 2014 12:52 am

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Postby Labsy » Sun Sep 22, 2019 4:54 pm

axslingr wrote:I ended up opening a support ticket on this. Response is below. The workaround did work for me.
We have a know bug to upgrade 8.8.12.p5 to 8.8..15.
The workaround is:
This can only happen when upgrade from 8.8.12.p5 to 8.8..15 .
After untar the zcs-8.8.15-xxxx.tgz delete the zimbra-timezone-data rpm/deb file from
rm -f packages/zimbra-timezone-data*.*
rerun the installer.
Thank you, I tried this, but I faced the error after 3nd step of re-ran installer:

Code: Select all

Do you agree with the terms of the software license agreement? [N] y
Checking current number of databases...

Do you want to verify message store database integrity? [Y]
Verifying integrity of message store databases.  This may take a while.
mysqld is alive
No errors found

Use Zimbra's package repository [Y]
Configuring package repository
ERROR: Unable to install packages via apt-get
Please fix system to allow normal package installation before proceeding

ZCS 8.8.15 runs fine, but I cannot run apt-get update, because of unmet dependency. Looks like this is preventing zimbra installer to run.

Code: Select all

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 zimbra-patch : Depends: zimbra-timezone-data (>= 1.0.1+1565604774) but 1.0.1+1562147505-1.u16 is installed
E: Unmet dependencies. Try using -f.
So, instead of going the suggested way of removing zimbra-timezone-data package from installer, I run apt-get -f install to fix this one unmet dependancy:

Code: Select all

apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  zimbra-timezone-data
The following packages will be upgraded:
  zimbra-timezone-data
1 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.
Need to get 0 B/48.4 kB of archives.
After this operation, 2,048 B disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 129907 files and directories currently installed.)
Preparing to unpack .../zimbra-timezone-data_1.0.1+1565604774-1.u16_amd64.deb ...
Unpacking zimbra-timezone-data (1.0.1+1565604774-1.u16) over (1.0.1+1562147505-1.u16) ...
Setting up zimbra-timezone-data (1.0.1+1565604774-1.u16) ...
Then apt update and install the latest patch:

Code: Select all

apt-get update
apt-get upgrade
The following packages have been kept back:
  linux-generic linux-headers-generic linux-image-generic open-vm-tools ubuntu-minimal
The following packages will be upgraded:
  zimbra-common-core-jar zimbra-mbox-admin-console-war zimbra-mbox-webclient-war zimbra-mta-patch zimbra-patch zimbra-proxy-patch
6 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Need to get 44.6 MB of archives.
After this operation, 195 kB of additional disk space will be used.
Do you want to continue? [Y/n]

At the end I switched to zimbra user and restarted services:

Code: Select all

zmcontrol restart

Now I have the latest patch:

Code: Select all

zmcontrol -v
Release 8.8.15.GA.3829.UBUNTU16.64 UBUNTU16_64 FOSS edition, Patch 8.8.15_P1.

:)

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 6 guests