Page 1 of 2

Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Thu Aug 29, 2019 11:26 pm
by jered
Has anyone successfully installed this patch? There seems to be a repo error:

Code: Select all

The following packages will be upgraded:
  ubuntu-advantage-tools zimbra-common-core-jar zimbra-mbox-webclient-war
  zimbra-patch zimbra-timezone-data
5 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 63.1 kB/34.8 MB of archives.
After this operation, 3,072 B of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main ubuntu-advantage-tools all 10ubuntu0.14.04.4 [14.8 kB]
Get:2 https://repo.zimbra.com/apt/8812/ trusty/zimbra zimbra-timezone-data amd64 1.0.1+1565604774-1.u14 [48.3 kB]
Err https://repo.zimbra.com/apt/8812/ trusty/zimbra zimbra-timezone-data amd64 1.0.1+1565604774-1.u14
  HttpError404
Fetched 14.8 kB in 0s (64.2 kB/s)
E: Failed to fetch https://repo.zimbra.com/apt/8812/pool/zimbra/z/zimbra-timezone-data/zimbra-timezone-data_1.0.1+1565604774-1.u14_amd64.deb  HttpError404

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Fri Aug 30, 2019 5:15 am
by phoenix
Yes, I've installed it OK but I use CentOS & DNF and that had the same problem as you've shown, I switched to using yum and that installed the patch without problems.

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Fri Aug 30, 2019 9:53 am
by sandro
Same problem for me.
No solutions found yet.

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Fri Aug 30, 2019 10:25 am
by mollami
hi,

also my problem
after upgrade to 8.8.15.GA.3829.UBUNTU14.64 :

****************************
The following packages will be upgraded:
zimbra-patch zimbra-timezone-data
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 48.3 kB/61.1 kB of archives.
After this operation, 103 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 https://repo.zimbra.com/apt/8815/ trusty/zimbra zimbra-timezone-data amd64 1.0.1+1565596046-1.u14 [48.3 kB]
Err https://repo.zimbra.com/apt/8815/ trusty/zimbra zimbra-timezone-data amd64 1.0.1+1565596046-1.u14
HttpError404
E: Failed to fetch https://repo.zimbra.com/apt/8815/pool/z ... _amd64.deb HttpError404

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
***************************

zimbra.list :
deb [arch=amd64] https://repo.zimbra.com/apt/87 trusty zimbra
deb [arch=amd64] https://repo.zimbra.com/apt/8815 trusty zimbra
deb-src [arch=amd64] https://repo.zimbra.com/apt/87 trusty zimbra

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Sat Aug 31, 2019 7:56 am
by mollami
[ Solved ] for me,

this morning I tried another "apt-get update" and the upgrade completed fine

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Sat Aug 31, 2019 2:11 pm
by jered
mollami wrote:[ Solved ] for me,

this morning I tried another "apt-get update" and the upgrade completed fine


Interesting! I just tried again and had the same (broken) results.

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Sun Sep 01, 2019 12:55 pm
by keynet
sandro wrote:Same problem for me.
No solutions found yet.

And for me on Centos 7 during upgrade from latest 8.8.12 to 8.8.15

error: Failed dependencies:
zimbra-timezone-data >= 1.0.1+1565604774 is needed by (installed) zimbra-patch-8.8.12.1566472978.p5-1.r7.x86_64

Package mgt reports that 1.0.1+1565604774-1.r7 is installed

Strange in that 8.8.12 is being removed to go to 8.8.15, never had a problem with Zimbra upgrades before.
What to do ?

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Sun Sep 01, 2019 6:48 pm
by adgi
Hello,

In CentOS 7.x, I removed existing package zimbra-timezone-data by:
rpm -e zimbra-timezone-data --nodeps

Next time, I install from downloaded repository zcs-8.8.15_GA_3829.RHEL7_64.20190718141144 package zimbra-timezone-data by
cd zcs-8.8.15_GA_3829.RHEL7_64.20190718141144/packages/
rpm -ivh zimbra-timezone-data-1.0.1+1562147505-1.r7.x86_64.rpm

Next time: ./install.sh


But i think it is not supported.

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Mon Sep 02, 2019 2:47 am
by axslingr
Same here with Centos 7 and 8.8.12 > 8.8.15 upgrade on a test server. Had to use the --force-upgrade option to get through it, but it did without any issues.

Re: Unable to update to 8.8.12p5 on Ubuntu 14

Posted: Mon Sep 02, 2019 1:29 pm
by axslingr
Same upgrade on Ubuntu 16.04 works as expected.