Zimbra 8.7 autodiscover

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
josip.macek
Posts: 11
Joined: Wed Aug 24, 2016 1:27 pm

Zimbra 8.7 autodiscover

Postby josip.macek » Wed Aug 24, 2016 2:12 pm

Hello,
I freshly installed Zimbra 8.7. + Z-push for activesync with (http://vwiki.co.uk/Z-Push_v2_with_Zimbra ) this procedure.
Now i have problems with policyd but that is on other post.

I want to setup autodiscover.
On my dns i have setup SRV record, A record for autodiscover.expamle.domain and for _autodiscover._tcp.example.domain and records are pointing to my server.

In httpd config i made Alias for /Autodiscover/Autodiscover.xml point to /var/www/html/z-push/autodiscover/autodiscover.php
But Microsoft tool for checking autodoscover cant complete testing.
Now i wait for certificate because it maybe dont work because of that. ( no mather that i selected that Ignore trust of SSL )

Firewalld is offline.

Any idea. ?

Tnx in advance for help and effort.


User avatar
tonster
Zimbra Employee
Zimbra Employee
Posts: 312
Joined: Fri Feb 21, 2014 10:14 am
Location: Ypsilanti, MI
ZCS/ZD Version: Release 8.7.0_GA_1659.RHEL6_64_2016

Re: Zimbra 8.7 autodiscover

Postby tonster » Wed Aug 24, 2016 4:22 pm

I would suggest contacting the authors of zpush for assistance.
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 926
Joined: Sat Sep 13, 2014 12:47 am

Re: Zimbra 8.7 autodiscover

Postby liverpoolfcfan » Wed Aug 24, 2016 7:14 pm

I replied earlier but I guess my reply got quarantined

Do you have a publicly available DNS entry for autodiscover.yourdomain.com pointing to your z-push server's public IP Address?

Did you configure the separate autodiscover config.php file to match your needs?
You need to set
define('TIMEZONE', 'Europe/London'); // Your timezone
define('SERVERURL', 'https://z-push.yourdomain.com/Microsoft-Server-ActiveSync');
define('USE_FULLEMAIL_FOR_LOGIN', true); // True/False as required
and most of course
define('BACKEND_PROVIDER', 'BackendZimbra');

I have found that different devices use capitalized and uncapitalized (A|a)utodiscover so it is best to allow for matching all cases. I use

Code: Select all

    AliasMatch (?i)/Autodiscover/Autodiscover.xml "/var/www/html/z-push/src/autodiscover/autodiscover.php"


and then for the Location definition use a similar match

Code: Select all

   <LocationMatch "/(A|a)utodiscover/">
    .... your settings ...
   </LocationMatch>


I am pretty sure the Microsoft tester will only work with a public SSL certificate - so go and generate one with letsencrypt

I also have a vague notion that it may be a requirement that the directory location for Autodiscover has Basic Auth on it where you need to login with your zimbra credentials.
josip.macek
Posts: 11
Joined: Wed Aug 24, 2016 1:27 pm

Re: Zimbra 8.7 autodiscover

Postby josip.macek » Thu Aug 25, 2016 8:51 am

I have managed that. I have found manual for that.
Because problems of policyd and lack of time for testing i will install new zimbra 8.5 (((( because i have another zimbra server 8.5 version and on that i have no problem with policyd )))) version and i will re-try autodiscovery and post back with entire configuration and test results.

Tnx
josip.macek
Posts: 11
Joined: Wed Aug 24, 2016 1:27 pm

Re: Zimbra 8.7 autodiscover

Postby josip.macek » Wed Sep 21, 2016 6:20 am

Hello,

i managed to have "testing ok" on Microsoft test site (https://testconnectivity.microsoft.com/).
But discovery do not work...
In my zimbra logs for autodiscovery i have no errors. I will keep you posted if i manage to make it work with full post from step one to the last.
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 926
Joined: Sat Sep 13, 2014 12:47 am

Re: Zimbra 8.7 autodiscover

Postby liverpoolfcfan » Wed Sep 21, 2016 9:59 am

Do you use a public SSL certificate? Or a self-signed one?

What device type are you testing with?

I am petty sure autodiscovery will not succeed with a self-signed certificate.

Are you seeing requests to Apache for Autodiscovery? If the requests are seen and handled - then either your configuration settings in your config.php file are not right, or the certificate is not good, or the device is not handling it properly.

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 9 guests