Page 1 of 2

Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Wed Nov 23, 2016 1:10 am
by NetCircle
The subject pretty much says it all. When 'zmcontrol shutdown' is run, zmconfigd stops, it moves on to 'Stopping zimlet webapp...' which eventually fails.

I have a daily cron job that shuts zimbra down, rsyncs the zimbra root to another location, then restarts zimbra. It has been running flawlessly for years.

The server and nearly all its users are 14 hours ahead of me and when I tried connecting today I got an error that the server wasn't responding. I realized it was within the usual backup timeframe so I connected via ssh to check its progress. I found the backup was not running and there were a mixture of some services running, others not. I checked my cron job log and from the time stamps found the zimbra shutdown had been running for nearly 15 minutes but had not completed stopping zimbra. I needed to get it back up and online so I ran a zmcontrol start and all returned to normal. All services were up, I could logon through the web interface and send and receive mail.

I ran zmfixperms, then tried running 'zmcontrol stop' again. Same result. It hung on 'Stopping zimlet webapp.' After several minutes, I interrupted through the stop command, ran 'zmcontrol start,' and verified all services were running normally again.

The host O/S is CentOS release 6.8 with Zimbra Release 8.7.0_GA_1659.RHEL6_64_20160628192545 RHEL6_64 FOSS edition. The most recent upgrade was from 8.07 to 8.70 in early October. I find nothing of significance in either Zimbra.log or mailbox.log.

We have run Zimbra since early release 5 with very few previous problems but I have had to suspend my cron job pending resolution of this problem. There are other nagging problems with this release but having a production system that cannot be shutdown smoothly makes me very uncomfortable.

Re: Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Wed Dec 21, 2016 9:28 am
by bhwong
I notice zimlet webapp take the longest to stop. Potential issue.

Re: Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Sat Feb 25, 2017 10:00 am
by andreaswolske
Same issue here with RHEL 6.8 ZCS 7.2. Do you have by any chance non-default Zimlets installed? I'm running zExtras Chat.
Pressing Ctrl-C on all Jetty Apps will finally stopping zimbra leaving MySQL still running.
What I'm wondering is the following "zmmailboxdctl stop" does work which is pretty much the same. zmstorectl stop does not work either.
I'll open a SR with Zimbra.

Re: Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Sat Feb 25, 2017 7:42 pm
by andreaswolske

Re: Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Mon Nov 06, 2017 2:54 pm
by amnesia
Has anyone discovered a workaround for this? I'm having the same issue on 8.7.4.GA.1730 on Ubuntu 16 and it is currently preventing me from upgrading.

Re: Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Thu Jan 25, 2018 7:17 pm
by jdossey7
I'm having the same issue with a brand new install of Zimbra 8.8.5 on Centos 7.4. It started after I installed LetsEncrypt certs. Before I did that, I was using self-signed certs and did not have the shutdown problem.

Re: Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Mon Apr 09, 2018 6:07 am
by zulhairiseman
Anyone found solution for this issue?

Re: Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Sat Jun 09, 2018 8:29 pm
by stegbth
Hi,

same problem with
* Release 8.8.8.GA.2009.UBUNTU16.64 UBUNTU16_64 FOSS edition
* latest OS patches
* certificate from own CA

any solution known?

also after pressing Ctrl+C, the next Javaprocess seems to hang to stop
a

Code: Select all

pkill -u zimbra
seems to stop all processes.

regards
Thomas

Re: Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Thu Jul 12, 2018 4:29 pm
by zulhairiseman
still hasn't find any solution. :(

Re: Zimbra won't shutdown - Stopping zimlet webapp fails

Posted: Tue Jul 31, 2018 11:24 pm
by psilvahr
Well, i see this solution, but not tested yet:

Jason Waters 2017-06-30 23:49:58 UTC
I got mine fixed! Thanks to Zimbra support. So I did this.

su - Zimbra
zmcontrol stop
Then control-C to to stop the services that don't start
mkdir /opt/zimbra/log/oldpids
mv /opt/zimbra/log/*.pid /opt/zimbra/log/oldpids
zmcontrol start
zmcontrol stop

And mine just worked! Hope it helps others!