Out of office doesn't send reply to external senders

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
vebaglaci
Posts: 9
Joined: Mon Jun 03, 2019 8:47 am

Out of office doesn't send reply to external senders

Postby vebaglaci » Wed Apr 01, 2020 12:25 pm

Hi,

I'm using "Release 8.8.15.GA.3829.UBUNTU14.64 UBUNTU14_64 FOSS edition, Patch 8.8.15_P1." on Ubuntu 14.04.

How my zimbra configured :
Domains :
--mail.sandbox.com -- using to manage server admin@mail.sandbox.com is the Administrator login account
--mydomain.com -- set as default domain and accounts defined to this domain.

Working Mode :
--mydomain.com defined as external account, on every 2 minutes zimbra connecting to pop.mydomain.com, downloading e-mails and delivering to user's inbox.
--When users send e-mail to outer world, zimbra sending emails through external relay server (smtp.mydomain.com), i'm setting external relay settings through "/opt/zimbra/conf/relayhost_map" and "/opt/zimbra/conf/relay_password" files

Everything works just fine with above configuration except Out of office messages. When users send mail to eachother (from mydomain.com to mydomain.com) if out of office is enabled system replies with defined Ooo message, but when user received an email from external user like "testing@gmail.com" system doesn't return any Ooo message to sender, "Send custom message to those not in my organisation" defined as enabled, and the most strange thing is there is no any message in the mailbox.log file, not any error, not any message about Ooo message, just nothing.

What did i tried :
--Ooo auto reply cache duration set to zero :

Code: Select all

zmprov mc default zimbraPrefOutOfOfficeCacheDuration 0
--

Code: Select all

zmprov ma test@mydomain.com zimbraPrefOutOfOfficeCacheDuration 0

--Disabled anti-spam service
--Checked with Hosting company to make sure they are not blocking any outgoing messages, they confirmed that there are no any block with any kind, and all other outgoing messages reaching to external recipients without any problem.
--Tested with and without "Send auto-replies during the following time period" option, didn't change the status.

My mailbox.log as attached.
Attachments
Mailboxlog.txt.zip
Mailbox.log file
(13.21 KiB) Downloaded 342 times
Screen Shot 2020-04-01 at 14.36.20.png
Ooo settings of user
Screen Shot 2020-04-01 at 14.36.20.png (73.45 KiB) Viewed 10447 times


vebaglaci
Posts: 9
Joined: Mon Jun 03, 2019 8:47 am

Re: Out of office doesn't send reply to external senders

Postby vebaglaci » Thu Apr 02, 2020 5:26 pm

does anybody have an solution/idea about this ?
vebaglaci
Posts: 9
Joined: Mon Jun 03, 2019 8:47 am

Re: Out of office doesn't send reply to external senders

Postby vebaglaci » Wed Apr 08, 2020 5:12 am

TerranceM wrote:Expand organization configuration. Right-click on Default -> click on properties-> Click on Message Format tab-> and then click to select the Allow automatic replies and Allow automatic forward checkboxes. This then allows auto-replies to go to external senders. We keep ours turned off.


Thanks for reply, did you mean COS with "Organization configuration" because i couldn't find anything regarding Organization Configuration in zimbra admin panel and when i right click to default COS there is no properties option on the list.
Lewis-H
Posts: 49
Joined: Wed Jan 01, 2020 11:28 am
Contact:

Re: Out of office doesn't send reply to external senders

Postby Lewis-H » Fri Apr 10, 2020 2:03 pm

Open the Automatic Replies dialog.
Set the option: Send automatic replies.
Verify that the Automatic Reply for “Outside My Organization” is set to Off.
Click on he Rules
Click on the button: Add Rule
Click on the From
Select the “Reply with” option.
vebaglaci
Posts: 9
Joined: Mon Jun 03, 2019 8:47 am

Re: Out of office doesn't send reply to external senders

Postby vebaglaci » Fri Apr 10, 2020 2:12 pm

Lewis-H wrote:Open the Automatic Replies dialog.
Set the option: Send automatic replies.
Verify that the Automatic Reply for “Outside My Organization” is set to Off.
Click on he Rules
Click on the button: Add Rule
Click on the From
Select the “Reply with” option.

Thanks for the reply but there is no such option as Rule in my panel?

plase see attached screenshots.
Attachments
Screen Shot 2020-04-10 at 17.11.34.png
Screen Shot 2020-04-10 at 17.11.34.png (46.5 KiB) Viewed 5712 times
Screen Shot 2020-04-10 at 17.11.41.png
Screen Shot 2020-04-10 at 17.11.41.png (24.45 KiB) Viewed 5712 times
Screen Shot 2020-04-10 at 17.11.24.png
Screen Shot 2020-04-10 at 17.11.24.png (94.13 KiB) Viewed 5712 times
vebaglaci
Posts: 9
Joined: Mon Jun 03, 2019 8:47 am

Re: Out of office doesn't send reply to external senders

Postby vebaglaci » Tue Apr 21, 2020 10:25 am

anyone has a solution/idea?
Lewis-H
Posts: 49
Joined: Wed Jan 01, 2020 11:28 am
Contact:

Re: Out of office doesn't send reply to external senders

Postby Lewis-H » Wed Apr 22, 2020 2:03 pm

Open the Automatic Replies dialog.
Set the option: Send automatic replies.
Verify that the Automatic Reply for “Outside My Organization” is set to Off.
Click on the Rules
Click on the button: Add Rule
Click on the From
Select the “Reply with” option.
vebaglaci
Posts: 9
Joined: Mon Jun 03, 2019 8:47 am

Re: Out of office doesn't send reply to external senders

Postby vebaglaci » Wed Apr 22, 2020 2:30 pm

Lewis-H wrote:Open the Automatic Replies dialog.
Set the option: Send automatic replies.
Verify that the Automatic Reply for “Outside My Organization” is set to Off.
Click on the Rules
Click on the button: Add Rule
Click on the From
Select the “Reply with” option.


read my previous post very carefully(and check the screenshots), there are no rules link or button in anywhere, there is only Filter option and in Filter option there is no Reply with option.Maybe you are using different version or maybe you have an extra plug-in or zimlet i don't know, but in my server there is no Rules option in anywhere.

last week i contacted with Zimbra and said i'm willing to pay their support fee to fix it, they forwarded me to their local support office, zimbra guys connected to server tried things and after 2 hours they said "well, we are aware of this problem, it's common one but there are no fix for it, wait for zimbra x and upgrade". What the hell !!!! why would i upgrade to version X for just out of office option ? What kind of logic is this ?

Yesterday i spend a whole day and wrote a php script, users set their out of office option from script's panel, script connecting their inbox through imap auto-replying incoming mails, so my script fixed my problem for now but it's quite annoying zimbra can't do that. I was using kerio before switch to zimbra and it was just fine, now i'm re-thinking to buy kerio licence, Zimbra's support is so bad, since the first day i'm struggling with problems and no one helps properly, i've fixed every problem i had encountered but it took so long and now auto-reply is not working and there is no solution.

Thanks for your time and reply, but as i said there is no Rules option in my panel and i've solved with my script.

Zimbra is torture for sure.

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 14 guests