[SOLVED] Outgoing mail going out on MX Record's IP, rather than Cluster IP

Running our Appliance (ZCA), ZCS on VMware, or any other virtual machine software? Post your thoughts here.
vargacs
Posts: 27
Joined: Fri Aug 19, 2016 11:39 pm

[SOLVED] Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby vargacs » Sat Aug 20, 2016 12:57 am

Hello all,

I have a Hyper-v virtualized Zimbra installation. I have an IP pool from ISP. My Zimbra's external IP is xxx.xxx.xxx.203 with port forwarding/NAT to internal IP (192.168.0.53). My global Hyper-V external IP is xxx.xxx.xxx.205. The Zimbra is working fine, the mails are sending and receiving, but I recognized, that the mail headers is containing the xxx.xxx.xxx.205 IP (Hyper-V networks IP), as sender IP. My mails are going there rather than the dedicated public IP. How can I make that the mail sending is going over to the IP xxx.xxx.xxx.203 ( this is the MX record, mail.mydomain.com)
My ISP told me they are made the NAT for this, but nothing changed. What can I set in the Zimbra server to make its working? The best solution would be that the zimbra is assing to its own external IP, but if only the mail sending is going over there is also good.

I made a pic what I have to make.

Image


Thanking in advance!
Csabi


vargacs
Posts: 27
Joined: Fri Aug 19, 2016 11:39 pm

Re: Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby vargacs » Sat Aug 20, 2016 9:24 pm

Nobody can help me? :(

Tapatalkkal küldve az én SM-G930F eszközömről
User avatar
tonster
Zimbra Employee
Zimbra Employee
Posts: 268
Joined: Fri Feb 21, 2014 10:14 am
Location: Ypsilanti, MI
ZCS/ZD Version: Release 8.7.0_GA_1659.RHEL6_64_2016

Re: Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby tonster » Thu Aug 25, 2016 4:55 am

You need to set zimbraMtaLmtpHostLookup to native.

Code: Select all

 
zmprov mcf zimbraMtaLmtpHostLookup native


Sent from my SM-G925T using Tapatalk
vargacs
Posts: 27
Joined: Fri Aug 19, 2016 11:39 pm

Re: RE: Re: Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby vargacs » Thu Aug 25, 2016 7:23 pm

tonster wrote:You need to set zimbraMtaLmtpHostLookup to native.

Code: Select all

 
zmprov mcf zimbraMtaLmtpHostLookup native


Sent from my SM-G925T using Tapatalk

Dear tonster,

Thank you for your answer. I made it, but nothing changed.
Any other idea maybe?

Thanks,
Csabi

Tapatalkkal küldve az én SM-G930F eszközömről
User avatar
jorgedlcruz
Zimbra Employee
Zimbra Employee
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Re: Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby jorgedlcruz » Fri Aug 26, 2016 1:29 am

Hi vargacs,
Have you restarted the MTA service right?

Best regards
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
vargacs
Posts: 27
Joined: Fri Aug 19, 2016 11:39 pm

Re: Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby vargacs » Fri Aug 26, 2016 1:56 pm

jorgedlcruz wrote:Hi vargacs,
Have you restarted the MTA service right?

Best regards


Yes I did the:

Code: Select all

zmcontrol stop
zmcontrol start

But nothing changed. After I did a VM restart, but again nothing changed.
User avatar
jorgedlcruz
Zimbra Employee
Zimbra Employee
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Re: Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby jorgedlcruz » Sat Aug 27, 2016 7:52 pm

What is your Gateway? It is a router, or the same Firewall?

From Zimbra server if you do a

Code: Select all

tracepath 8.8.8.8


What is the result? Does the zimbra traffic goes to the correct GW or goes to the Hyper-V?

Best regards
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
vargacs
Posts: 27
Joined: Fri Aug 19, 2016 11:39 pm

Re: Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby vargacs » Sat Aug 27, 2016 8:27 pm

jorgedlcruz wrote:What is your Gateway? It is a router, or the same Firewall?

From Zimbra server if you do a

Code: Select all

tracepath 8.8.8.8


What is the result? Does the zimbra traffic goes to the correct GW or goes to the Hyper-V?

Best regards


The Gateway is the same Firewall, not a router.

The tracepath is showing only our gateway, and nothing else.

Best regards
vargacs
Posts: 27
Joined: Fri Aug 19, 2016 11:39 pm

Re: Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby vargacs » Sat Aug 27, 2016 8:52 pm

My problem is Solved!! I talked with my support who is handling my firewall, and they broke something in the NAT rules. Thank you for your help!!

Only one question: In the mail header I can see the Zimbra's local IP (192.168.0.53) also. How can I hide it? Can I do it?
User avatar
jorgedlcruz
Zimbra Employee
Zimbra Employee
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Re: [SOLVED] Outgoing mail going out on MX Record's IP, rather than Cluster IP

Postby jorgedlcruz » Sun Aug 28, 2016 8:17 pm

Hi vargacs,
I will mark this thread as solved, please search for the other question on the forum, or if not, create a new thread :)

Best regards
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/

Return to “Virtualization”

Who is online

Users browsing this forum: No registered users and 1 guest