Filter - no "Forward to" option

Post feedback about our hosted demo or your local install. Tell us what you love and/or what you’d like to see added in the future.
dzilupl
Posts: 21
Joined: Thu Jun 16, 2016 8:34 am

Filter - no "Forward to" option

Postby dzilupl » Wed Jul 13, 2016 4:07 pm

Hi

I'm using Zimbra 8.7 RC2. In filter options I can't choose action "Forward to" - this option is missing. Anyone know what can be wrong?


phoenix
Ambassador
Ambassador
Posts: 25816
Joined: Fri Sep 12, 2014 9:56 pm

Re: Filter - no "Forward to" option

Postby phoenix » Wed Jul 13, 2016 4:19 pm

dzilupl wrote:Hi

I'm using Zimbra 8.7 RC2. In filter options I can't choose action "Forward to" - this option is missing. Anyone know what can be wrong?
Do you mean the "Redirect to recipient" option that's also available in the current ZCS 8.6 release?
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
dzilupl
Posts: 21
Joined: Thu Jun 16, 2016 8:34 am

Re: Filter - no "Forward to" option

Postby dzilupl » Thu Jul 14, 2016 10:08 am

Bill, I found in documentation this:

Image

Unfortunately I can't find it when adding new filter:

Image

Is this 8.7 bug or maybe this option isn't available in open source edition?
v1rtu4l
Posts: 36
Joined: Tue Jun 28, 2016 3:04 pm

Re: Filter - no "Forward to" option

Postby v1rtu4l » Sun Jul 17, 2016 12:54 am

i got this option in the OSE of 8.7
User avatar
DualBoot
Outstanding Member
Outstanding Member
Posts: 842
Joined: Mon Apr 18, 2016 8:18 pm
Location: Earth
ZCS/ZD Version: ZCS FLOSS - 8.7.11 Mutli servers

Re: Filter - no "Forward to" option

Postby DualBoot » Mon Aug 22, 2016 10:39 pm

In 8.7 OSE this is no more indicated "Forward To" but "Redirect to Address".
The Guy - DualBoot

PostMaster - WikiMaster - SysAdmin
"Free Your Mind. Think Open Source"
april.org
Zetalliance Member - zetalliance.org
ring-solutions
Posts: 1
Joined: Thu Aug 25, 2016 12:19 pm

Re: Filter - no "Forward to" option

Postby ring-solutions » Thu Aug 25, 2016 12:28 pm

It seems that this option is hidden in 8.7

However you can do this from CLI.
First check what filters the user already has:

Code: Select all

zmprov ga user@domain.com zimbraMailSieveScript


Then add the forwarding rule and optionaly all the others you found using previous command (because this command overwrites all existing rules with new one(s)).
This is an example for a forwarding rule only:

Code: Select all

zmprov ma user@account.com zimbraMailSieveScript 'require ["fileinto", "reject", "tag", "flag"];
# Change2RuleName
if anyof (address :all :contains :comparator "i;ascii-casemap" ["to","cc"] "user@domain.com") {
    redirect "user2@domain2.com";
    keep;
}'


After this, you will have the rule in filters with "Redirect to address" option.
zanewilson
Posts: 3
Joined: Sun Aug 21, 2016 6:55 pm

Re: Filter - no "Forward to" option

Postby zanewilson » Mon Aug 29, 2016 11:31 am

I am looking specifically for a "Forward To" filter rule. Redirect is a very different action, it sends the mail to another account but makes it look as if it was originally sent to that account (From address is taken from the original email and CC list is maintained). If you forward a mail, the "from" address is the email address sending the forward, not the email address that sent the original email. Redirect is very useful, but not appropriate for every "forwarding" use case.

Is this simply a case that Zimbra decided that noone needs to be able to forward mail in a filter rule, and it's not possible to do in 8.7GA? I can see searching various forums that there certainly was a forward filter action at some point in the past.

I tried to export the filters, edit the script to have a "forward" action instead of redirect, and re-import but I can't get the export/import to work (without modifying). I'm doing this:

Code: Select all

$ zmprov ga zane zimbraMailSieveScript  > 1
$ sed 's/zimbraMailSieveScript: //g' 1 > 2
$ zmprov ma zane zimbraMailSieveScript `cat 2`
usage:  modifyAccount(ma) {name@domain|id} [attr1 value1 [attr2 value2...]]
For general help, type : zmprov --help


Error message isn't very enlightening, unfortunately. So I can't export filters as-is and reimport as-is - what am I doing wrong? Same thing using just the account name on its own or the full email address.
zanewilson
Posts: 3
Joined: Sun Aug 21, 2016 6:55 pm

Re: Filter - no "Forward to" option

Postby zanewilson » Mon Aug 29, 2016 11:40 am

FYI I found this option:

$ zmprov ma account@domain.com zimbraFeatureMailForwardingInFiltersEnabled TRUE

Despite the fact it's called "ForwardingInFilters" not "RedirectingInFilters" this controls whether users are allowed to use a redirect rule in filters - has nothing to do with forwarding.
cuongpv22
Posts: 5
Joined: Fri Sep 16, 2016 9:47 am

Re: Filter - no "Forward to" option

Postby cuongpv22 » Fri Sep 16, 2016 10:42 am

Hi

I'm using Zimbra 8.0.9 . In filter options I choose action "Redirect to address " - beacause i want to forward this email to specify email but it working unlike "Forward" Mail. Anyone know how to do this ?

Thanks in advance .
Alessio
Posts: 8
Joined: Tue Aug 02, 2016 9:37 am
ZCS/ZD Version: 8.7

Re: Filter - no "Forward to" option

Postby Alessio » Mon Sep 26, 2016 1:01 pm

Hi

we have 8.7 NE and many accounts even haven't the option "Redirect to:" ad mentioned by dzilupl.

Is this a bug?

It is seriously bothering us.

Return to “Users”

Who is online

Users browsing this forum: No registered users and 1 guest