What version of vcard/vcf does latest Zimbra support?

Questions, comments, and problems with Zimbra on Apple desktops & general CalDAV / CardDAV questions.
eval
Posts: 39
Joined: Sat Oct 29, 2016 3:41 pm

What version of vcard/vcf does latest Zimbra support?

Postby eval » Sat Oct 29, 2016 4:43 pm

Does Zimbra CE v8.7.0/8.7.1 implement vcard/vcf v4? Or still just v3?

If there's a document/specification about it, I've missed it.

This doc

https://wiki.zimbra.com/wiki/REST_File_Formats#VCF

refers only to v3 -- and is labelled as outdated, "archive documentation".

A search at

https://wiki.zimbra.com/index.php?search=vcf

doesn't provide anything newer.

A URL with uptodate info would be helpful.


phoenix
Ambassador
Ambassador
Posts: 25608
Joined: Fri Sep 12, 2014 9:56 pm

Re: What version of vcard/vcf does latest Zimbra support?

Postby phoenix » Sat Oct 29, 2016 7:55 pm

Bugzilla would be the place to look for information such as this, see this:

https://bugzilla.zimbra.com/show_bug.cgi?id=76577
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
eval
Posts: 39
Joined: Sat Oct 29, 2016 3:41 pm

Re: What version of vcard/vcf does latest Zimbra support?

Postby eval » Sat Oct 29, 2016 9:48 pm

Well actually, no, Bugzilla is the LAST place I'd look for documentation of a released package's specs & capabilities, especially for long-lived standards support.

Thanks for the link though.

Open & unresolved since 2012? That doesn't look like good news at all. :-(
phoenix
Ambassador
Ambassador
Posts: 25608
Joined: Fri Sep 12, 2014 9:56 pm

Re: What version of vcard/vcf does latest Zimbra support?

Postby phoenix » Sun Oct 30, 2016 6:57 am

As you'd already looked at the Documentation and found that it supported vCard v3 then bugzilla was the place to look for upcoming supported versions. While some of the information you reviewed was old, it was still valid that v3 was the supported version as mentioned in several wiki notes and if v4 had been supported then I guess there would have been some announcement or mention in the documentation. :)
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
User avatar
Gren Elliot
Zimbra Employee
Zimbra Employee
Posts: 183
Joined: Tue Jun 10, 2014 4:45 am

Re: What version of vcard/vcf does latest Zimbra support?

Postby Gren Elliot » Sun Oct 30, 2016 8:25 pm

https://bugzilla.zimbra.com/show_bug.cgi?id=76577 is the bug we consider to be the main one requesting VCARD 4 support.
Zimbra does not currently support VCARD 4.

For what its worth, although there are a lot of good things about VCARD 4, it has not yet achieved wide support in the industry.
If we did add support for it, we would probably make it optional. A lot of code in the wild expects VCARD 3 (even for CardDAV clients) and would struggle with VCARD 4 data.
eval
Posts: 39
Joined: Sat Oct 29, 2016 3:41 pm

Re: What version of vcard/vcf does latest Zimbra support?

Postby eval » Sun Oct 30, 2016 10:10 pm

vcard4 support is in owncloud/nextcloud, prosody , KDE Kontact, Mozilla Thunderbird/cardbook, sabre/dav, Davical, Kolab, Davdroid, etc etc, to name just a few.

> A lot of code in the wild expects VCARD 3 (even for CardDAV clients) and would struggle with VCARD 4 data.

And lack of vcard4 support can lead to data loss on (attempted) sync with vcard3 servers.

"wide" is subjective, and depends very much on use & perspective.

having the option is the best choice.

but, sounds like Zimbra have decided against it.

which is all that I wanted to know.

Thanks.
User avatar
Gren Elliot
Zimbra Employee
Zimbra Employee
Posts: 183
Joined: Tue Jun 10, 2014 4:45 am

Re: What version of vcard/vcf does latest Zimbra support?

Postby Gren Elliot » Mon Oct 31, 2016 10:34 am

I wouldn't say that Zimbra has decided against it. Personally, I would love to see it done. Having said that, it hasn't hit my radar yet on things to work on.

I take your point on losing fidelity syncing VCARD 4 with servers that don't support it.

Voting on the bug would increase its visibilility.

Return to “CalDAV / CardDAV / iSync”

Who is online

Users browsing this forum: No registered users and 2 guests