0.58 just installed - some problems found

General discussion about Zimbra Desktop.
Mo_Hong
Advanced member
Advanced member
Posts: 51
Joined: Fri Sep 12, 2014 10:07 pm

0.58 just installed - some problems found

Postby Mo_Hong » Thu Oct 04, 2007 5:12 pm

I've just installed Zimbra Desktop 0.58, the installation went fine, no errors, but after I finished the install and went over to the account testing, I got the following error on the page:
system failure: java.lang.ClassCastException: java.util.HashSet
In the mailbox.log the message was the following:
2007-10-04 18:07:33,360 WARN [btpool0-8] [name=zimbra;ip=127.0.0.1;] misc - checkValue: no attribute info for: offlineRemoteServerName

2007-10-04 18:07:33,360 WARN [btpool0-8] [name=zimbra;ip=127.0.0.1;] misc - checkValue: no attribute info for: offlineRemoteServerVersion

2007-10-04 18:07:33,360 WARN [btpool0-8] [name=zimbra;ip=127.0.0.1;] misc - checkValue: no attribute info for: offlineRemoteServerPort

2007-10-04 18:07:33,361 WARN [btpool0-8] [name=zimbra;ip=127.0.0.1;] misc - checkValue: no attribute info for: offlineRemoteSecureConn

2007-10-04 18:07:33,559 WARN [btpool0-8] [name=zimbra;ip=127.0.0.1;] SoapEngine - handler exception

java.lang.ClassCastException: java.util.HashSet

at com.zimbra.cs.db.DbOfflineDirectory.createDirectoryEntry(DbOfflineDirectory.java:67)

at com.zimbra.cs.account.offline.OfflineProvisioning.createAccount(OfflineProvisioning.java:476)

at com.zimbra.cs.service.admin.CreateAccount.handle(CreateAccount.java:58)

at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:324)

at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:191)

at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:104)

at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:268)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)

at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:170)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:362)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:712)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:211)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.handler.RewriteHandler.handle(RewriteHandler.java:176)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:313)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:506)

at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:844)

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:644)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)
Just to let you know, if you have any solution to this problem, it would be great...


jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

0.58 just installed - some problems found

Postby jjzhuang » Thu Oct 04, 2007 5:53 pm

Interesting. If this is really a clean install, then everybody should see this. Not sure why it works for others. Please file a bug with this information. Thanks!
Mo_Hong
Advanced member
Advanced member
Posts: 51
Joined: Fri Sep 12, 2014 10:07 pm

0.58 just installed - some problems found

Postby Mo_Hong » Thu Oct 04, 2007 6:15 pm

I'll file the bug. I think it was a clean install, it did not show any error messages. This is a Linux install and it's sync to a NE 4.5.6 edition. I'll keep it posted on what I find.
Regards,

E.

Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 8 guests