I got this error message.

General discussion about Zimbra Desktop.
16221Derf
Posts: 9
Joined: Fri Sep 12, 2014 10:37 pm

I got this error message.

Postby 16221Derf » Wed Aug 15, 2007 11:26 pm

I installed zdesktop on Fedora core7 and that went fine. But starting zimbra gave me this error...





[root@softwareworkstation1 init.d]# ./zdesktop start

Starting zdesktop

[root@softwareworkstation1 init.d]# nohup: appending output to `nohup.out'
************************************************************************************************


1 [main] INFO org.mortbay.log - Logging to org.slf4j.impl.SimpleLogger(org.mortbay.log) via org.mortbay.log.Slf4jLog

597 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7633

600 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7634

600 [main] INFO org.mortbay.log - jetty-6.1.2rc1

1581 [main] INFO org.mortbay.log - No Transaction manager found - if your webapp requires one, please configure one.

log4j:WARN No appenders could be found for logger (zimbra.misc).

log4j:WARN Please initialize the log4j system properly.

Zimbra server process is running as root, changing to user=zimbra uid=-1 gid=-1

Zimbra server process, after change, is running with uid=-1 euid=-1 gid=-1 egid=-1

ZoneInfo: /root/zimbra/zdesktop/jre/lib/zi/ZoneInfoMappings (Permission denied)

1 [main] INFO org.mortbay.log - Logging to org.slf4j.impl.SimpleLogger(org.mortbay.log) via org.mortbay.log.Slf4jLog

328 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7633

331 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7634

332 [main] INFO org.mortbay.log - jetty-6.1.2rc1

582 [main] INFO org.mortbay.log - No Transaction manager found - if your webapp requires one, please configure one.

log4j:WARN No appenders could be found for logger (zimbra.misc).

log4j:WARN Please initialize the log4j system properly.

Zimbra server process is running as root, changing to user=zimbra uid=-1 gid=-1

Zimbra server process, after change, is running with uid=-1 euid=-1 gid=-1 egid=-1

ZoneInfo: /root/zimbra/zdesktop/jre/lib/zi/ZoneInfoMappings (Permission denied)
****************************************************************************************************
What im i doing wrong


jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

I got this error message.

Postby jholder » Wed Aug 15, 2007 11:31 pm

I just realized my other post may be have been wrong. Why is the UID -1?
That may be a problem on our end.
Also, the zimbra user may not have access to /root
16221Derf
Posts: 9
Joined: Fri Sep 12, 2014 10:37 pm

I got this error message.

Postby 16221Derf » Wed Aug 15, 2007 11:45 pm

Yea could be my bad for installing under root. Ill reinstall and give an update on that.

Thanks for the tip.
16221Derf
Posts: 9
Joined: Fri Sep 12, 2014 10:37 pm

I got this error message.

Postby 16221Derf » Thu Aug 16, 2007 12:01 am

Hey,

No luck, I reinstalled zdesktop (under a different directory) and its still not starting up.

Same error message
Any ideas?
jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

I got this error message.

Postby jholder » Thu Aug 16, 2007 12:05 am

I think it might be related to this:



Zimbra server process is running as root, changing to user=zimbra uid=-1 gid=-1

Zimbra server process, after change, is running with uid=-1 euid=-1 gid=-1 egid=-1

File a bug on that.
16221Derf
Posts: 9
Joined: Fri Sep 12, 2014 10:37 pm

I got this error message.

Postby 16221Derf » Thu Aug 16, 2007 12:36 am

Will do

thanks for the help
jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

I got this error message.

Postby jjzhuang » Sun Aug 19, 2007 8:15 am

Are you running as root? It can't be run as root. We'll make it more friendly but running as root is always bad. Thanks!
16221Derf
Posts: 9
Joined: Fri Sep 12, 2014 10:37 pm

I got this error message.

Postby 16221Derf » Tue Aug 21, 2007 1:29 am

I cant start the zdesktop server without being root because i don't have sufficient rights as a regular user. So I have to run it as root. Is there a way i can start the zdesktop server without changing my user settings?
jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

I got this error message.

Postby jjzhuang » Tue Aug 21, 2007 1:38 am

We have a check to make sure the server is not running as root. This is a security measure. It's definitely a good idea to run any application not as root, especially with something complex like zdesktop. Thanks!
16221Derf
Posts: 9
Joined: Fri Sep 12, 2014 10:37 pm

I got this error message.

Postby 16221Derf » Thu Aug 30, 2007 6:56 pm

Zimbra server process is running as uid=0 euid=0 gid=0 egid=0

Fatal error: terminating: can not start server with uid of 0


How can I change the uid?

Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 4 guests