MX record

Need some help getting Zimbra Desktop set up and working?
WantedStarling
Posts: 3
Joined: Wed May 15, 2019 9:40 pm

MX record

Postby WantedStarling » Wed May 15, 2019 9:57 pm

Hello, I am trying to install Zimbra following the steps from this page https://blog.zimbra.com/2016/05/install ... 14-04-lts/. I am using Ubuntu 14.04 and have set up a static IP. Now I am on the step where I configure the dnsmasq. I finished with the dns configuration and tried to do an mx record. The answer I get is: Image.
The answer in the picture on the guide is different. On the answer section at the end of the line it has the full server address while mine shows the static IP I have set. Also one more difference is that I don't get the Additional Section as shown also on the guide. Please tell me if I doing something wrong. I am not going to proceed with the installation until I figure out these two.

Thank you for your time


phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: MX record

Postby phoenix » Thu May 16, 2019 9:08 am

I don't use dnsmasq so I'm no expert in configuring it but if you're not getting the correct response then your configuration is incorrect. Take a look at the Split DNS wiki article and it should give you a good example on wht needs to be configured.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
Klug
Elite member
Elite member
Posts: 2352
Joined: Mon Dec 16, 2013 11:35 am
Contact:

Re: MX record

Postby Klug » Thu May 16, 2019 12:13 pm

The MX should be (ie: it has to be) a FQDN.

So you have two mistakes here.
The first is you're using an IP address instead of a FQDN.
The second is you've added a dot at the end of the IP address (this is only to be used with FQDN).
WantedStarling
Posts: 3
Joined: Wed May 15, 2019 9:40 pm

Re: MX record

Postby WantedStarling » Thu May 16, 2019 2:01 pm

I actually managed to solve this but I now get an error during the installation about the MX again. Here are the new results: Image

Besides that I am now stuck on the step that says

DNS ERROR resolving MX for zimbra.wantestarling.com
It is suggested that the domain name has an MX record configured in DNS
Change domain name? [Yes]


I chose to change it and entered wantedstarling.com again. But it still doesn't find this domain.
Klug
Elite member
Elite member
Posts: 2352
Joined: Mon Dec 16, 2013 11:35 am
Contact:

Re: MX record

Postby Klug » Thu May 16, 2019 5:11 pm

It means the DNS resolver the zimbra server is using is not aware of the MX record you've set up.

You might want to check the SplitDNS wiki page.
Rony
Posts: 11
Joined: Fri Jan 27, 2017 3:50 pm

Re: MX record

Postby Rony » Thu May 16, 2019 6:14 pm

If it is your real domain wantedstarling.com, it cannot be found.
Try using this tool to search for all your DNS settings:
https://www.whatsmydns.net

Return to “Installation Help”

Who is online

Users browsing this forum: No registered users and 4 guests