Easy install of Z-Push

Take your Zimbra with you!
User avatar
jasggomes
Advanced member
Advanced member
Posts: 69
Joined: Sat Sep 13, 2014 12:59 am
Location: Lisbon, PT
ZCS/ZD Version: Release 8.7.11.GA.1854.UBUNTU14.64
Contact:

Re: Easy install of Z-Push

Postby jasggomes » Sat Mar 10, 2018 1:20 pm

Hi,

Just upgraded to version 2.4 of Z-Push and Zimbra Backedn still on version 67

There is an issue with the Vackend but you can solve it using this: https://sourceforge.net/p/zimbrabackend/bugs/76/

Regards.
JG


AlexV
Posts: 1
Joined: Tue Jul 10, 2018 11:43 am

Re: Easy install of Z-Push

Postby AlexV » Tue Jul 10, 2018 1:14 pm

Hello!

Thank you for the tuturial!
Same for me, i installed the php7 packages, but these commands are not accepted:

root@zimbra:~# systemctl enable php-fpm
Failed to execute operation: No such file or directory

root@zimbra:~# systemctl start php-fpm
Failed to start php-fpm.service: Unit php-fpm.service not found.

So of course, when i try to reach https://zimbra.example.com/Microsoft-Server-ActiveSync, i have a HTTP ERROR 502

Can you guys please help me to enable fpm ?

Thank you!
phoenix
Ambassador
Ambassador
Posts: 25722
Joined: Fri Sep 12, 2014 9:56 pm

Re: Easy install of Z-Push

Postby phoenix » Tue Jul 10, 2018 1:35 pm

AlexV wrote:root@zimbra:~# systemctl enable php-fpm
Failed to execute operation: No such file or directory

root@zimbra:~# systemctl start php-fpm
Failed to start php-fpm.service: Unit php-fpm.service not found.
I would guess from those errors that you don't have php-fpm installed, it would also help if you gave details of which distribution you're using.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
seidler
Posts: 13
Joined: Fri Jun 30, 2017 8:28 am

Re: Easy install of Z-Push

Postby seidler » Fri Aug 31, 2018 8:15 am

AlexV wrote:Hello!

Thank you for the tuturial!
Same for me, i installed the php7 packages, but these commands are not accepted:

root@zimbra:~# systemctl enable php-fpm
Failed to execute operation: No such file or directory

root@zimbra:~# systemctl start php-fpm
Failed to start php-fpm.service: Unit php-fpm.service not found.

So of course, when i try to reach https://zimbra.example.com/Microsoft-Server-ActiveSync, i have a HTTP ERROR 502

Can you guys please help me to enable fpm ?

Thank you!


Sorry about the late reply, I think if you install php 7 then the service name is "php7.0-fpm", so the command to start and enable is

systemctl enable php7.0-fpm
systemctl start php7.0-fpm


Stefan

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 4 guests