[ 2 problems ] Zimbra (8.7.1.GA) migration Ubuntu 16.04 LTS -> CentOS 7.5

Forum to discuss, report issues, or provide feedback about Zimbra Suite Plus Installation or Upgrade
maciej
Posts: 2
Joined: Thu Feb 28, 2019 8:27 am

[ 2 problems ] Zimbra (8.7.1.GA) migration Ubuntu 16.04 LTS -> CentOS 7.5

Postby maciej » Thu Feb 28, 2019 8:55 am

Hi Guys,

Is it even possible to migrate Zimbra between platforms. I've followed the Zimbra migration document, keeping my fingers crossed, but unfortunately hit the wall. This is what I've done:

1) Installed Zimbra on CentOS 7.5:

Code: Select all

[root@new-zcs zcs-8.7.1_GA_1670.RHEL7_64.20161025045328]# ./install.sh -s
[root@new-zcs zcs-8.7.1_GA_1670.RHEL7_64.20161025045328]# rm -rf /opt/zimbra


2) Rsynced the data from the old server (Ubuntu) to the new one (CentOS):

Code: Select all

root@old-zcs:/var/log/mysql# rsync -e ssh -axvzKHS  /opt/zimbra/ new-zcs.example.org:/opt/zimbra


3) Fixed the permissions:

Code: Select all

[root@new-zcs zcs-8.7.1_GA_1670.RHEL7_64.20161025045328]# /opt/zimbra/libexec/zmfixperms -e -v
[root@new-zcs zcs-8.7.1_GA_1670.RHEL7_64.20161025045328]# chown root:postdrop /opt/zimbra/common/sbin/postqueue
[root@new-zcs zcs-8.7.1_GA_1670.RHEL7_64.20161025045328]# chown root:postdrop /opt/zimbra/common/sbin/postdrop
[root@new-zcs zcs-8.7.1_GA_1670.RHEL7_64.20161025045328]# chmod g+s /opt/zimbra/common/sbin/postqueue
[root@new-zcs zcs-8.7.1_GA_1670.RHEL7_64.20161025045328]# chmod g+s /opt/zimbra/common/sbin/postdrop
[root@new-zcs zcs-8.7.1_GA_1670.RHEL7_64.20161025045328]# cd /opt/zimbra/common/
[root@new-zcs common]# chown root.root *
[root@new-zcs common]# chown root.zimbra conf/
[root@new-zcs common]# chown -R root.root libexec/
[root@new-zcs common]# chown -R root.root bin/
[root@new-zcs common]# cd conf
[root@new-zcs conf]# chown root.zimbra *
[root@new-zcs conf]# chown zimbra.zimbra master.cf master.cf.in bysender bysender.lmdb  tag_as_foreign.re tag_as_foreign.re.in tag_as_originating.re tag_as_originating.re.in
[root@new-zcs conf]# chown root.root snmp.conf main.cf


4) Reinstalled perl packages:

Code: Select all

[root@new-zcs~]# for i in $(rpm -qa | grep zimbra | grep perl); do yum -y reinstall ${i}; done


Problem:

I. Now when I try to do an upgrade, I get this:

Code: Select all

[root@new-zcs zcs-8.7.1_GA_1670.RHEL7_64.20161025045328]# ./install.sh

Operations logged to /tmp/install.log.EJPPOioq
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.7.1_GA_1670
    zimbra-logger...FOUND zimbra-logger-8.7.1_GA_1670
    zimbra-mta...FOUND zimbra-mta-8.7.1_GA_1670
    zimbra-dnscache...FOUND zimbra-dnscache-8.7.1_GA_1670
    zimbra-snmp...FOUND zimbra-snmp-8.7.1_GA_1670
    zimbra-store...FOUND zimbra-store-8.7.1_GA_1670
    zimbra-apache...FOUND zimbra-apache-8.7.1_GA_1670
    zimbra-spell...FOUND zimbra-spell-8.7.1_GA_1670
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-1.4.37-2
    zimbra-proxy...FOUND zimbra-proxy-8.7.1_GA_1670
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.7.1_GA_1670
ZCS upgrade from 8.7.1 to 8.7.1 will be performed.
Validating ldap configuration
Error: Unable to create a successful TLS connection to the ldap masters.
       Fix cert configuration prior to upgrading.


I've created new certificates (plus the commercial certificates are still valid) and even disabled the TLS for LDAP:

Code: Select all

[zimbra@new-zcs ~]$ /opt/zimbra/bin/zmcertmgr createcrt -new -days 3650
[zimbra@new-zcs ~]$ /opt/zimbra/bin/zmcertmgr deploycrt self


Code: Select all

[zimbra@new-zcs ~]$ zmlocalconfig -e ssl_allow_untrusted_certs=true
[zimbra@new-zcs ~]$ zmlocalconfig -e ldap_starttls_supported=0
[zimbra@new-zcs ~]$ zmlocalconfig -e ldap_starttls_required=false
[zimbra@new-zcs ~]$ zmlocalconfig -e ldap_common_require_tls=0


Code: Select all

[zimbra@new-zcs ~]$ /opt/zimbra/bin/zmcertmgr viewdeployedcrt | grep -- "^-\|^not"
- ldap: /opt/zimbra/conf/slapd.crt
notBefore=Feb 28 07:38:13 2019 GMT
notAfter=Feb 25 07:38:13 2029 GMT
- mailboxd: /opt/zimbra/mailboxd/etc/mailboxd.pem
notBefore=Feb 28 07:38:13 2019 GMT
notAfter=Feb 25 07:38:13 2029 GMT
- mta: /opt/zimbra/conf/smtpd.crt
notBefore=Feb 28 07:38:13 2019 GMT
notAfter=Feb 25 07:38:13 2029 GMT
- proxy: /opt/zimbra/conf/nginx.crt
notBefore=Feb 28 07:38:13 2019 GMT
notAfter=Feb 25 07:38:13 2029 GMT

[zimbra@new-zcs ~]$ openssl x509 -in /opt/zimbra/ssl/zimbra/commercial/commercial.crt -noout -text | grep Not
            Not Before: Oct 28 00:00:00 2016 GMT
            Not After : Oct 27 23:59:59 2019 GMT


II. When I try to run these commands on the other hand I get PERL error:

Code: Select all

[zimbra@dev-server ~]$ zmcontrol -v
/usr/bin/perl: symbol lookup error: /opt/zimbra/common/lib/perl5/x86_64-linux-gnu-thread-multi/auto/Socket/Socket.so: undefined symbol: Perl_xs_handshake


Which prevents me from doing anything.

Therefore, is it even possible to do a cross-platform migration, or should I leave it and create a new Zimbra instance. If that's the case is there any other way of moving the configuration, rather then setting everything up from scratch and imapsync'ing the emails?

Thank you for your help.

Kind regards

Maciej


phoenix
Ambassador
Ambassador
Posts: 26063
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: [ 2 problems ] Zimbra (8.7.1.GA) migration Ubuntu 16.04 LTS -> CentOS 7.5

Postby phoenix » Thu Feb 28, 2019 10:17 am

Use the ZeXtras Migration Tool.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
maciej
Posts: 2
Joined: Thu Feb 28, 2019 8:27 am

Re: [ 2 problems ] Zimbra (8.7.1.GA) migration Ubuntu 16.04 LTS -> CentOS 7.5

Postby maciej » Thu Feb 28, 2019 1:33 pm

phoenix wrote:Use the ZeXtras Migration Tool.


Thank you for your quick response. I'll have a look.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 1 guest