M1 -> M2 Upgrade Scripts

Official Zimbra news, events, releases, and updates.
goetzi
Advanced member
Advanced member
Posts: 184
Joined: Fri Sep 12, 2014 9:59 pm

M1 -> M2 Upgrade Scripts

Postby goetzi » Sat Nov 19, 2005 7:37 pm

[quote user="agehring"]I had M1 running on HTTPS only, and after the upgrade, it's running on HTTP only.
Is there a "zm" command to change this or does the HTTP/ssl conf file need changed?[/QUOTE]
Yes, there is
su - zimbra

zmtlsctl mixed (or
tomcat">https)
tomcat
stop

tomcat start


14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

M1 -> M2 Upgrade Scripts

Postby 14319KevinH » Sat Nov 19, 2005 7:43 pm

[quote user="adobrin"]

1. is it specific to the Open Source version, or will it work for M1->M2/Network
2. we have confirmed success with this, right? :)

[/QUOTE]
1) Yes it should work for both.
2) Yes, our QA team has validated it and it seems from the posts several folks on the forums have got it to work.
adobrin
Advanced member
Advanced member
Posts: 134
Joined: Fri Sep 12, 2014 9:56 pm

M1 -> M2 Upgrade Scripts

Postby adobrin » Sat Nov 19, 2005 7:45 pm

thanks for the quick reply.
btw kevin, you shouldnt be working !
adobrin
Advanced member
Advanced member
Posts: 134
Joined: Fri Sep 12, 2014 9:56 pm

M1 -> M2 Upgrade Scripts

Postby adobrin » Sat Nov 19, 2005 8:32 pm

ok.


ran through the installation, it seems to have not been too eventful. it didn't catch that i had the stock RH apache installed already, and since port 80 wasn't an issue with M1 (b/c of the redirect) I had it running. This seems to have caused a bit of a conflict; and the web client and IMAP interfaces don't seem to be functioning. SMTP and the Admin interface are working. I'm assuming everything critical to delivery is ok.
I get an error about a conflict on 7080 when restarting zimbra.
I'm going to do some poking around, I'll keep you posted.
adobrin
Advanced member
Advanced member
Posts: 134
Joined: Fri Sep 12, 2014 9:56 pm

M1 -> M2 Upgrade Scripts

Postby adobrin » Sat Nov 19, 2005 8:46 pm

ok.
took out the redhat apache instance, and rebooted. didn't get the same errors this time.
last problem was zmiptables, which i was manually calling in my firewall installation. obviously/apparently its not needed anymore :) i think the upgrade should have overwritten the zmiptables script. shrug--not too big of a deal.


Anyway, all in all, it took about 30 minutes to do, with 15 minutes afterwords troubleshooting those two issues. "Pretty Damn Simple."
Thank you folks for all your hard work; we really appreciate it.
adobrin
Advanced member
Advanced member
Posts: 134
Joined: Fri Sep 12, 2014 9:56 pm

M1 -> M2 Upgrade Scripts

Postby adobrin » Sun Nov 20, 2005 11:03 am

Just remembered another issue.
Though it looked like the install/upgrade script tried to save my existing TLS certificates (by copying them to and from /tmp?) i got errors about /tmp/tlscertfilename not exisitng during the install, and the certs were overwritten with self signed defaults.
again, not too big of a deal :)
vaitguy
Posts: 15
Joined: Fri Sep 12, 2014 9:55 pm

M1 -> M2 Upgrade Scripts

Postby vaitguy » Mon Nov 21, 2005 1:31 pm

Get ain immediate failure that the script cannot determine my ZCS version. when I manually run rpm -q zimbra-core, I get version zimbra-core-2005.0.0-39.FC3-1Armstrong
I see that in the script, its looking for zimbra-coor-3.0.xxxxxx.
Can I manually edit the script to return M1 as I have not run the M2 install yet?
I'm using this personally as my prod email right now (not the company, just myselft/deparment) and would prefer not to mess this up.
MW
avisser
Posts: 29
Joined: Fri Sep 12, 2014 9:57 pm

M1 -> M2 Upgrade Scripts

Postby avisser » Mon Nov 21, 2005 1:34 pm

The upgrade sailed through, but smtp authentication is failing now. In M1 I had authentication enabled, and TLS unchecked. I was able to send fine with those settings, but now my send requests are getting rejected. I haven't changed a thing in Thunderbird, it is using the my full email address as the username on port 25. I have tried checking/unchecking it, restarting the server with zmcontrol and that still doesn't fix it. Also restarting Thunderbird doesn't fix the problem.
this is what /var/log/zimbra.log shows:
Nov 21 13:32:05 mail postfix/smtpd[9533]: connect from []

Nov 21 13:32:08 mail postfix/smtpd[9533]: warning: SASL authentication failure: Password verification failed

Nov 21 13:32:08 mail postfix/smtpd[9533]: warning: []: SASL PLAIN authentication failed

Nov 21 13:32:08 mail postfix/smtpd[9533]: warning: []: SASL LOGIN authentication failed

Nov 21 13:32:10 mail postfix/smtpd[9533]: lost connection after AUTH from []

Nov 21 13:32:10 mail postfix/smtpd[9533]: disconnect from []
sasl is running:

[zimbra@mail ~]$ ps -ef | grep sasl

zimbra 6335 1 0 13:15 ? 00:00:00 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra

zimbra 6336 6335 0 13:15 ? 00:00:00 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra

zimbra 6337 6335 0 13:15 ? 00:00:00 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra

zimbra 6338 6335 0 13:15 ? 00:00:00 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra

zimbra 6339 6335 0 13:15 ? 00:00:00 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra

zimbra 10476 18830 0 13:36 pts/0 00:00:00 grep sasl

[zimbra@mail ~]$



any suggestions?
17629anand
Zimbra Alumni
Zimbra Alumni
Posts: 273
Joined: Fri Sep 12, 2014 9:53 pm

M1 -> M2 Upgrade Scripts

Postby 17629anand » Mon Nov 21, 2005 1:42 pm

[quote user="avisser"]The upgrade sailed through, but smtp authentication is failing now. In M1 I had authentication enabled, and TLS unchecked. I was able to send fine with those settings, but now my send requests are getting rejected. I haven't changed a thing in Thunderbird, it is using the my full email address as the username on port 25. I have tried checking/unchecking it, restarting the server with zmcontrol and that still doesn't fix it.

any suggestions?[/QUOTE]What does /opt/zimbra/cyrus-sasl/etc/saslauthd.conf say? Does zimbra_url look reasonable?
avisser
Posts: 29
Joined: Fri Sep 12, 2014 9:57 pm

M1 -> M2 Upgrade Scripts

Postby avisser » Mon Nov 21, 2005 1:45 pm

the saslauthd.conf looks reasonable to me, is it right?
[zimbra@mail ~]$ cat /opt/zimbra/cyrus-sasl/etc/saslauthd.conf

zimbra_url: https://mail.agroup.com/service/soap/

zimbra_cert_file: /opt/zimbra/conf/smtpd.crt

zimbra_cert_check: off

[zimbra@mail ~]$


:D :D :D

After some tinkering and more forum searching, I changed the url in (saslauthd.conf.in)to use http not https, restarted zmsaslauthdctl and authentication is working now. So my conclusion is that during the upgrade, the zimbra_url was changed from http to https. Hope this helps you guys fix the bug.

Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 1 guest