installation failed "ERROR: Unable to install required packages"

Ask questions about your setup or get help installing ZCS server (ZD section below).
sheepei
Posts: 11
Joined: Thu May 04, 2017 9:07 am

installation failed "ERROR: Unable to install required packages"

Postby sheepei » Tue May 23, 2017 1:51 am

Hi. I tried to install ZImbra open source 8.7.7 on CentOS6.9. The installation is fail.
It showed
ERROR: Unable to install required packages
Fix the issues with remote package installation and rerun the installer


Code: Select all

[root@zimbralab zcs-8.7.7_GA_1787.RHEL6_64.20170410133400]# ./install.sh --platform-override

Operations logged to /tmp/install.log.o0iXjvKn
Checking for existing installation...
    zimbra-chat...NOT FOUND
    zimbra-drive...NOT FOUND
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-convertd...NOT FOUND
    zimbra-memcached...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-core...NOT FOUND


----------------------------------------------------------------------
PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
SYNACOR, INC. ("SYNACOR") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

License Terms for this Zimbra Collaboration Suite Software:
https://www.zimbra.com/license/zimbra-public-eula-2-6.html
----------------------------------------------------------------------



Do you agree with the terms of the software license agreement? [N] y





Use Zimbra's package repository [Y] n

Checking for installable packages

Found zimbra-core (local)
Found zimbra-ldap (local)
Found zimbra-logger (local)
Found zimbra-mta (local)
Found zimbra-dnscache (local)
Found zimbra-snmp (local)
Found zimbra-store (local)
Found zimbra-apache (local)
Found zimbra-spell (local)
Found zimbra-proxy (local)


Select the packages to install

Install zimbra-ldap [Y]

Install zimbra-logger [Y]

Install zimbra-mta [Y]

Install zimbra-dnscache [Y]

Install zimbra-snmp [Y]

Install zimbra-store [Y]

Install zimbra-apache [Y]

Install zimbra-spell [Y]

Install zimbra-proxy [Y]
Checking required space for zimbra-core
Checking space for zimbra-store
Checking required packages for zimbra-store
zimbra-store package check complete.

Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-dnscache
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell
    zimbra-proxy

The system will be modified.  Continue? [N] y

Beginning Installation - see /tmp/install.log.o0iXjvKn for details...

                 zimbra-core will be installed.
                 zimbra-ldap will be installed.
               zimbra-logger will be installed.
                  zimbra-mta will be installed.
             zimbra-dnscache will be installed.
                 zimbra-snmp will be installed.
                zimbra-store will be installed.
               zimbra-apache will be installed.
                zimbra-spell will be installed.
                zimbra-proxy will be installed.

Removing /opt/zimbra
Removing zimbra crontab entry...done.
Cleaning up zimbra init scripts...done.
Cleaning up /etc/security/limits.conf...done.

Finished removing Zimbra Collaboration Server.


Installing local packages (10):
   zimbra-core
   zimbra-ldap
   zimbra-logger
   zimbra-mta
   zimbra-dnscache
   zimbra-snmp
   zimbra-store
   zimbra-apache
   zimbra-spell
   zimbra-proxy
      ...
ERROR: Unable to install required packages
Fix the issues with remote package installation and rerun the installer



in log file

Code: Select all

Installing local packages (10):
   zimbra-core
   zimbra-ldap
   zimbra-logger
   zimbra-mta
   zimbra-dnscache
   zimbra-snmp
   zimbra-store
   zimbra-apache
   zimbra-spell
   zimbra-proxy

Loading "fastestmirror" plugin
Loading "security" plugin
Config time: 0.027
Yum Version: 3.2.29
Setting up Local Package Process
rpmdb time: 0.001
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-core-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-core-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-core-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Setting up Package Sacks
Loading mirror speeds from cached hostfile
Obs Init time: 0.002
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-ldap-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-ldap-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-ldap-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-logger-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-logger-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-logger-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-mta-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-mta-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-mta-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-dnscache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-dnscache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-dnscache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-snmp-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-snmp-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-snmp-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-store-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-store-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-store-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-apache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-apache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-apache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-spell-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-spell-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-spell-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Examining /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-proxy-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm: zimbra-proxy-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Marking /root/zcs-8.7.7_GA_1787.RHEL6_64.20170410133400/packages/zimbra-proxy-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package zimbra-apache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-apache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core', None, (None, None, None)) as a requirement of zimbra-apache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-apache-components', None, (None, None, None)) as a requirement of zimbra-apache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-apache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-apache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-apache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-apache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
zimbra-apache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 requires: zimbra-apache-components
--> Processing Dependency: zimbra-apache-components for package: zimbra-apache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Searching pkgSack for dep: zimbra-apache-components
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
---> Package zimbra-core.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-core.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core-components', None, (None, None, None)) as a requirement of zimbra-core.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-core.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-core.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-core.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-core.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
zimbra-core-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 requires: zimbra-core-components
--> Processing Dependency: zimbra-core-components for package: zimbra-core-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Searching pkgSack for dep: zimbra-core-components
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
---> Package zimbra-dnscache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-dnscache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core', None, (None, None, None)) as a requirement of zimbra-dnscache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-dnscache-components', None, (None, None, None)) as a requirement of zimbra-dnscache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-dnscache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-dnscache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-dnscache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-dnscache.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
zimbra-dnscache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 requires: zimbra-dnscache-components
--> Processing Dependency: zimbra-dnscache-components for package: zimbra-dnscache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Searching pkgSack for dep: zimbra-dnscache-components
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
---> Package zimbra-ldap.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-ldap.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core', None, (None, None, None)) as a requirement of zimbra-ldap.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-ldap-components', None, (None, None, None)) as a requirement of zimbra-ldap.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-ldap.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-ldap.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-ldap.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-ldap.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
zimbra-ldap-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 requires: zimbra-ldap-components
--> Processing Dependency: zimbra-ldap-components for package: zimbra-ldap-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Searching pkgSack for dep: zimbra-ldap-components
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
---> Package zimbra-logger.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-logger.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core', None, (None, None, None)) as a requirement of zimbra-logger.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-logger.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-logger.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-logger.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-logger.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
---> Package zimbra-mta.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-mta.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core', None, (None, None, None)) as a requirement of zimbra-mta.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-mta-components', None, (None, None, None)) as a requirement of zimbra-mta.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-mta.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-mta.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-mta.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-mta.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
zimbra-mta-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 requires: zimbra-mta-components
--> Processing Dependency: zimbra-mta-components for package: zimbra-mta-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Searching pkgSack for dep: zimbra-mta-components
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
---> Package zimbra-proxy.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-proxy.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core', None, (None, None, None)) as a requirement of zimbra-proxy.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-proxy-components', None, (None, None, None)) as a requirement of zimbra-proxy.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-proxy.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-proxy.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-proxy.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-proxy.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
zimbra-proxy-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 requires: zimbra-proxy-components
--> Processing Dependency: zimbra-proxy-components for package: zimbra-proxy-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Searching pkgSack for dep: zimbra-proxy-components
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
---> Package zimbra-snmp.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-snmp.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core', None, (None, None, None)) as a requirement of zimbra-snmp.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-snmp-components', None, (None, None, None)) as a requirement of zimbra-snmp.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-snmp.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-snmp.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-snmp.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-snmp.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
zimbra-snmp-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 requires: zimbra-snmp-components
--> Processing Dependency: zimbra-snmp-components for package: zimbra-snmp-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Searching pkgSack for dep: zimbra-snmp-components
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
---> Package zimbra-spell.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-spell.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core', None, (None, None, None)) as a requirement of zimbra-spell.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-spell-components', None, (None, None, None)) as a requirement of zimbra-spell.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-spell.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-spell.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-spell.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-spell.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
zimbra-spell-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 requires: zimbra-spell-components
--> Processing Dependency: zimbra-spell-components for package: zimbra-spell-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Searching pkgSack for dep: zimbra-spell-components
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
---> Package zimbra-store.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 will be installed
Checking deps for zimbra-store.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-core', None, (None, None, None)) as a requirement of zimbra-store.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('zimbra-store-components', None, (None, None, None)) as a requirement of zimbra-store.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-store.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-store.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-store.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of zimbra-store.x86_64 0:8.7.7_GA_1787.RHEL6_64-20170410133400 - u
zimbra-store-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 requires: zimbra-store-components
--> Processing Dependency: zimbra-store-components for package: zimbra-store-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64
Searching pkgSack for dep: zimbra-store-components
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
Setting up Package Sacks
--> Finished Dependency Resolution
Dependency Process ending
Depsolve time: 1.832
Error: Package: zimbra-ldap-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 (/zimbra-ldap-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64)
           Requires: zimbra-ldap-components
Error: Package: zimbra-dnscache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 (/zimbra-dnscache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64)
           Requires: zimbra-dnscache-components
Error: Package: zimbra-snmp-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 (/zimbra-snmp-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64)
           Requires: zimbra-snmp-components
Error: Package: zimbra-store-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 (/zimbra-store-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64)
           Requires: zimbra-store-components
Error: Package: zimbra-proxy-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 (/zimbra-proxy-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64)
           Requires: zimbra-proxy-components
Error: Package: zimbra-mta-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 (/zimbra-mta-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64)
           Requires: zimbra-mta-components
Error: Package: zimbra-apache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 (/zimbra-apache-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64)
           Requires: zimbra-apache-components
Error: Package: zimbra-spell-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 (/zimbra-spell-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64)
           Requires: zimbra-spell-components
Error: Package: zimbra-core-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64 (/zimbra-core-8.7.7_GA_1787.RHEL6_64-20170410133400.x86_64)
           Requires: zimbra-core-components
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


phoenix
Ambassador
Ambassador
Posts: 26285
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: installation failed "ERROR: Unable to install required packages"

Postby phoenix » Tue May 23, 2017 2:14 am

The problem is the reply you gave to this question:

Use Zimbra's package repository [Y] n
You need that enabled then run the install again. Why are you not installing the current ZCS 8.7.9 on a Centos7 server?
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
sheepei
Posts: 11
Joined: Thu May 04, 2017 9:07 am

Re: installation failed "ERROR: Unable to install required packages"

Postby sheepei » Tue May 23, 2017 2:31 am

dfkmkmfdkamf;lml ,fa fadf
Last edited by sheepei on Tue Jun 06, 2017 7:53 am, edited 1 time in total.
douglasoliveira.adv
Posts: 3
Joined: Fri Jun 02, 2017 4:15 pm

Re: installation failed "ERROR: Unable to install required packages"

Postby douglasoliveira.adv » Fri Jun 02, 2017 4:22 pm

I have the same problem:

Code: Select all


[ec2-user@mail zcs-8.7.9_GA_1794.RHEL7_64.20170505054622]$ sudo ./install.sh --platform-override                     

Operations logged to /tmp/install.log.IdkCot9i
Checking for existing installation...
    zimbra-chat...NOT FOUND
    zimbra-drive...NOT FOUND
    zimbra-suiteplus...NOT FOUND
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-convertd...NOT FOUND
    zimbra-memcached...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-core...NOT FOUND


----------------------------------------------------------------------
PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
SYNACOR, INC. ("SYNACOR") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

License Terms for this Zimbra Collaboration Suite Software:
https://www.zimbra.com/license/zimbra-public-eula-2-6.html
----------------------------------------------------------------------



Do you agree with the terms of the software license agreement? [N] y




Checking for installable packages

Found zimbra-core (local)
Found zimbra-ldap (local)
Found zimbra-logger (local)
Found zimbra-mta (local)
Found zimbra-dnscache (local)
Found zimbra-snmp (local)
Found zimbra-store (local)
Found zimbra-apache (local)
Found zimbra-spell (local)
Found zimbra-proxy (local)


Select the packages to install

Install zimbra-ldap [Y] y

Install zimbra-logger [Y] y       

Install zimbra-mta [Y] y

Install zimbra-dnscache [Y] y

Install zimbra-snmp [Y] y

Install zimbra-store [Y] y

Install zimbra-apache [Y] y

Install zimbra-spell [Y] y

Install zimbra-proxy [Y] y
Checking required space for zimbra-core
Checking space for zimbra-store
Checking required packages for zimbra-store
zimbra-store package check complete.

Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-dnscache
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell
    zimbra-proxy

You appear to be installing packages on a platform different
than the platform for which they were built.

This platform is UNKNOWN
Packages found: RHEL7_64
This may or may not work.

Using packages for a platform in which they were not designed for
may result in an installation that is NOT usable. Your support
options may be limited if you choose to continue.
You will also be responsible for configuring the system to point
at an appropriate package repository for third party.


Install anyway? [N] y

The system will be modified.  Continue? [N] y

Beginning Installation - see /tmp/install.log.IdkCot9i for details...

                 zimbra-core will be installed.
                 zimbra-ldap will be installed.
               zimbra-logger will be installed.
                  zimbra-mta will be installed.
             zimbra-dnscache will be installed.
                 zimbra-snmp will be installed.
                zimbra-store will be installed.
               zimbra-apache will be installed.
                zimbra-spell will be installed.
                zimbra-proxy will be installed.

Removing /opt/zimbra
Removing zimbra crontab entry...done.
Cleaning up zimbra init scripts...done.
Cleaning up /etc/security/limits.conf...done.

Finished removing Zimbra Collaboration Server.


Installing local packages (10):
   zimbra-core
   zimbra-ldap
   zimbra-logger
   zimbra-mta
   zimbra-dnscache
   zimbra-snmp
   zimbra-store
   zimbra-apache
   zimbra-spell
   zimbra-proxy
      ...
ERROR: Unable to install required packages
Fix the issues with remote package installation and rerun the installer




I have the same problem, how do I fix it?
phoenix
Ambassador
Ambassador
Posts: 26285
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: installation failed "ERROR: Unable to install required packages"

Postby phoenix » Fri Jun 02, 2017 4:33 pm

douglasoliveira.adv wrote:

Code: Select all


[ec2-user@mail zcs-8.7.9_GA_1794.RHEL7_64.20170505054622]$ sudo ./install.sh --platform-override


Code: Select all

You appear to be installing packages on a platform different
than the platform for which they were built.

This platform is UNKNOWN
Packages found: RHEL7_64
This may or may not work.

Using packages for a platform in which they were not designed for
may result in an installation that is NOT usable. Your support
options may be limited if you choose to continue.
You will also be responsible for configuring the system to point
at an appropriate package repository for third party.
The relevant snippets from your post would be those above, why are you using 'platform-override' and "This platform is UNKNOWN" is there so what distribution are you using? If it's anything other than CentOS7 or RHEL7 then you're not likely to get much support.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
douglasoliveira.adv
Posts: 3
Joined: Fri Jun 02, 2017 4:15 pm

Re: installation failed "ERROR: Unable to install required packages"

Postby douglasoliveira.adv » Fri Jun 02, 2017 7:27 pm

Hi!

Many thanks for the reply.

I'm using an CentOs7 ec2 aws distribution.

But it has been very difficult for me to set up the zimbra there. The tutorials I find are very old.

I do not know what to do anymore.
douglasoliveira.adv
Posts: 3
Joined: Fri Jun 02, 2017 4:15 pm

Re: installation failed "ERROR: Unable to install required packages"

Postby douglasoliveira.adv » Fri Jun 02, 2017 7:48 pm

Hi.

I also tried to install it in the way below but also gave error.

Code: Select all

[ec2-user@mail zcs-8.7.7_GA_1787.RHEL7_64.20170410133400]$ sudo ./install.sh --platform-override                                                   

Operations logged to /tmp/install.log.65njJKfZ
Checking for existing installation...
    zimbra-chat...NOT FOUND
    zimbra-drive...NOT FOUND
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-convertd...NOT FOUND
    zimbra-memcached...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-core...NOT FOUND


----------------------------------------------------------------------
PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
SYNACOR, INC. ("SYNACOR") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

License Terms for this Zimbra Collaboration Suite Software:
https://www.zimbra.com/license/zimbra-public-eula-2-6.html
----------------------------------------------------------------------



Do you agree with the terms of the software license agreement? [N] y




Checking for installable packages

Found zimbra-core (local)
Found zimbra-ldap (local)
Found zimbra-logger (local)
Found zimbra-mta (local)
Found zimbra-dnscache (local)
Found zimbra-snmp (local)
Found zimbra-store (local)
Found zimbra-apache (local)
Found zimbra-spell (local)
Found zimbra-proxy (local)


Select the packages to install

Install zimbra-ldap [Y] y

Install zimbra-logger [Y] y

Install zimbra-mta [Y] y

Install zimbra-dnscache [Y] y

Install zimbra-snmp [Y] y

Install zimbra-store [Y] y

Install zimbra-apache [Y] y

Install zimbra-spell [Y] y

Install zimbra-proxy [Y] n
Checking required space for zimbra-core
Checking space for zimbra-store
Checking required packages for zimbra-store
zimbra-store package check complete.

Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-dnscache
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

You appear to be installing packages on a platform different
than the platform for which they were built.

This platform is UNKNOWN
Packages found: RHEL7_64
This may or may not work.

Using packages for a platform in which they were not designed for
may result in an installation that is NOT usable. Your support
options may be limited if you choose to continue.
You will also be responsible for configuring the system to point
at an appropriate package repository for third party.


Install anyway? [N] y

The system will be modified.  Continue? [N] y

Beginning Installation - see /tmp/install.log.65njJKfZ for details...

                 zimbra-core will be installed.
                 zimbra-ldap will be installed.
               zimbra-logger will be installed.
                  zimbra-mta will be installed.
             zimbra-dnscache will be installed.
                 zimbra-snmp will be installed.
                zimbra-store will be installed.
               zimbra-apache will be installed.
                zimbra-spell will be installed.

Removing /opt/zimbra
Removing zimbra crontab entry...done.
Cleaning up zimbra init scripts...done.
Cleaning up /etc/security/limits.conf...done.

Finished removing Zimbra Collaboration Server.


Installing local packages (9):
   zimbra-core
   zimbra-ldap
   zimbra-logger
   zimbra-mta
   zimbra-dnscache
   zimbra-snmp
   zimbra-store
   zimbra-apache
   zimbra-spell
      ...
ERROR: Unable to install required packages
Fix the issues with remote package installation and rerun the installer



User avatar
DualBoot
Elite member
Elite member
Posts: 1073
Joined: Mon Apr 18, 2016 8:18 pm
Location: Earth
ZCS/ZD Version: ZCS FLOSS - 8.7.11 Mutli servers

Re: installation failed "ERROR: Unable to install required packages"

Postby DualBoot » Fri Jun 16, 2017 8:21 pm

Show us the OS you are running :
lsb_release -a

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests