www Port Conflict/Changing Zimbra Apache Setting

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
macguru
Posts: 17
Joined: Fri Sep 12, 2014 10:08 pm

www Port Conflict/Changing Zimbra Apache Setting

Postby macguru » Mon Apr 10, 2006 4:46 am

Hi,
I have encountered a nasty problem which still keeps out my Zimbra installation out of net stream. Zimbra launches its own copy of Apache which takes ports 80 (http) and 443 (http SSL). However, I cannot move our company web scripts into Zimbra's Apache because we have our own custom installation on the same SuSE 10 box.
So, I took the shortest route and tried to change Zimbra's Apache ports 80 to 81 and 443 to 444 respectively using this script:
/opt/zimbra/libexec/zmsetup.pl
After applying configuration and starting services again Zimbra's Apache still listening port 80. I have manually edited httpd.cong, no effect anyway.
So I digged forums and found this:
For anyone else who runs into this, what I did was edit:

/opt/zimbra/jakarta-tomcat-5.5.7/webapps/service/WEB-INF/web.xml

80, 443, 7070, 7443

To read:

HTML Code:

80, 443, 7070, 7443, 8888


As a followup, it seems this is no longer true.

Well, it is, but it no longer works this way :-)

Any changes you make to web.xml are now overwritten when Zimbra starts up. You can make those same changes in this file:

/opt/zimbra/jakarta-tomcat-5.5.7/conf/service.web.xml.in

And that will solve this problem.


So, what is the proper way to instruct Zimbra's Apache to run for example on port 8080 for http and port 8081 for http SSL?
Of course, I can edit my firewall rules to swap ports, but this is rather awkward solution. I think, it would be better to change Zimbra's Apache behaviour.
Thanks in advance for any help.
PS. Please add this topic to the admin manual, or at least, wiki/faq site.


phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

www Port Conflict/Changing Zimbra Apache Setting

Postby phoenix » Mon Apr 10, 2006 5:12 am

Zimbra install should find the port conflicts and you have the option to change them at that time. My advice, FWIW, is to run the install script again and make the changes when you do that. BTW, Zimbra doesn't use Apache it uses Tomcat.
You can always add the information to the wiki yourself. ;)
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
macguru
Posts: 17
Joined: Fri Sep 12, 2014 10:08 pm

www Port Conflict/Changing Zimbra Apache Setting

Postby macguru » Mon Apr 10, 2006 8:31 am

Hi, Bill,
Thanks a lot for reply.
As I wrote in my previous post, I did changed the port # with:
/opt/zimbra/libexec/zmsetup.pl
However, it had no effect whatsoever (at least, in my case, I have even rebooted system).
What could be another solution?
phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

www Port Conflict/Changing Zimbra Apache Setting

Postby phoenix » Mon Apr 10, 2006 8:54 am

That wasn't what I meant, I was suggesting you run install.sh again and go through the install process and change the ports at the end, before you commit the upgrade.
When you ran zmsetup.pl were you doing at as 'su - zimbra'?
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
macguru
Posts: 17
Joined: Fri Sep 12, 2014 10:08 pm

www Port Conflict/Changing Zimbra Apache Setting

Postby macguru » Mon Apr 10, 2006 2:37 pm

Hi, Bill,
No, I have run it as root.
phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

www Port Conflict/Changing Zimbra Apache Setting

Postby phoenix » Mon Apr 10, 2006 2:43 pm

All zimbra commands are run as 'su - zimbra' otherwise you'll get problems.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
bobby
Zimbra Employee
Zimbra Employee
Posts: 515
Joined: Fri Sep 12, 2014 10:01 pm

www Port Conflict/Changing Zimbra Apache Setting

Postby bobby » Mon Apr 10, 2006 2:52 pm

there are a few things that should be run as root ;). you'll notice for some that it prompts for a password or states "Warning: libexec/zmsetup.pl must be run as root!".
you can change the webmail access ports like this (with the appropriate SERVERNAME):
su - zimbra

zmprov ms SERVERNAME zimbraMailPort 81

zmprov ms SERVERNAME zimbraMailSSLPort 444

tomcat restart
phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

www Port Conflict/Changing Zimbra Apache Setting

Postby phoenix » Mon Apr 10, 2006 2:59 pm

[quote user="17224bobby"]there are a few things that should be run as root ;). [/QUOTE]

I'm having a bad day today, I'll go back to sleep for a while and see if that helps. :o :D
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
macguru
Posts: 17
Joined: Fri Sep 12, 2014 10:08 pm

www Port Conflict/Changing Zimbra Apache Setting

Postby macguru » Tue Apr 11, 2006 1:46 pm

Thanks! Its worked finally :-))
raph
Posts: 6
Joined: Fri Sep 12, 2014 10:01 pm

www Port Conflict/Changing Zimbra Apache Setting

Postby raph » Sun Apr 16, 2006 11:10 am

where can i find more info about the zmprov command seems quite usefull but when i run it with -h argument it doesnt seems to give me all the options

Return to “Administrators”

Who is online

Users browsing this forum: Bing [Bot], Majestic-12 [Bot] and 21 guests