Split Dns setup

Ask questions about your setup or get help installing ZCS server (ZD section below).
axiomcrs
Posts: 24
Joined: Sat Sep 13, 2014 2:54 am

Split Dns setup

Postby axiomcrs » Tue Sep 25, 2012 1:00 pm

I have read the various posts and docs about split dns, but it still seems to have issues:

Here are the responses to the commands that involve thiese issues. When I run the install.sh script it reports a dns mx problem.
[root@zimbrahost axiomcrs]# host `hostname`

zimbrahost.axiomcomputerservices.com has address 63.251.179.13

zimbrahost.axiomcomputerservices.com has address 8.15.7.117

Host zimbrahost.axiomcomputerservices.com not found: 3(NXDOMAIN)

[root@zimbrahost axiomcrs]# dig axiomcomputerservices.com mx
; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.3 <<>> axiomcomputerservices.com mx

;; global options: +cmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; QUESTION SECTION:

;axiomcomputerservices.com. IN MX
;; ANSWER SECTION:

axiomcomputerservices.com. 5274 IN MX 0 axiomcomputerservices.com.
;; ADDITIONAL SECTION:

axiomcomputerservices.com. 5274 IN A 74.104.135.114
;; Query time: 2 msec

;; SERVER: 10.3.0.3#53(10.3.0.3)

;; WHEN: Tue Sep 25 13:53:48 2012

;; MSG SIZE rcvd: 75

[root@zimbrahost axiomcrs]# dig axiomcomputerservices.com any
; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.3 <<>> axiomcomputerservices.com any

;; global options: +cmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 3
;; QUESTION SECTION:

;axiomcomputerservices.com. IN ANY
;; ANSWER SECTION:

axiomcomputerservices.com. 5231 IN A 74.104.135.114

axiomcomputerservices.com. 8336 IN NS ns2.bluehost.com.

axiomcomputerservices.com. 8336 IN NS ns1.bluehost.com.

axiomcomputerservices.com. 8336 IN SOA ns1.bluehost.com. root.box603.bluehost.com. 2012091400 86400 7200 3600000 300

axiomcomputerservices.com. 5231 IN MX 0 axiomcomputerservices.com.

axiomcomputerservices.com. 14400 IN TXT "v=spf1 a mx ptr include:bluehost.com ?all"
;; ADDITIONAL SECTION:

ns2.bluehost.com. 2150 IN A 69.89.16.4

ns1.bluehost.com. 2140 IN A 74.220.195.31

axiomcomputerservices.com. 5231 IN A 74.104.135.114
;; Query time: 98 msec

;; SERVER: 10.3.0.3#53(10.3.0.3)

;; WHEN: Tue Sep 25 13:54:31 2012

;; MSG SIZE rcvd: 270

[
root@zimbrahost axiomcrs]# cat /etc/hosts

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4

::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

10.3.0.99 zimbrahost.axiomcomputerservices.com

[root@zimbrahost axiomcrs]# cat /etc/resolv.conf

nameserver 10.3.0.3

nameserver 71.243.0.12

nameserver 10.3.0.99

[root@zimbrahost axiomcrs]#


phoenix
Ambassador
Ambassador
Posts: 26727
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Split Dns setup

Postby phoenix » Tue Sep 25, 2012 1:08 pm

You're hosts file is incorrect, your resolv.conf file is incorrect and you have invalid DNS A & MX records - the only article you need to read is the one in the wiki - that article tells you all you need to know about the format of your MX records (compare yours to the example - hint: check the FQDN), the A record (specifically the IP address to which it points), the resolv.conf (how many and which DNS servers should be in there) and the hosts file (specifically the IP address and the FQDN of your ZCS server). When you've checked those and corrected the you should run all the commands in the 'Verify....' section of that article and post the output here - to make the output more readable please enclose each bit of output in code tags to make it easier to read (see your post above after my edit).
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
axiomcrs
Posts: 24
Joined: Sat Sep 13, 2014 2:54 am

Split Dns setup

Postby axiomcrs » Tue Sep 25, 2012 2:07 pm

After restarting the named daemon I get:
root@zimbrahost named]# /etc/init.d/named restart

Stopping named: [ OK ]

Starting named:

Error in named configuration:

db.zimbrahost.axiomcomputerservices.com:1: no TTL specified; using SOA MINTTL instead

db.zimbrahost.axiomcomputerservices.com:8: NS record '10.3.0.99' appears to be an address

db.zimbrahost.axiomcomputerservices.com:10: ignoring out-of-zone data (axiomcomputerservices.com)

dns_rdata_fromtext: db.zimbrahost.axiomcomputerservices.com:10: near 'zimbrahost.axiomcomputerservices.com.': not a valid number

zone zimbrahost.axiomcomputerservices.com/IN: loading from master file db.zimbrahost.axiomcomputerservices.com failed: not a valid number

zone zimbrahost.axiomcomputerservices.com/IN: not loaded due to errors.

_default/zimbrahost.axiomcomputerservices.com/IN: not a valid number

[FAILED]

[root@zimbrahost named]#


I am following the bind part of the wiki. Here is named.conf:
[root@zimbrahost named]# cat /etc/named.conf

//

// named.conf

//

//
options {

directory "/var/named";

dump-file "/var/named/data/cache_dump.db";

statistics-file "/var/named/data/named_stats.txt";

forwarders { 10.3.0.3 ; };

};
zone "zimbrahost.axiomcomputerservices.com" {

type master;

file "db.zimbrahost.axiomcomputerservices.com";

};

[root@zimbrahost named]#



The db.server zone file is:
[root@zimbrahost named]# cat /var/named/db.zimbrahost.axiomcomputerservices.com 

@ IN SOA zimbrahost.axiomcomputerservices.com. hostmaster.zimbrahost.axiomcomputerservices.com. (

10118 ;

43200 ;

3600 ;

3600000 ;

2592000 ) ;
IN NS 10.3.0.99
axiomcomputerservices.com. IN MX zimbrahost.axiomcomputerservices.com.

zimbrahost.axiomcomputerservices.com. IN A 10.3.0.99

[root@zimbrahost named]#



The /etc/hosts file is:
[root@zimbrahost named]# cat /etc/hosts

127.0.0.1 zimbrahost zimbrahost.axiomcomputerservices.com

10.3.0.99 zimbrahost.axiomcomputerservices.com

[root@zimbrahost named]#

resolv.conf is:
[root@zimbrahost named]# cat /etc/resolv.conf

search axiomcomputerservices.com

nameserver 127.0.0.1

nameserver 10.3.0.3

nameserver 71.243.0.12

nameserver 10.3.0.99

[root@zimbrahost named]#
phoenix
Ambassador
Ambassador
Posts: 26727
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Split Dns setup

Postby phoenix » Tue Sep 25, 2012 2:27 pm

Why have you not fixed your hosts file and your resolv.conf files?
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
axiomcrs
Posts: 24
Joined: Sat Sep 13, 2014 2:54 am

Split Dns setup

Postby axiomcrs » Tue Sep 25, 2012 2:53 pm

The instructions for the bind section does not actually say to edit the hosts file. That part of the wiki applies to the dnsmasq configuring. Here is my hosts:
[root@zimbrahost named]# cat /etc/hosts

127.0.0.1 localhost.localdomain localhost

10.3.0.99 zimbrahost.axiomcomputerservices.com

[root@zimbrahost named]#

My resolv.conf file looks right to me.
soxfan
Outstanding Member
Outstanding Member
Posts: 958
Joined: Fri Sep 12, 2014 10:08 pm

Split Dns setup

Postby soxfan » Tue Sep 25, 2012 3:24 pm

In your zone file the "NS" record should contain a FQDN (ie zimbrahost.axiomcomputerservices.com) instead of the IP address and your "MX" record needs a priority number (ie 10) in front of the server name. Those are the two issues that jump out at me based on the error messages you are getting when you try to start named.
phoenix
Ambassador
Ambassador
Posts: 26727
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Split Dns setup

Postby phoenix » Wed Sep 26, 2012 1:23 am

[quote user="axiomcrs"]The instructions for the bind section does not actually say to edit the hosts file.[/QUOTE]No but the ZCS Installation instructions do as does the 'Verify...' section of the wiki article.
[quote user="axiomcrs"]That part of the wiki applies to the dnsmasq configuring.[/QUOTE]You're mistaken, the 'Verify...' section is a completely separate section in the article and it's description of the hosts & resolv file applies to your server whichever DNS server is in use.
[quote user="axiomcrs"]Here is my hosts:
[root@zimbrahost named]# cat /etc/hosts

127.0.0.1 localhost.localdomain localhost

10.3.0.99 zimbrahost.axiomcomputerservices.com

[root@zimbrahost named]#

My resolv.conf file looks right to me.[/QUOTE]Your resolv file is not correct and both files require modifying as described in the article.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
axiomcrs
Posts: 24
Joined: Sat Sep 13, 2014 2:54 am

Split Dns setup

Postby axiomcrs » Wed Sep 26, 2012 9:07 am

My resolv.conf is now:
search axiomcomputerservices.com

nameserver 127.0.0.1

From the wiki, the zone file wants "internal address of server" for the NS line, but you said it should be the fqdn of the server. The same situation appears in the A line of the zone file. It wants an address, but you say it should be a name. Which one is it?
axiomcrs
Posts: 24
Joined: Sat Sep 13, 2014 2:54 am

Split Dns setup

Postby axiomcrs » Wed Sep 26, 2012 3:23 pm

Is it necessary to name the mx-host with the first word mail as in mail.yourdomain.com? Also, the hosts file has a line where it defines mail with the word mail as the first part of the fqdn, as in mail.yourdomain.com? Can I name the first part of the fqdn for the mail function with whatever name I want? Can I do specify this in the hosts file: 10.3.0.99 xyz.axiomcomputerservices.com xyz?
soxfan
Outstanding Member
Outstanding Member
Posts: 958
Joined: Fri Sep 12, 2014 10:08 pm

Split Dns setup

Postby soxfan » Wed Sep 26, 2012 3:30 pm

[QUOTE]From the wiki, the zone file wants "internal address of server" for the NS line, but you said it should be the fqdn of the server. The same situation appears in the A line of the zone file. It wants an address, but you say it should be a name. Which one is it? [/QUOTE]

The NS line should contain the name of your server, not the IP address. You are right, the wiki is a little unclear in this situation. Actually the FQDN needs a "." at the end. There are other notations you can use, but for simplicity let's stick with FQDN followed immediately (no spaces) by a period. Your "A" record is fine. Where the wiki article says "internal address of the server" you should use the IP address. The other mistake, as I mentioned in my previous replay is that your "MX" record needs a priority number (ie 10) in front of the server name.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests