install error. SLAPD not starting?

Ask questions about your setup or get help installing ZCS server (ZD section below).
1342superman
Posts: 10
Joined: Fri Sep 12, 2014 9:56 pm

install error. SLAPD not starting?

Postby 1342superman » Tue Oct 04, 2005 2:21 pm

When i install I get this error

Starting servers...Calling GetServiceInfoRequest (zimbra.onamia.k12.mn.us)
RESPONSE: (Zimbra::Mon::serviceInfo)

host

ip 10.0.176.39

name zimbra.onamia.k12.mn.us

done

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.onamia.k12.mn.us:389)
Installation complete!
when I do a ps -uux | grep for slapd or zimbra, I get nothing returned indacating slapd. When I search on zimbra I get a lot of mysql/jave/ perl misc stuff but no ldap.

Any ideas?

Also, i should mention that I installed this on FC4 so that may be the issue.


14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

install error. SLAPD not starting?

Postby 14319KevinH » Tue Oct 04, 2005 4:45 pm

Try: ldd /opt/zimbra/openldap/libexec/slapd
If that looks ok then try the instructions here:

http://www.zimbra.com/forums/showthread.php?p=142&highlight=slapd#post142
1342superman
Posts: 10
Joined: Fri Sep 12, 2014 9:56 pm

install error. SLAPD not starting?

Postby 1342superman » Wed Oct 05, 2005 7:51 am

when I run the last command I get an error while loading shared libraries: libssl.so.4

I have copied the results of the command below. Do I need to sym link the library file from somewhere else?


[zimbra@zimbra ~]$ /opt/zimbra/libexec/zmldapinit

/opt/zimbra/openldap/sbin/slappasswd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

/opt/zimbra/openldap/sbin/slappasswd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

db_recover: Finding last valid log LSN: file: 1 offset 28

/opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

Started slapd: pid

/opt/zimbra/openldap/bin/ldapmodify: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

/opt/zimbra/openldap/bin/ldapmodify: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

[zimbra@zimbra ~]$
1342superman
Posts: 10
Joined: Fri Sep 12, 2014 9:56 pm

install error. SLAPD not starting?

Postby 1342superman » Wed Oct 05, 2005 7:53 am

[root@zimbra ~]# ldd /opt/zimbra/openldap/libexec/slapd

linux-gate.so.1 => (0x00718000)

libdb-4.2.so => /opt/zimbra/lib/libdb-4.2.so (0x00bdc000)

libsasl2.so.2 => /opt/zimbra/cyrus-sasl/lib/libsasl2.so.2 (0x008b7000)

libssl.so.4 => not found

libcrypto.so.4 => not found

libresolv.so.2 => /lib/libresolv.so.2 (0x00655000)

libpthread.so.0 => /lib/libpthread.so.0 (0x00641000)

libc.so.6 => /lib/libc.so.6 (0x004d4000)

libdl.so.2 => /lib/libdl.so.2 (0x00600000)

/lib/ld-linux.so.2 (0x004b6000)
1342superman
Posts: 10
Joined: Fri Sep 12, 2014 9:56 pm

install error. SLAPD not starting?

Postby 1342superman » Wed Oct 05, 2005 10:15 am

I made sym links to the libssl.so.5 and libcrypto.so.5 and all is well
ln -s /lib/libssl.so.5 /lib/libssl.so.4

ln -s /lib/libcrypto.so.5 /lib/libcrypto.so.4
then reinstalled and all works well now.
ramidotcom
Posts: 15
Joined: Fri Sep 12, 2014 9:57 pm

install error. SLAPD not starting?

Postby ramidotcom » Thu Oct 06, 2005 9:22 pm

can you just specify how to make these sym links, like what is the syntax
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

install error. SLAPD not starting?

Postby 14319KevinH » Fri Oct 07, 2005 1:45 am

[quote user="ramidotcom"]can you just specify how to make these sym links, like what is the syntax[/QUOTE]
What superman posted is the exact syntax.
fak3r
Posts: 16
Joined: Fri Sep 12, 2014 9:57 pm

install error. SLAPD not starting?

Postby fak3r » Mon Oct 10, 2005 12:30 pm

[quote user="ramidotcom"]can you just specify how to make these sym links, like what is the syntax[/QUOTE]
ln -s /usr/lib/libssl.so.0.9.7 /lib/libssl.so.4

ln -s /usr/lib/libpcre.so.3 /lib/libpcre.so.0

ln -s /usr/lib/libcrypto.so.0.9.7 /lib/libcrypto.so.4
fak3r
wynton
Posts: 10
Joined: Fri Sep 12, 2014 10:28 pm

install error. SLAPD not starting?

Postby wynton » Tue Apr 17, 2007 2:18 pm

[quote user="1342superman"]I made sym links to the libssl.so.5 and libcrypto.so.5 and all is well
ln -s /lib/libssl.so.5 /lib/libssl.so.4

ln -s /lib/libcrypto.so.5 /lib/libcrypto.so.4
then reinstalled and all works well now.[/QUOTE]
I follow your way, it doesn't work. How can I unlinks that I did links before? Thanks.
jholder
Zimbra Employee
Zimbra Employee
Posts: 4693
Joined: Fri Sep 12, 2014 10:00 pm

install error. SLAPD not starting?

Postby jholder » Wed Apr 18, 2007 12:33 am

rm /lib/libssl.so.4

rm /lib/libcrypto.so.4

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests