Login page appears, can't login - Gentoo

Ask questions about your setup or get help installing ZCS server (ZD section below).
fak3r
Posts: 16
Joined: Fri Sep 12, 2014 9:57 pm

Login page appears, can't login - Gentoo

Postby fak3r » Mon Oct 10, 2005 5:27 pm

Ok, I've gotten past everything on these pages:
http://www.zimbra.com/blog/archives/2005/08/developing_with.html


But">http://zimbra.com/forums/showthread.php?t=186
But
when I point to http://servername:7070 I get the login page! but as soon as I enter username and password, I get the following error:

An unknown application error has occurred. Please correct any errors and retry. If the problem persists, please contact your System Aministrator. (INVALID_PDU)


The thing is, I get nothing in the logs, so I suspect something isn't running. How can I tell what isn't running?
zimbra@jorge bin $ ./zimbra status

Password:

Calling GetServiceInfoRequest ()
RESPONSE: (Zimbra::Mon::serviceInfo)

host

ip

name

zimbra@jorge bin $ ./zimbra stop

Password:

Calling ShutDownRequest ()
zimbra@jorge bin $ ./zimbra start

Password:

Calling startup ()
perl /opt/zimbra/bin/zmmon &
RESPONSE: (Zimbra::Mon::serviceInfo)

host

ip

name

zimbra@jorge bin $

What's happening? Is something not starting? How do I add a new user, and login?
fak3r


14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Login page appears, can't login - Gentoo

Postby 14319KevinH » Mon Oct 10, 2005 5:57 pm

Does zmcontrol start work for you?
Anything in /opt/zimbra/tomcat/logs/* that is suspect?
pshah
Outstanding Member
Outstanding Member
Posts: 264
Joined: Fri Sep 12, 2014 9:55 pm

Login page appears, can't login - Gentoo

Postby pshah » Mon Oct 10, 2005 7:06 pm

Also try navigating to http://servername:7070/?debug=1 instead - this should bring up a "debug" window which will give you more details on what requests the client is making and the response your getting back. It might help us if you pasted the request/response as well.
Goodluck.
fak3r
Posts: 16
Joined: Fri Sep 12, 2014 9:57 pm

Login page appears, can't login - Gentoo

Postby fak3r » Mon Oct 10, 2005 9:30 pm

[quote user="14319KevinH"]Does zmcontrol start work for you?[/QUOTE]
It does, is this all the output I should expect though?
zimbra@jorge bin $ ./zmcontrol start

Calling start (jorge)
perl ./zmmon &
zimbra@jorge bin $

[quote user="14319KevinH"]Anything in /opt/zimbra/tomcat/logs/* that is suspect?[/QUOTE]
Yep, there's trouble there for sure - what is the keystore? I had a earlier error that it couldn't find it, so I created it as a file, but now get the following:
jorge logs # cat catalina.out

Oct 10, 2005 9:22:53 PM org.apache.coyote.http11.Http11Protocol init

INFO: Initializing Coyote HTTP/1.1 on http-7070

Oct 10, 2005 9:22:53 PM org.apache.coyote.http11.Http11Protocol init

SEVERE: Error initializing endpoint

java.io.EOFException

at java.io.DataInputStream.readInt(DataInputStream.java:358)

at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:627)

at java.security.KeyStore.load(KeyStore.java:1150)

at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getStore(JSSESocketFactory.java:280)

at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getKeystore(JSSESocketFactory.java:222)

at org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.getKeyManagers(JSSE14SocketFactory.java:141)

at org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.init(JSSE14SocketFactory.java:109)

at org.apache.tomcat.util.net.jsse.JSSESocketFactory.createSocket(JSSESocketFactory.java:88)

at org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(PoolTcpEndpoint.java:292)

at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:142) at org.apache.catalina.connector.Connector.initialize(Connector.java:918)

at org.apache.catalina.core.StandardService.initialize(StandardService.java:580)

at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:764)

at org.apache.catalina.startup.Catalina.load(Catalina.java:490)

at org.apache.catalina.startup.Catalina.load(Catalina.java:509)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:243)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:408)

Oct 10, 2005 9:22:53 PM org.apache.catalina.startup.Catalina load

SEVERE: Catalina.start

LifecycleException: Protocol handler initialization failed: java.io.EOFException

at org.apache.catalina.connector.Connector.initialize(Connector.java:920)

at org.apache.catalina.core.StandardService.initialize(StandardService.java:580)

at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:764)

at org.apache.catalina.startup.Catalina.load(Catalina.java:490)

at org.apache.catalina.startup.Catalina.load(Catalina.java:509)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:243)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:408)

Oct 10, 2005 9:22:53 PM org.apache.catalina.startup.Catalina load

INFO: Initialization processed in 2702 ms

Oct 10, 2005 9:22:53 PM org.apache.catalina.core.StandardService start

INFO: Starting service Catalina

Oct 10, 2005 9:22:53 PM org.apache.catalina.core.StandardEngine start

INFO: Starting Servlet Engine: Apache Tomcat/5.5.7

Oct 10, 2005 9:22:53 PM org.apache.catalina.core.StandardHost start

INFO: XML validation disabled

Oct 10, 2005 9:22:56 PM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive service.war

log4j:WARN No appenders could be found for logger (org.apache.catalina.session.ManagerBase).

log4j:WARN Please initialize the log4j system properly.

Oct 10, 2005 9:22:58 PM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive zimbra.war

Oct 10, 2005 9:22:58 PM org.apache.catalina.core.ApplicationContext log

INFO: org.apache.webapp.balancer.BalancerFilter: init(): ruleChain: [org.apache.webapp.balancer.RuleChain: [org.apache.webapp.balancer.rules.URLStringMatchRule: Target string: News / Redirect URL: http://www.cnn.com], [org.apache.webapp.balancer.rules.RequestParameterRule: Target param name: paramName / Target param value: paramValue / Redirect URL: http://www.yahoo.com], [org.apache.webapp.balancer.rules.AcceptEverythingRule: Redirect URL: http://jakarta.apache.org]]

Oct 10, 2005 9:22:58 PM org.apache.coyote.http11.Http11Protocol start

INFO: Starting Coyote HTTP/1.1 on http-7070

Oct 10, 2005 9:22:58 PM org.apache.coyote.http11.Http11Protocol start

SEVERE: Error starting endpoint

java.io.EOFException

at java.io.DataInputStream.readInt(DataInputStream.java:358)

at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:627)

at java.security.KeyStore.load(KeyStore.java:1150)

at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getStore(JSSESocketFactory.java:280)

at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getKeystore(JSSESocketFactory.java:222)

at org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.getKeyManagers(JSSE14SocketFactory.java:141)

at org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.init(JSSE14SocketFactory.java:109)

at org.apache.tomcat.util.net.jsse.JSSESocketFactory.createSocket(JSSESocketFactory.java:88)

at org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(PoolTcpEndpoint.java:292)

at org.apache.tomcat.util.net.PoolTcpEndpoint.startEndpoint(PoolTcpEndpoint.java:312)

at org.apache.coyote.http11.Http11Protocol.start(Http11Protocol.java:181)

at org.apache.catalina.connector.Connector.start(Connector.java:990)

at org.apache.catalina.core.StandardService.start(StandardService.java:459)

at org.apache.catalina.core.StandardServer.start(StandardServer.java:683)

at org.apache.catalina.startup.Catalina.start(Catalina.java:537)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:271)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:409)

Oct 10, 2005 9:22:59 PM org.apache.catalina.startup.Catalina start

SEVERE: Catalina.start:

LifecycleException: Protocol handler start failed: java.io.EOFException

at org.apache.catalina.connector.Connector.start(Connector.java:992)

at org.apache.catalina.core.StandardService.start(StandardService.java:459)

at org.apache.catalina.core.StandardServer.start(StandardServer.java:683)

at org.apache.catalina.startup.Catalina.start(Catalina.java:537)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:271)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:409)

Oct 10, 2005 9:22:59 PM org.apache.catalina.startup.Catalina start

INFO: Server startup in 5477 ms
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Login page appears, can't login - Gentoo

Postby 14319KevinH » Mon Oct 10, 2005 9:37 pm

Ahh keystore looks like the next stopper. You need to run zmcreatecert and then zmcertinstall twice. Once for mta and once for mail box. So like:
zmcertinstall mta /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key
zmcertinstall mailbox /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key
dready
Posts: 8
Joined: Fri Sep 12, 2014 9:57 pm

Login page appears, can't login - Gentoo

Postby dready » Mon Oct 10, 2005 9:38 pm

Similar problem here...i got this error on login page trying to login...
An unknown application error has occurred. Please correct any errors and retry. If the problem persists, please contact your System Aministrator. (service.FAILURE)




This machine is behind the firewall and im allowed to use port 8080 for http. I changed settings in server.xml, zmiptables and web.xml (changing 80 with 8080). Maybe there is some other file that i must modify...

With default Zimbra settings i got redirected to machine which uses port 80 and normally...page not found.

Any idea?
Thanx.


I found something in the catalina.out log:

SEVERE: Protocol handler pause failed

java.net.ConnectException: Connection refused

at java.net.PlainSocketImpl.socketConnect(Native Method)

at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)

at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)

at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)

at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:364)

at java.net.Socket.connect(Socket.java:507)

at java.net.Socket.connect(Socket.java:457)

at java.net.Socket.(Socket.java:365)

at java.net.Socket.(Socket.java:207)

at org.apache.jk.common.ChannelSocket.unLockSocket(ChannelSocket.java:460)

at org.apache.jk.common.ChannelSocket.pause(ChannelSocket.java:272)

at org.apache.jk.server.JkMain.pause(JkMain.java:677)

at org.apache.jk.server.JkCoyoteHandler.pause(JkCoyoteHandler.java:208)

at org.apache.catalina.connector.Connector.pause(Connector.java:933)

at org.apache.catalina.core.StandardService.stop(StandardService.java:491)

at org.apache.catalina.core.StandardServer.stop(StandardServer.java:717)

at org.apache.catalina.startup.Catalina.stop(Catalina.java:586)

at org.apache.catalina.startup.Catalina.start(Catalina.java:561)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:271)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:409)

Oct 10, 2005 10:25:09 PM org.apache.catalina.core.StandardService stop

INFO: Stopping service Catalina

Oct 10, 2005 10:25:09 PM org.apache.coyote.http11.Http11Protocol destroy

INFO: Stopping Coyote HTTP/1.1 on http-7070

Oct 10, 2005 10:25:09 PM org.apache.coyote.http11.Http11Protocol destroy

INFO: Stopping Coyote HTTP/1.1 on http-7071

Oct 10, 2005 10:26:27 PM org.apache.coyote.http11.Http11Protocol init

INFO: Initializing Coyote HTTP/1.1 on http-7070

Oct 10, 2005 10:26:28 PM org.apache.coyote.http11.Http11Protocol init

INFO: Initializing Coyote HTTP/1.1 on http-7071

Oct 10, 2005 10:26:28 PM org.apache.catalina.startup.Catalina load

INFO: Initialization processed in 2271 ms
fak3r
Posts: 16
Joined: Fri Sep 12, 2014 9:57 pm

Login page appears, can't login - Gentoo

Postby fak3r » Tue Oct 11, 2005 10:28 am

[quote user="14319KevinH"]Ahh keystore looks like the next stopper. You need to run zmcreatecert and then zmcertinstall twice. Once for mta and once for mail box. So like:
zmcertinstall mta /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key
zmcertinstall mailbox /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key[/QUOTE]
Kevin

I don't have /opt/zimbra/ssl, and I don't see an ssl dir anywhere under Zimbra:

zimbra@jorge bin $ find /opt/zimbra/ -name ssl -print

zimbra@jorge bin $


How do I create these? I don't see anything in the install docs that I missed in regards to ssl.
Also

zimbra@jorge bin $ find /opt/zimbra/ -name ca.key -print

zimbra@jorge bin $

zimbra@jorge bin $ find /opt/zimbra -name smtpd.crt -print

zimbra@jorge bin $

fak3r
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Login page appears, can't login - Gentoo

Postby 14319KevinH » Tue Oct 11, 2005 12:04 pm

zmcreatecert will create these for you. You need to run that first. Sorry if I didn't make it clear.
fak3r
Posts: 16
Joined: Fri Sep 12, 2014 9:57 pm

Login page appears, can't login - Gentoo

Postby fak3r » Tue Oct 11, 2005 12:31 pm

Thanks Kevin, got that done, now I can do the zmcertinstall mta, but not the mailbox:
zimbra@jorge bin $ zmcertinstall mta /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key

** Importing server cert
zimbra@jorge bin $ zmcertinstall mailbox /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key

** Importing server cert
keytool error: java.lang.Exception: Public keys in reply and keystore don't match

zimbra@jorge bin $
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Login page appears, can't login - Gentoo

Postby 14319KevinH » Tue Oct 11, 2005 12:36 pm

For mailbox I think I borked the command. It should be:
zmcertinstall mailbox /opt/zimbra/ssl/ssl/server/server.crt /opt/zimbra/ssl/ssl/ca/ca.key

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: Google [Bot] and 6 guests