No_Such_Server

Ask questions about your setup or get help installing ZCS server (ZD section below).
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

No_Such_Server

Postby 14319KevinH » Mon Nov 21, 2005 10:04 am

[quote user="vpoorboy"]I have the same problem with Zimbra Binaries for FC4. It showed the same error though "etc/hosts" is "127.0.0.1 localhost.localdomain localhost"[/QUOTE]
Your /etc/hosts should have 2 lines. The 2nd line needs your real IP address and both FQDN and short host name.


chamo
Posts: 19
Joined: Fri Sep 12, 2014 10:00 pm

No_Such_Server

Postby chamo » Mon Nov 21, 2005 4:09 pm

Anyone have any suggestions on troubleshooting this No_Such_Server error I am recieving on install of M2 on a fresh install of FC3?
My domain name of the zimbra box resolves to the correct IP address on the Zimbra box using nslookup domain.domainname.com.
I was able and am still able to load M1 on a clean install of FC3 and it works without any issues..
My host file is correct and looks like this:
127.0.0.7 localhost.localdomain locahost

xx.xx.xx.xx zmail.domainname.com


anyone know anyting else that I can try in order to troubleshoot this No_Such_Server error that I receive..
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

No_Such_Server

Postby 14319KevinH » Mon Nov 21, 2005 4:51 pm

[quote user="chamo"]

127.0.0.7 localhost.localdomain locahost

xx.xx.xx.xx zmail.domainname.com

[/QUOTE]
You last line should look like:
xx.x.x.x zmail.domainname.com zmail


You were missing the local part. Are there any errors in your /tmp/install.log?
chamo
Posts: 19
Joined: Fri Sep 12, 2014 10:00 pm

No_Such_Server

Postby chamo » Mon Nov 21, 2005 5:31 pm

I left the short name off my post..

/etc/hosts does look like:
xx.xx.xx.xx zmail.domain.com zmail
install log shows the following error:

cat: /opt/zimbra/zimbramon/zimbra.cf . in: No such file or directory

ERROR: service.Failure (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
not sure if this error is becuase of a reinstall after doing several ./install.sh then ./install.sh -u
vpoorboy
Advanced member
Advanced member
Posts: 67
Joined: Fri Sep 12, 2014 9:58 pm

No_Such_Server

Postby vpoorboy » Mon Nov 21, 2005 11:21 pm

Yes, I also have the same problems. Adding the second line in /etc/hosts has no effect. Reinstalling Zimbra I faced "No such server" again. I run "zmcontrol start" and here is the error:

Host mail.test.homedns.org

Starting ldap...Done.

ERROR: account.NO_SUCH_SERVER (no such server: mail.test.homedns.org)


And the content of "/etc/hosts":
127.0.0.1       localhost.localdomain   localhost

192.168.1.33 mail.test.homedns.org mail

Note that 192.168.1.33 is the local IP that the modem assigns to my NIC. The modem has an Outside IP: a.b.c.d .But it's not static, so I use dynDNS to map it to test.homedns.org.

I've tried replacing 192.168.1.33 with a.b.c.d, but there's still the problem.
I think in my system, Zimbra doesnot rely much on "/etc/hosts". With a dns system installed maybe the problem will be solved.
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

No_Such_Server

Postby marcmac » Tue Nov 22, 2005 8:53 am

the no such server error, I believe, means the servername isn't configured in ldap - run zmprov gas, and see if the server is listed.
chamo
Posts: 19
Joined: Fri Sep 12, 2014 10:00 pm

No_Such_Server

Postby chamo » Tue Nov 22, 2005 9:19 am

When I run zmprov gas, i get the following:
ERROR: service:FAILURE (system failure: unabel to list all servers) (cause: javax.naming.NameNotFoundException [LDAP: error code 32 - No Such Object])
This is on a clean install done last night on a clean install of FC3 with yum uodate run, and all the needed installs before running ./install.sh.
any ideas?
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

No_Such_Server

Postby marcmac » Tue Nov 22, 2005 9:58 am

I'm not sure what's causing that - were there ldap errors in the install.log in /tmp? Is slapd running? (I assume that it is).
Does

/opt/zimbra/openldap/sbin/slapcat -f conf/slapd.conf | grep dn | grep servers

return a line with your server name in it?
What does zmhostname return?
chamo
Posts: 19
Joined: Fri Sep 12, 2014 10:00 pm

No_Such_Server

Postby chamo » Tue Nov 22, 2005 10:29 am

slapd is running..
running:

/opt/zimbra/openldap/sbin/slapcat -f conf/slapd.conf | grep dn | grep servers

returns 'slapcat: bad configuration file!'
running zmhostname returns my correct FQDN.


here is my install log:

Preparing packages for installation...

zimbra-core-3.0.0_M2_740.FC3-20051114171941

cat: /opt/zimbra/zimbramon/zimbra.cf.in: No such file or directory

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)

mkdir: cannot create directory `/opt/zimbra/.ssh': File exists

Preparing packages for installation...

zimbra-ldap-3.0.0_M2_740.FC3-20051114171941

cat: /opt/zimbra/zimbramon/zimbraldap.cf: No such file or directory

Preparing packages for installation...

zimbra-logger-3.0.0_M2_740.FC3-20051114171941

cat: /opt/zimbra/zimbramon/zimbralogger.cf: No such file or directory

Preparing packages for installation...

zimbra-mta-3.0.0_M2_740.FC3-20051114171941

cat: /opt/zimbra/zimbramon/zimbramta.cf: No such file or directory

Preparing packages for installation...

zimbra-snmp-3.0.0_M2_740.FC3-20051114171941

cat: /opt/zimbra/zimbramon/zimbrasnmp.cf: No such file or directory

Preparing packages for installation...

zimbra-store-3.0.0_M2_740.FC3-20051114171941

cat: /opt/zimbra/zimbramon/zimbramail.cf: No such file or directory

Preparing packages for installation...

zimbra-apache-3.0.0_M2_740.FC3-20051114171941

Preparing packages for installation...

zimbra-spell-3.0.0_M2_740.FC3-20051114171941

vpoorboy
Advanced member
Advanced member
Posts: 67
Joined: Fri Sep 12, 2014 9:58 pm

No_Such_Server

Postby vpoorboy » Tue Nov 22, 2005 10:51 am

yes, all errors Chamo had with his FC3 box are the same with mine (FC4 box). What's the problem ?

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests