can't receive local mail

Ask questions about your setup or get help installing ZCS server (ZD section below).
tachijuan
Advanced member
Advanced member
Posts: 57
Joined: Fri Sep 12, 2014 9:56 pm

can't receive local mail

Postby tachijuan » Sat Nov 26, 2005 1:14 pm

OK - had this working with M1, but can't get it to work with M2. I can send emails outbound, but no inbound mails get delivered.
I've seen a couple of threads similar to this. Both of them had a commong thread in them that the DNS service is being provided by dyndns.org.
here's a dig of my domain:
[zimbra@stud ~]$ dig orlandini.us
; <<>> DiG 9.3.1 <<>> orlandini.us

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 5
;; QUESTION SECTION:

;orlandini.us. IN A
;; ANSWER SECTION:

orlandini.us. 60 IN A 216.27.161.17
;; AUTHORITY SECTION:

orlandini.us. 43737 IN NS ns2.mydyndns.org.

orlandini.us. 43737 IN NS ns3.mydyndns.org.

orlandini.us. 43737 IN NS ns4.mydyndns.org.

orlandini.us. 43737 IN NS ns5.mydyndns.org.

orlandini.us. 43737 IN NS ns1.mydyndns.org.
;; ADDITIONAL SECTION:

ns1.mydyndns.org. 64355 IN A 63.208.196.92

ns2.mydyndns.org. 64007 IN A 204.13.249.82

ns3.mydyndns.org. 22908 IN A 63.209.15.211

ns4.mydyndns.org. 70645 IN A 213.155.150.206

ns5.mydyndns.org. 69791 IN A 63.208.196.93
;; Query time: 49 msec

;; SERVER: 207.69.188.186#53(207.69.188.186)

;; WHEN: Sat Nov 26 14:12:15 2005

;; MSG SIZE rcvd: 228


so - it seems like i have an MX and A records set right.
I've tried sending email through gmail and also through telnet to SMTP on the host. Both ways, the SMTP session completes ok, but the message does not get delivered.
Is there some place where I can see what zimbra is doing with the message after the SMTP session is complete?
Thanks!


marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

can't receive local mail

Postby marcmac » Sat Nov 26, 2005 2:32 pm

Unless I'm blind this morning - I don't see any MX records listed for your domain at all...


[quote user="tachijuan"]OK - had this working with M1, but can't get it to work with M2. I can send emails outbound, but no inbound mails get delivered.
I've seen a couple of threads similar to this. Both of them had a commong thread in them that the DNS service is being provided by dyndns.org.
here's a dig of my domain:
[zimbra@stud ~]$ dig orlandini.us
; <<>> DiG 9.3.1 <<>> orlandini.us

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 5
;; QUESTION SECTION:

;orlandini.us. IN A
;; ANSWER SECTION:

orlandini.us. 60 IN A 216.27.161.17
;; AUTHORITY SECTION:

orlandini.us. 43737 IN NS ns2.mydyndns.org.

orlandini.us. 43737 IN NS ns3.mydyndns.org.

orlandini.us. 43737 IN NS ns4.mydyndns.org.

orlandini.us. 43737 IN NS ns5.mydyndns.org.

orlandini.us. 43737 IN NS ns1.mydyndns.org.
;; ADDITIONAL SECTION:

ns1.mydyndns.org. 64355 IN A 63.208.196.92

ns2.mydyndns.org. 64007 IN A 204.13.249.82

ns3.mydyndns.org. 22908 IN A 63.209.15.211

ns4.mydyndns.org. 70645 IN A 213.155.150.206

ns5.mydyndns.org. 69791 IN A 63.208.196.93
;; Query time: 49 msec

;; SERVER: 207.69.188.186#53(207.69.188.186)

;; WHEN: Sat Nov 26 14:12:15 2005

;; MSG SIZE rcvd: 228


so - it seems like i have an MX and A records set right.
I've tried sending email through gmail and also through telnet to SMTP on the host. Both ways, the SMTP session completes ok, but the message does not get delivered.
Is there some place where I can see what zimbra is doing with the message after the SMTP session is complete?
Thanks![/QUOTE]
tachijuan
Advanced member
Advanced member
Posts: 57
Joined: Fri Sep 12, 2014 9:56 pm

can't receive local mail

Postby tachijuan » Sun Nov 27, 2005 8:03 pm

You were right. Copy pasted the wrong thing ....
here's the dig mx records:

tachijuan@shell4:~$ dig orlandini.us mx
; <<>> DiG 9.2.4 <<>> orlandini.us mx

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:

;orlandini.us. IN MX
;; ANSWER SECTION:

orlandini.us. 42381 IN MX 5 orlandini.us.
;; Query time: 1 msec

;; SERVER: 66.93.87.2#53(66.93.87.2)

;; WHEN: Sun Nov 27 17:52:37 2005

;; MSG SIZE rcvd: 46


here's a /var/log/zimbra.log copy paste of a session:
Nov 27 20:50:38 stud postfix/smtpd[30555]: connect from shell4.sea5.speakeasy.net[69.17.116.5]

Nov 27 20:50:38 stud postfix/anvil[30714]: warning: My hostname stud is not a fully qualified name - set myhostname or mydomain in /opt/zimbra/postfix-2.2.3/conf/main.cf

Nov 27 20:50:38 stud postfix/smtpd[30555]: B9E6A100F4F: client=shell4.sea5.speakeasy.net[69.17.116.5]

Nov 27 20:50:38 stud postfix/cleanup[30576]: B9E6A100F4F: message-id=

Nov 27 20:50:38 stud postfix/qmgr[6108]: B9E6A100F4F: from=, size=569, nrcpt=1 (queue active)

Nov 27 20:50:38 stud amavis[16589]: (16589-09) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20051127T150004-16589: -> Received: SIZE=569 from stud ([127.0.0.1]) by localhost (stud [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 16589-09 for ; Sun, 27 Nov 2005 20:50:38 -0500 (EST)

Nov 27 20:50:38 stud amavis[16589]: (16589-09) body hash: e92849bffd71ad8cfc61db0e5d06dfea

Nov 27 20:50:38 stud amavis[16589]: (16589-09) Checking: exVjHubebqTO [69.17.116.5] ->

Nov 27 20:50:38 stud amavis[16589]: (16589-09) p001 1 Content-Type: text/plain, size: 23 B, name:

Nov 27 20:50:38 stud amavis[16589]: (16589-09) Checking for banned types and filenames

Nov 27 20:50:38 stud amavis[16589]: (16589-09) collect banned table[0]: XXXX@orlandini.us, tables: DEFAULT=>Amavis::Lookup::RE=ARRAY(0xa2f9e20)

Nov 27 20:50:38 stud amavis[16589]: (16589-09) p.path XXXX@orlandini.us: "P=p001,L=1,M=text/plain,T=asc"

Nov 27 20:50:38 stud amavis[16589]: (16589-09) Using ClamAV-clamd: (built-in interface)

Nov 27 20:50:38 stud amavis[16589]: (16589-09) Using (ClamAV-clamd) on dir: CONTSCAN /opt/zimbra/amavisd/tmp/amavis-20051127T150004-16589/parts


Nov 27 20:50:38 stud postfix/smtpd[30555]: disconnect from shell4.sea5.speakeasy.net[69.17.116.5]

Nov 27 20:50:38 stud amavis[16589]: (16589-09) ClamAV-clamd: Connecting to socket 127.0.0.1:3310

Nov 27 20:50:38 stud amavis[16589]: (16589-09) ClamAV-clamd: Sending CONTSCAN /opt/zimbra/amavisd/tmp/amavis-20051127T150004-16589/parts
to INET socket 127.0.0.1:3310

Nov 27 20:50:38 stud amavis[16589]: (16589-09) ask_av (ClamAV-clamd): /opt/zimbra/amavisd/tmp/amavis-20051127T150004-16589/parts CLEAN

Nov 27 20:50:38 stud amavis[16589]: (16589-09) ClamAV-clamd result: clean

Nov 27 20:50:39 stud amavis[16589]: (16589-09) spam_scan: hits=-0.583 tests=[AWL=-0.147,BAYES_20=-1.951,BLANK_LINES_70_80=1.515]

Nov 27 20:50:39 stud amavis[16589]: (16589-09) lookup_ldap_attr(amavisspamkilllevel) (WARN: no such attribute in LDAP entry), "XXXX@orlandini.us" result=undef

Nov 27 20:50:39 stud amavis[16589]: (16589-09) lookup_ldap_attr(amavisspamtaglevel) (WARN: no such attribute in LDAP entry), "XXXX@orlandini.us" result=undef

Nov 27 20:50:39 stud amavis[16589]: (16589-09) lookup_ldap_attr(amavisspamtag2level) (WARN: no such attribute in LDAP entry), "XXXX@orlandini.us" result=undef

Nov 27 20:50:39 stud amavis[16589]: (16589-09) SPAM-TAG, -> , No, hits=-0.583 tagged_above=-10 required=6.6 autolearn=no tests=[AWL=-0.147, BAYES_20=-1.951, BLANK_LINES_70_80=1.515]

Nov 27 20:50:39 stud postfix/smtpd[30584]: connect from localhost.localdomain[127.0.0.1]

Nov 27 20:50:39 stud amavis[16589]: (16589-09) AUTH not needed, user='', MTA offers ''

Nov 27 20:50:39 stud postfix/smtpd[30584]: 2D400100F62: client=localhost.localdomain[127.0.0.1]

Nov 27 20:50:39 stud amavis[16589]: (16589-09) response to RCPT TO for : "250 Ok"

Nov 27 20:50:39 stud postfix/cleanup[30576]: 2D400100F62: message-id=

Nov 27 20:50:39 stud postfix/qmgr[6108]: 2D400100F62: from=, size=1113, nrcpt=1 (queue active)

Nov 27 20:50:39 stud postfix/smtpd[30584]: disconnect from localhost.localdomain[127.0.0.1]

Nov 27 20:50:39 stud amavis[16589]: (16589-09) FWD via SMTP: -> , 250 2.6.0 Ok, id=16589-09, from MTA([127.0.0.1]:10025): 250 Ok: queued as 2D400100F62

Nov 27 20:50:39 stud amavis[16589]: (16589-09) lookup_ldap_attr(amavisspamtag2level) (WARN: no such attribute in LDAP entry), "XXXX@orlandini.us" result=undef

Nov 27 20:50:39 stud amavis[16589]: (16589-09) Passed CLEAN, [69.17.116.5] [69.17.116.5] -> , Message-ID: , mail_id: exVjHubebqTO, Hits: -0.583, 402 ms

Nov 27 20:50:39 stud amavis[16589]: (16589-09) TIMING [total 414 ms] - SMTP EHLO: 7 (2%)2, SMTP pre-MAIL: 3 (1%)2, lookup_ldap: 46 (11%)14, SMTP pre-DATA-flush: 4 (1%)15, SMTP DATA: 1 (0%)15, body_hash: 2 (1%)15, gen_mail_id: 2 (0%)16, mime_decode: 20 (5%)21, get-file-type1: 16 (4%)24, decompose_part: 1 (0%)25, parts_decode: 0 (0%)25, AV-scan-1: 22 (5%)30, spam-wb-list: 9 (2%)32, SA msg read: 1 (0%)32, SA parse: 3 (1%)33, SA check: 138 (33%)66, update_cache: 5 (1%)67, deal_with_mail_size: 3 (1%)68, fwd-connect: 19 (5%)73, fwd-mail-from: 7 (2%)74, fwd-rcpt-to: 8 (2%)76, write-header: 7 (2%)78, fwd-data: 1 (0%)78, fwd-data-end: 40 (10%)88, fwd-rundown: 3 (1%)88, main_log_entry: 40 (10%)98, update_snmp: 6 (1%)99, unlink-1-files: 2 (1%)100, rundown: 1 (0%)100

Nov 27 20:50:39 stud postfix/smtp[30581]: B9E6A100F4F: to=, relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6.0 Ok, id=16589-09, from MTA([127.0.0.1]:10025): 250 Ok: queued as 2D400100F62)

Nov 27 20:50:39 stud amavis[16589]: (16589-09) extra modules loaded: Net/LDAP/Bind.pm

Nov 27 20:50:39 stud amavis[16589]: (16589-09) load: 0 %, total idle 21018.817 s, busy 16.410 s

Nov 27 20:50:39 stud postfix/qmgr[6108]: B9E6A100F4F: removed

Nov 27 20:50:39 stud postfix/lmtp[30717]: warning: My hostname stud is not a fully qualified name - set myhostname or mydomain in /opt/zimbra/postfix-2.2.3/conf/main.cf

Nov 27 20:50:39 stud postfix/bounce[30718]: warning: My hostname stud is not a fully qualified name - set myhostname or mydomain in /opt/zimbra/postfix-2.2.3/conf/main.cf

Nov 27 20:50:39 stud postfix/lmtp[30717]: 2D400100F62: to=, relay=none, delay=0, status=deferred (connect to stud.orlandini.us[216.27.161.17]: Connection refused)

and a quick look at zmcontrol status:

[zimbra@stud ~]$ zmcontrol status

Host stud.orlandini.us

antispam Running

antivirus Running

ldap Running

logger Running

mailbox Running

mta Running

snmp Running

spell Running


and some more info: running on fc3 with yum update as of monday last week. Also sitting behind a nat router with ports 25, 110, 143, and 465 pointing to the mail server (stud).
This configuration was working with M1.
This thing is soooo cool. Please help :-)
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

can't receive local mail

Postby marcmac » Mon Nov 28, 2005 10:14 am

stud postfix/lmtp[30717]: warning: My hostname stud is not a fully qualified name - set myhostname or mydomain in /opt/zimbra/postfix-2.2.3/conf/main.cf

Nov 27 20:50:39 stud postfix/bounce[30718]: warning: My hostname stud is not a fully qualified name - set myhostname or mydomain in /opt/zimbra/postfix-2.2.3/conf/main.cf

Nov 27 20:50:39 stud postfix/lmtp[30717]: 2D400100F62: to=, relay=none, delay=0, status=deferred (connect to stud.orlandini.us[216.27.161.17]: Connection refused)


The last line is attempting to deliver via LMTP, port 7025 - forward that on your firewall, too, and you should be ok.
tachijuan
Advanced member
Advanced member
Posts: 57
Joined: Fri Sep 12, 2014 9:56 pm

can't receive local mail

Postby tachijuan » Mon Nov 28, 2005 5:39 pm

thanks!
this is very cool. hosting email for three domains.
adding the second and third two took minutes.
that's very, very cool.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests