Page 1 of 1

Cannot receive mails

Posted: Sat Nov 26, 2005 7:04 pm
by zzzzsg
Hi Everybody
I installed zcs-3.0.0_M2_740.FC3.tgz on Fedora 3.
Everything seems to be working except that I cannot receive any mail, not even mails I send to myself. That is, cannot receive any mail at all. Cannot receive mail from internal Zimbra users, cannot receive mail from external users, e.g. tom@yahoo.com. I can send mails out to non-zimbra accounts though.
When I was using M1 previously, everything was okay - could receive mail.
I checked the /var/log/zimbra.log and found these
Nov 26 16:55:29 servername postfix/lmtp[31552]: 493E92C14B: to=, relay=none, delay=189, status=deferred (connect to servername.mydomainname.com[ip....]: Connection timed out)

Nov 26 16:56:00 servername postfix/qmgr[30039]: 3D1F72C147: from=, size=1118, nrcpt=1 (queue active)
I did a zmcontrol status and everything was running.
Can anybody help?
Thank you very much in anticipation.

Cannot receive mails

Posted: Sun Nov 27, 2005 1:52 pm
by marcmac
Here's what's happening here:
The servername that it's trying to connect to (on port 25) isn't resolving to an IP on your box - does the IP match the server? If it resolves to a port-forwarded firewall IP, is the firewall allowing the connection? (The fact that it's timing out, not being refused, makes me suspect firewall.)
It's possible that you're MX records aren't right - you can try turning off DNS lookups in the MTA, but you'll have to set a relay host, for all outgoing mail.

Cannot receive mails

Posted: Sun Nov 27, 2005 10:09 pm
by 14319KevinH
Also might want to run zmiptables -u to make sure iptables is now disabled.

Cannot receive mails

Posted: Mon Nov 28, 2005 11:00 am
by zzzzsg
Yes, turning off DNS works. I forgot I did the same thing on Zimbra 1.

Thank you.
[quote user="marcmac"]Here's what's happening here:
The servername that it's trying to connect to (on port 25) isn't resolving to an IP on your box - does the IP match the server? If it resolves to a port-forwarded firewall IP, is the firewall allowing the connection? (The fact that it's timing out, not being refused, makes me suspect firewall.)
It's possible that you're MX records aren't right - you can try turning off DNS lookups in the MTA, but you'll have to set a relay host, for all outgoing mail.[/QUOTE]