yikes

Ask questions about your setup or get help installing ZCS server (ZD section below).
jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

yikes

Postby jholder » Sun Nov 27, 2005 4:36 pm

So, everything was running fine... I decided today would be a good time to reboot my machine (since I havn't done it in a long time)
Well, when I did, Zimbra didn't come backup. Somtime about a

javax.naming.CommunicationException
So, I reinstalled, and I got an error with can't connecting to LDAP on port 389 (the same problem I had before.)
So I followed the instructions marcmac gave me earlier by

deleting /opt/zimbra/openldap-data/* and now it comes up great! However, all my users and data is not appearing.
I have a feelings all their stores are there. Is there anyway to re-import them?
thx


marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

yikes

Postby marcmac » Sun Nov 27, 2005 5:14 pm

You can re-import them, if you have a backup.
jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

yikes

Postby jholder » Sun Nov 27, 2005 5:28 pm

does it have to be a backup of the /opt/zimbra/openldap-data/ dir?
Also, it did so many save configs when I tried to recover. Is it possible to scavange that?
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

yikes

Postby marcmac » Sun Nov 27, 2005 5:44 pm

That, or a backup via zmbackup will dump ldap data to /opt/zimbra/backup/ldap.bak.
jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

yikes

Postby jholder » Sun Nov 27, 2005 6:00 pm

what would I need to do to extract the data from the save configs? I already erased the /opt/zimbra/openldap-data/ dir, so I think that's what I'll have to do. :p
jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

yikes

Postby jholder » Sun Nov 27, 2005 9:42 pm

I tried resetting the ldap password

[zimbra@tusd-exch01 bin]$ ldap start

db_recover: Ignoring log file: /opt/zimbra/openldap-data/log.0000000001: magic number 0, not 40988

db_recover: Invalid log file: log.0000000001: Invalid argument

db_recover: PANIC: Invalid argument

db_recover: PANIC: DB_RUNRECOVERY: Fatal error, run database recovery

db_recover: DB_ENV->open: DB_RUNRECOVERY: Fatal error, run database recovery

Started slapd: pid
jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

yikes

Postby jholder » Sun Nov 27, 2005 11:41 pm

Okay, I've read through, and tried everything that's been posted here.
No matter what I doduring the install of M2, I get the

Done

Creating server entry for tusd-exch01.tombstone.k12.az.us...*** Running as zimbra user: /opt/zimbra/bin/zmprov cs tusd-exch01.tombstone.k12.az.us

Done

Setting spell check URL to http://tusd-exch01.tombstone.k12.az.us:7780/aspell.php">http://tusd-exch01.tombstone.k12.az.us:7780/aspell.php...

*** Running as zimbra user: /opt/zimbra/bin/zmprov ms tusd-exch01.tombstone.k12.az.us zimbraSpellCheckURL http://tusd-exch01.tombstone.k12.az.us:7780/aspell.php">http://tusd-exch01.tombstone.k12.az.us:7780/aspell.php

Done

Setting service ports on tusd-exch01.tombstone.k12.az.us...

*** Running as zimbra user: /opt/zimbra/bin/zmprov ms tusd-exch01.tombstone.k12.az.us zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995

Done

Adding tusd-exch01.tombstone.k12.az.us to zimbraMailHostPool in default COS

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException tusd-exch01.tombstone.k12.az.us:389)

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException tusd-exch01.tombstone.k12.az.us:389)

Done

Creating domain tusd-exch01.tombstone.k12.az.us...

*** Running as zimbra user: /opt/zimbra/bin/zmprov cd tusd-exch01.tombstone.k12.az.us

*** Running as zimbra user: /opt/zimbra/bin/zmprov mcf zimbraDefaultDomainName tusd-exch01.tombstone.k12.az.us

Done

Creating user admin@tusd-exch01.tombstone.k12.az.us...

*** Running as zimbra user: /opt/zimbra/bin/zmprov

Done

Creating postmaster alias...

*** Running as zimbra user: /opt/zimbra/zmprov aaa admin@tusd-exch01.tombstone.k12.az.us root@tusd-exch01.tombstone.k12.az.us

*** Running as zimbra user: /opt/zimbra/zmprov aaa admin@tusd-exch01.tombstone.k12.az.us postmaster@tusd-exch01.tombstone.k12.az.us

Done

*** Running as zimbra user: /opt/zimbra/bin/zmprov mcf zimbraLogHostname tusd-exch01.tombstone.k12.az.us

Initializing mta config...

*** Running as zimbra user: /opt/zimbra/libexec/zmmtainit

Done

Configuring SNMP...

Setting local config snmp_notify to yes

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e snmp_notify=yes

Setting local config smtp_notify to yes

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e smtp_notify=yes

Setting local config snmp_trap_host to tusd-exch01.tombstone.k12.az.us

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e snmp_trap_host=tusd-exch01.tombstone.k12.az.us

Setting local config smtp_source to admin@tusd-exch01.tombstone.k12.az.us

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e smtp_source=admin@tusd-exch01.tombstone.k12.az.us

Setting local config smtp_destination to admin@tusd-exch01.tombstone.k12.az.us

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e smtp_destination=admin@tusd-exch01.tombstone.k12.az.us

*** Running as zimbra user: /opt/zimbra/libexec/zmsnmpinit

Done

Configuring Spell server...

Done

Setting services on tusd-exch01.tombstone.k12.az.us

*** Running as zimbra user: /opt/zimbra/bin/zmprov ms tusd-exch01.tombstone.k12.az.us zimbraServiceInstalled antivirus zimbraServiceInstalled antispam zimbraServiceInstalled logger zimbraServiceInstalled mailbox zimbraServiceInstalled mta zimbraServiceInstalled snmp zimbraServiceInstalled ldap zimbraServiceInstalled spell

*** Running as zimbra user: /opt/zimbra/bin/zmprov ms tusd-exch01.tombstone.k12.az.us zimbraServiceEnabled antivirus zimbraServiceEnabled antispam zimbraServiceEnabled spell zimbraServiceEnabled logger zimbraServiceEnabled mailbox zimbraServiceEnabled mta zimbraServiceEnabled snmp zimbraServiceEnabled ldap zimbraServiceEnabled spell

Done

*** Running as zimbra user: /opt/zimbra/bin/zmcontrol start

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException tusd-exch01.tombstone.k12.az.us:389)


I'm pretty sure it is a password syncing issue. I've tries resetting it with zmldappasswd utility (the normal one and the root one).
I still get the same error.
Any ideas??? Pleese??
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

yikes

Postby marcmac » Mon Nov 28, 2005 10:11 am

It's not a password syncing issue - the issue is, you deleted your ldap database, which is why ldap won't start - it can't find any DB files.
Does the /opt/zimbra/openldap-data directory still exist? If not, re-create it.
Once that's done, start ldap - if it starts, you can re-run the /opt/zimbra/libexec/zmldapinit step by hand - but you're still not going to have any users, preferences, servers, etc configured, so you won't be able to start anything.
If you don't have an ldap backup, you're pretty much in the position of having to re-install, and recreate all the users.
You may try copying all of your messages to another place, then re-injecting them after you reinstall (search the forums for lmtpinject)

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 9 guests