M2 -> M3 upgrade

Ask questions about your setup or get help installing ZCS server (ZD section below).
gutzeit
Posts: 19
Joined: Fri Sep 12, 2014 10:00 pm

M2 -> M3 upgrade

Postby gutzeit » Sun Jan 08, 2006 7:10 am

Hi,
I am running M2 version with no problems. I have active users on it and seems to work well.
I want to upgrade to M3 but I am bit scared since the last time I upgraded (M1->M2) it was not smooth, and I had to recreate all the users manually and to import user emails from a backup.
Is upgrade procedure/scripts is a part of M3 release ?
Did anyone upgraded from M2 to M3 ?
Are there any issues that I should be aware of ?
Thanks in advance.


marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

M2 -> M3 upgrade

Postby marcmac » Sun Jan 08, 2006 11:01 am

The upgrade is built into the installer, and it's much, much, much smoother than before. The system will detect the version you had, modify what needs to be modified in the dbs, and your user base, etc, will be retained.
8615slayer
Posts: 8
Joined: Fri Sep 12, 2014 10:02 pm

M2 -> M3 upgrade

Postby 8615slayer » Sun Jan 08, 2006 11:53 pm

Will be doing an upgrade later on my test platform (CentOS 4.2) using RHEL4 binary M3 release. Will let you guys know what transpired.
gutzeit
Posts: 19
Joined: Fri Sep 12, 2014 10:00 pm

M2 -> M3 upgrade

Postby gutzeit » Mon Jan 09, 2006 1:31 am

I've done the upgrade and the process was smooth and painless, except one issue.
Zimbra Tomcat on my installation works on different server port (not 8005), and this setting was overwritten by Zimbra.
Thanks.
FunkyPenguin
Advanced member
Advanced member
Posts: 140
Joined: Fri Sep 12, 2014 10:02 pm

M2 -> M3 upgrade

Postby FunkyPenguin » Mon Jan 09, 2006 8:48 am

I've just upgraded from M2 to M3, and everything went relatively smoothly. The only error I had was a port conflict warning on LDAP/LDAPS. When I checked all seemed ok; so I proceeded to check the Admin Console, again all seems ok. I then went to log in via the web UI and then I hit a stickler, nothing :(
I had M2 configured to use https, so I thought that maybe the upgrade had changed it to use http by default, so I ran zmtlsctl https and restarted tomcat. Still no luck :( I can send and recieve mail via ThunderBird and Outlook, but not the web UI. Anyone got any idea?
Oh while I remember I get a 500 error when I try and notify Zimbra of my installation. The link that was generated by the install is:
http://www.zimbra.com/cgi-bin/notify.cgi?VER=3.0.0_M3_436&MAIL=admin@hawk.forcev.net
goetzi
Advanced member
Advanced member
Posts: 184
Joined: Fri Sep 12, 2014 9:59 pm

M2 -> M3 upgrade

Postby goetzi » Mon Jan 09, 2006 8:51 am

When I upgraded the warning with the LDAP port conflict also showed up.
After the upgrade the server was configured to use http. I changed it to https, restartet the tomcat server, but when I wanted to access the web GUI, it didn't work. So i restarted the whole zimbra server, now it is working fine.
FunkyPenguin
Advanced member
Advanced member
Posts: 140
Joined: Fri Sep 12, 2014 10:02 pm

M2 -> M3 upgrade

Postby FunkyPenguin » Mon Jan 09, 2006 9:05 am

Looks like I just needed to be patient :p After about 10mins all worked fine. The upgrade was probably as painless as any application I used, and definately the best for an OpenSource collaboration product :D Nice one chaps
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

M2 -> M3 upgrade

Postby marcmac » Mon Jan 09, 2006 11:53 am

Glad it went smoothly - we learned our lesson on that one :)
I'll check out the http/https mode setting retention. I'm in that code making it easier to change the ports, so I'll see what's up with the upgrade.
8615slayer
Posts: 8
Joined: Fri Sep 12, 2014 10:02 pm

M2 -> M3 upgrade

Postby 8615slayer » Mon Jan 09, 2006 8:06 pm

Here's what happen with my upgrade (M2 to M3 on CentOS 4.2):
1.) The install scripts is generating tons of this, i even got a file open limit error at one time.
16310 tty1 S+ 0:00 /bin/bash /bin/unicode_start latarcyrheb-sun16
2.) Upgrade failed and tried to override my previous installation, left it at 6pm yesterday and its not yet done until now and still generating tons of unicode_start tasks.


Apologies to the Zimbra guys, i know CentOS is not officially supported yet.
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

M2 -> M3 upgrade

Postby marcmac » Mon Jan 09, 2006 8:28 pm

Try export LANG=C before you run the script

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests