How to move 8.7.1 from 14.04 to 16.04

Ask questions about your setup or get help installing ZCS server (ZD section below).
stunningIT
Posts: 6
Joined: Sun Jan 01, 2017 1:54 am

How to move 8.7.1 from 14.04 to 16.04

Postby stunningIT » Sun Jan 01, 2017 2:03 am

Hi to all of you and a happy new year! ;-)

Since three days I'm trying to move my Ubuntu 14.04 / Zimbra 8.7.1 installation to a new VM (16.04) and I don't get it. I must be doing something terribly wrong and need you help.
Please tell me the correct way - what and when do I have to do what to move the zimbra installation to the new server?

At last I tried this one: https://wiki.zimbra.com/wiki/How_to_mov ... her_server
But it didn't work out either.

Please - does anybody know how I can accomplish this server move?

Thanks a lot,
Michael


phoenix
Ambassador
Ambassador
Posts: 26448
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: How to move 8.7.1 from 14.04 to 16.04

Postby phoenix » Sun Jan 01, 2017 1:05 pm

It really isn't much use posting an "... it doesn't work" thread without giving details of exactly what went wrong, what steps you've taken to resolve the problem and with thread/post you've used to try and fix the problem. Having said that, I'd recommend that you use the ZeXtras Migration Tool to move your installation from one server to another - it's easy, it works and it's free to use and you can also find that recommendation (usually by me) all over the forums.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
stunningIT
Posts: 6
Joined: Sun Jan 01, 2017 1:54 am

Re: How to move 8.7.1 from 14.04 to 16.04

Postby stunningIT » Mon Jan 02, 2017 11:56 am

Hi Bill, hi all ;-)

thank you for answering. I know, without any provided information the crystal ball is what is needed. :-(
At the time of writing my post I still tested around with moving the server. So now I will provide some information.
So I just wanted to know if generally there are any known problems when moving to a new server or if my assumptions or the way I was trying to move the server is generally right or not. That was my intent when writing my first post.

Bill, is it possible to do a server migration without using third party software like the Zextras migration tool you recommended? I saw this recommendation a lot of times here in the forums while searching, but I really want to do this by hand and let no software do some unknown magic. Hope you understand that. Just for my understanding - why do you prefer using Zextras migration tool?

All right. What do we have. This is what I've done so far.

Steps 1-6 are from: https://wiki.zimbra.com/wiki/Ajcody-Notes-Server-Move
  1. Preparation: Install Ubuntu 16.04 on fresh VM, configure it with exact the same network settings like 14.04 VM. Difference: Name of network device now ens160 instead of eth0. So everything runs smooth. IP okay, DNS okay, Gateway okay, Files hosts, hostname, resolv.conf okay - like the old (at the moment running) server
  2. Storage mount points exact like the old server: Zimbra has it's own VMDK, 500GB mountet on /opt and formatted as ext4. For importing data from old Zimbra server I temporary mount the VMDK of the old server at the new server on /opt-OLD-ZIMBRA
  3. install Zimbra with "install.sh -s" from /ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114/
  4. rsync -avH --exclude='data/ldap/*' --progress /opt-OLD-ZIMBRA/zimbra/ /opt/zimbra
  5. rsync -avHS --delete --progress /opt-OLD-ZIMBRA/zimbra/ /opt/zimbra
  6. /opt/zimbra/libexec/zmfixperms --verbose --extended


Next steps 7-20 (in this list 1-14, this is weird) are from: https://wiki.zimbra.com/wiki/How_to_mov ... her_server
  1. chown root:postdrop /opt/zimbra/common/sbin/postqueue
  2. chown root:postdrop /opt/zimbra/common/sbin/postdrop
  3. chmod g+s /opt/zimbra/common/sbin/postqueue
  4. chmod g+s /opt/zimbra/common/sbin/postdrop
  5. cd /opt/zimbra/common/
  6. chown root.root *
  7. chown root.zimbra conf/
  8. chown -R root.root libexec/
  9. chown -R root.root bin/
  10. cd conf
  11. chown root.zimbra *
  12. chown zimbra.zimbra master.cf master.cf.in bysender bysender.lmdb tag_as_foreign.re tag_as_foreign.re.in tag_as_originating.re tag_as_originating.re.in
  13. chown root.root snmp.conf main.cf
  14. postfix check


This is what I get at point 12:

Code: Select all

Output from 12:
chown: cannot access 'bysender': No such file or directory
chown: cannot access 'bysender.lmdb': No such file or directory


This is what I get at point 14:

Code: Select all

Output from 14:
The program 'postfix' is currently not installed. You can install it by typing:
apt install postfix




The output from the first command "install.sh -s" is just as normal as it could be.
The output from the second command "install.sh" is this: (command output as well as logfile in the code-block)

Code: Select all

===========================================================================
root@mail:/ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114#
root@mail:/ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114#
root@mail:/ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114# ./install.sh

Operations logged to /tmp/install.log.9PRwU3R6
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.7.1.GA.1670.UBUNTU16.64
    zimbra-logger...FOUND zimbra-logger-8.7.1.GA.1670.UBUNTU16.64
    zimbra-mta...FOUND zimbra-mta-8.7.1.GA.1670.UBUNTU16.64
    zimbra-dnscache...FOUND zimbra-dnscache-8.7.1.GA.1670.UBUNTU16.64
    zimbra-snmp...FOUND zimbra-snmp-8.7.1.GA.1670.UBUNTU16.64
    zimbra-store...FOUND zimbra-store-8.7.1.GA.1670.UBUNTU16.64
    zimbra-apache...FOUND zimbra-apache-8.7.1.GA.1670.UBUNTU16.64
    zimbra-spell...FOUND zimbra-spell-8.7.1.GA.1670.UBUNTU16.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-1.4.25-1zimbra8.7b1.16.04
    zimbra-proxy...FOUND zimbra-proxy-8.7.1.GA.1670.UBUNTU16.64
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.7.1.GA.1670.UBUNTU16.64
ZCS upgrade from 8.7.1 to 8.7.1 will be performed.
Validating ldap configuration
Unknown Error: It should be impossible to reach this statement.
===========================================================================


Log-Datei /tmp/install.log.9PRwU3R6:
===========================================================================
root@mail:/tmp#
root@mail:/tmp# cat install.log.9PRwU3R6
COMMAND: ldap start
Started slapd: pid 13418
root@mail:/tmp#
root@mail:/tmp#
===========================================================================





I get this output when I run the script "install.sh --skip-upgrade-check": (command output as well as logfile in the code-block)

Code: Select all

===========================================================================
root@mail:/ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114#
root@mail:/ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114#
root@mail:/ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114# ./install.sh --skip-upgrade-check

Operations logged to /tmp/install.log.VdbK2B37
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.7.1.GA.1670.UBUNTU16.64
    zimbra-logger...FOUND zimbra-logger-8.7.1.GA.1670.UBUNTU16.64
    zimbra-mta...FOUND zimbra-mta-8.7.1.GA.1670.UBUNTU16.64
    zimbra-dnscache...FOUND zimbra-dnscache-8.7.1.GA.1670.UBUNTU16.64
    zimbra-snmp...FOUND zimbra-snmp-8.7.1.GA.1670.UBUNTU16.64
    zimbra-store...FOUND zimbra-store-8.7.1.GA.1670.UBUNTU16.64
    zimbra-apache...FOUND zimbra-apache-8.7.1.GA.1670.UBUNTU16.64
    zimbra-spell...FOUND zimbra-spell-8.7.1.GA.1670.UBUNTU16.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-1.4.25-1zimbra8.7b1.16.04
    zimbra-proxy...FOUND zimbra-proxy-8.7.1.GA.1670.UBUNTU16.64
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.7.1.GA.1670.UBUNTU16.64
ZCS upgrade from 8.7.1 to 8.7.1 will be performed.


----------------------------------------------------------------------
PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
SYNACOR, INC. ("SYNACOR") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

License Terms for this Zimbra Collaboration Suite Software:
https://www.zimbra.com/license/zimbra-public-eula-2-6.html
----------------------------------------------------------------------



Do you agree with the terms of the software license agreement? [N] y



Checking current number of databases...

Do you want to verify message store database integrity? [Y] n

Checking for installable packages

Found zimbra-core
Found zimbra-ldap
Found zimbra-logger
Found zimbra-mta
Found zimbra-dnscache
Found zimbra-snmp
Found zimbra-store
Found zimbra-apache
Found zimbra-spell
Found zimbra-memcached
Found zimbra-proxy



Use Zimbra's package repository [Y]
Configuring package repository

The Zimbra Collaboration Server appears to already be installed.
It can be upgraded with no effect on existing accounts,
or the current installation can be completely removed prior
to installation for a clean install.

Do you wish to upgrade? [Y]

Scanning for any new or additional packages available for installation
Existing packages will be upgraded
    Upgrading zimbra-core
    Upgrading zimbra-ldap
    Upgrading zimbra-logger
    Upgrading zimbra-mta
    Upgrading zimbra-dnscache
    Upgrading zimbra-snmp
    Upgrading zimbra-store
    Upgrading zimbra-apache
    Upgrading zimbra-spell
    Upgrading zimbra-memcached
    Upgrading zimbra-proxy
Checking required space for zimbra-core
Checking space for zimbra-store
Checking required packages for zimbra-store
zimbra-store package check complete.

Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-dnscache
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell
    zimbra-memcached
    zimbra-proxy

The system will be modified.  Continue? [N] y
Installing packages

zimbra-core will be downloaded.
zimbra-ldap will be downloaded.
zimbra-logger will be downloaded.
zimbra-mta will be downloaded.
zimbra-dnscache will be downloaded.
zimbra-snmp will be downloaded.
zimbra-store will be downloaded.
zimbra-apache will be downloaded.
zimbra-spell will be downloaded.
zimbra-memcached will be downloaded.
zimbra-proxy will be downloaded.
Downloading packages. This will not modify the system. This may take some time.

Saving existing configuration file to /opt/zimbra/.saveconfig

Shutting down zimbra mail

Backing up the ldap database...done.
Upgrading the remote packages

Removing deployed webapp directories
Local packages  zimbra-core zimbra-ldap zimbra-logger zimbra-mta zimbra-dnscache zimbra-snmp zimbra-store zimbra-apache zimbra-spell zimbra-proxy selected for installation
Monitor /tmp/install.log.VdbK2B37 for package installation progress
Remote package installation started
Installing zimbra-core-components  zimbra-ldap-components zimbra-mta-components zimbra-dnscache-components zimbra-snmp-components zimbra-store-components zimbra-apache-components zimbra-spell-components zimbra-memcached zimbra-proxy-components....done
Local package installation started
Installing  zimbra-core zimbra-ldap zimbra-logger zimbra-mta zimbra-dnscache zimbra-snmp zimbra-store zimbra-apache zimbra-spell zimbra-proxy...done
done

Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
   HOSTNAME=mail.ourdomain.de
   LDAPHOST=mail.ourdomain.de
   LDAPPORT=389
   SNMPTRAPHOST=mail.ourdomain.de
   SMTPSOURCE=admin@ourdomain.de
   SMTPDEST=admin@ourdomain.de
   SNMPNOTIFY=yes
   SMTPNOTIFY=yes
   LDAPROOTPW=*
   LDAPZIMBRAPW=*
   LDAPPOSTPW=*
   LDAPREPPW=*
   LDAPAMAVISPW=*
   LDAPNGINXPW=*
Restoring existing configuration file from /opt/zimbra/.saveconfig/localconfig.xml...done
./install.sh: line 336: 26700 Segmentation fault      (core dumped) /opt/zimbra/libexec/zmsetup.pl
root@mail:/ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114#
root@mail:/ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114#
root@mail:/ADMIN/zcs-8.7.1_GA_1670.UBUNTU16_64.20161025045114#
===========================================================================




Log-Datei /tmp/install.log.VdbK2B37:
===========================================================================
root@mail:/tmp#
root@mail:/tmp#
root@mail:/tmp# cat install.log.VdbK2B37
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
apt-transport-https is already the newest version (1.2.15ubuntu0.2).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Holen:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
OK:2 http://de.archive.ubuntu.com/ubuntu xenial InRelease
Holen:3 http://de.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Holen:4 http://de.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
OK:5 https://repo.zimbra.com/apt/87 xenial InRelease
Es wurden 306 kB in 0 s geholt (368 kB/s).
Paketlisten werden gelesen...
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
zimbra-apache-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-core-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-dnscache-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-ldap-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-memcached is already the newest version (1.4.25-1zimbra8.7b1.16.04).
zimbra-mta-components is already the newest version (1.0.2-1zimbra8.7b1.16.04).
zimbra-proxy-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-snmp-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-spell-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-store-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
COMMAND: zmlocalconfig -e zimbra_java_home=/opt/zimbra/common/lib/jvm/java
COMMAND: zmlocalconfig -e mailboxd_truststore=/opt/zimbra/common/lib/jvm/java/jre/lib/security/cacerts
COMMAND: zmlocalconfig -s | sed -e "s/ = \(.*\)/=\'\1\'/" > /opt/zimbra/.saveconfig/config.save
COMMAND: zmcontrol shutdown
COMMAND: /opt/zimbra/libexec/zmslapcat /opt/zimbra/data/ldap
REMOTE PACKAGES: zimbra-core-components  zimbra-ldap-components zimbra-mta-components zimbra-dnscache-components zimbra-snmp-components zimbra-store-components zimbra-apache-components zimbra-spell-components zimbra-memcached zimbra-proxy-components
LOCAL PACKAGES:  zimbra-core zimbra-ldap zimbra-logger zimbra-mta zimbra-dnscache zimbra-snmp zimbra-store zimbra-apache zimbra-spell zimbra-proxy
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
zimbra-apache-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-core-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-dnscache-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-ldap-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-memcached is already the newest version (1.4.25-1zimbra8.7b1.16.04).
zimbra-mta-components is already the newest version (1.0.2-1zimbra8.7b1.16.04).
zimbra-proxy-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-snmp-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-spell-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
zimbra-store-components is already the newest version (1.0.0-1zimbra8.7b1.16.04).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
(Lese Datenbank ... 128844 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../zimbra-core_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-core (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
Vorbereitung zum Entpacken von .../zimbra-ldap_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-ldap (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
Vorbereitung zum Entpacken von .../zimbra-logger_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-logger (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
Vorbereitung zum Entpacken von .../zimbra-mta_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-mta (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
Vorbereitung zum Entpacken von .../zimbra-dnscache_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-dnscache (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
Vorbereitung zum Entpacken von .../zimbra-snmp_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-snmp (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
Vorbereitung zum Entpacken von .../zimbra-store_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-store (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
Vorbereitung zum Entpacken von .../zimbra-apache_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-apache (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
Vorbereitung zum Entpacken von .../zimbra-spell_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-spell (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
Vorbereitung zum Entpacken von .../zimbra-proxy_8.7.1.GA.1670.UBUNTU16.64_amd64.deb ...
Entpacken von zimbra-proxy (8.7.1.GA.1670.UBUNTU16.64) über (8.7.1.GA.1670.UBUNTU16.64) ...
zimbra-core (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start runlevel arguments (2 5) do not match zimbra Default-Start values (3 5)
insserv: Service nscd has to be enabled to start service zimbra
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
zimbra-ldap (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
zimbra-logger (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
zimbra-mta (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
zimbra-dnscache (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
zimbra-snmp (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
zimbra-store (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
zimbra-apache (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
zimbra-spell (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
zimbra-proxy (8.7.1.GA.1670.UBUNTU16.64) wird eingerichtet ...
root@mail:/tmp#
root@mail:/tmp#
root@mail:/tmp#
===========================================================================




Okay. This is what I can provide right now.
I hope this is not to much information at one time.
And of course I really hope anyone can chip in with some useful thoughts ;-)

Cheers,
Michael
phoenix
Ambassador
Ambassador
Posts: 26448
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: How to move 8.7.1 from 14.04 to 16.04

Postby phoenix » Mon Jan 02, 2017 12:13 pm

That is the sort of information that covers what you've done and thanks for posting that. If you really want the easiest and most foolproof method I'd still point to to the ZeXtras Migration Tool: https://www.zextras.com/suite/migration-tool/

That really would provide you with the easiest and less error prone that any other method available. If you're moving to a new VM then you could take a snapshot of it's current state the try the ZeXtras tool and see how you get on with that.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
stunningIT
Posts: 6
Joined: Sun Jan 01, 2017 1:54 am

Re: How to move 8.7.1 from 14.04 to 16.04

Postby stunningIT » Mon Jan 02, 2017 1:26 pm

Hi Bill,

thanks a lot for your reply.
I don't want a fool-proof method. ;-) :-D
I really want to know what data has to go where, and want to see and verify with a manual server move / installation that everything is in the right place.
Sorry, but I really really really don't like black software magic ;-)

Would you (or someone else of course ;-) ) mind helping me out the manual way, please?

Michael
stunningIT
Posts: 6
Joined: Sun Jan 01, 2017 1:54 am

Re: How to move 8.7.1 from 14.04 to 16.04

Postby stunningIT » Wed Jan 04, 2017 11:58 am

Hi again ;-)

So there is absolutely no other possibility than to use Zextras migration tool?
This is really weird.. So noone has the chance ever again to move the server without using your Zextras tool.
Sorry, but I think I must be missing something here.

It really took me quite a time to post all this information. Format it so that it doesn't look poorly and I think it took me quite some effort to get things sorted.
And that should it be? No more idea? Just "use the software and everything will be fine" ??

Maybe Zimbra is not any longer the right product for us, when you now can't move a server anymore. Till now this is what I used to do since Zimbra 5. And now it's impossible to do it manually. You are advised to use a black magic software tool where you can't know what this software does... To me this doesn't feel right. I want to have full control and know what I'm doing. Especially in this scenario, in this case of moving a server to a new one.

And that's why I am asking for help here in the forums. ;-)

Cheers,
Michael
stunningIT
Posts: 6
Joined: Sun Jan 01, 2017 1:54 am

Re: How to move 8.7.1 from 14.04 to 16.04

Postby stunningIT » Mon Jan 09, 2017 12:25 pm

Is it possible that I'm hitting bug #107436 which is pinned now in the installation and upgrade forum?
I'm not performing an upgrade. But maybe this correlates somehow?
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2773
Joined: Thu May 22, 2014 4:47 pm

Re: How to move 8.7.1 from 14.04 to 16.04

Postby jorgedlcruz » Mon Jan 09, 2017 2:33 pm

Hi,
Please allow me a couple of days to try to have QA to perform a migration like you are trying.

Best regards
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
stunningIT
Posts: 6
Joined: Sun Jan 01, 2017 1:54 am

Re: How to move 8.7.1 from 14.04 to 16.04

Postby stunningIT » Wed Jan 11, 2017 2:08 pm

Hi jorgedlcruz,

jorgedlcruz wrote:Hi, Please allow me a couple of days to try to have QA to perform a migration like you are trying.


yes of course, no problem.

Cheers,
Michael
joebitcoinorg
Posts: 6
Joined: Mon Jan 30, 2017 6:44 pm

Re: How to move 8.7.1 from 14.04 to 16.04

Postby joebitcoinorg » Tue Jan 31, 2017 6:30 am

Yes, a detailed understanding of what goes where for the internals of Zimbra seem to be necessary.
I'm in disaster recovery mode here. The Operating system was inadvertently upgraded from 14.04 to 16.04.

The system is in shambles and there is no way to use a migration tool, because there is no longer a working server for such software to connect to.

I think that part of my issue was that in an effort to get the new binaries on and since the new ./install.sh wouldn't run right after the upgrade of the os, I got creative and did a dpkg -i * for everything in the packages directory of the extracted installer archive. I'm thinking that these are supposed to be installed with some extra parameters to target their install directory into the /opt/zimbra area, because I had some zimbra components getting installed in places other than /opt/zimbra.

Oh well next I'll try this one again since it now seems that everything is installable within /opt/zimbra.

I'm still waiting for a call from Zimbra so I can get pricing for assistance with the Open Source Zimbra system. In the mean while I'll press on here and with the IRC channel.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests