(SOLVED) Error moving from Ubuntu 14.04 to 16.04: It should be impossible to reach this statement.

Ask questions about your setup or get help installing ZCS server (ZD section below).
rdlarkin
Posts: 2
Joined: Mon Sep 04, 2017 5:32 pm

(SOLVED) Error moving from Ubuntu 14.04 to 16.04: It should be impossible to reach this statement.

Postby rdlarkin » Mon Sep 04, 2017 5:51 pm

I am trying to migrate my Zimbra server from one running Ubuntu 14.04 to 16.04. I have followed the instructions found here: https://wiki.zimbra.com/wiki/How_to_mov ... her_server

Everything works up until the point where I am running the final install.sh script at which point the following occurs:

Checking for existing installation...
zimbra-chat...FOUND zimbra-chat-1.0.6-1zimbra8.7b1.u16
zimbra-drive...FOUND zimbra-drive-1.0.6-1zimbra8.7b1.u16
zimbra-suiteplus...NOT FOUND
zimbra-ldap...FOUND zimbra-ldap-8.7.11.GA.1854.UBUNTU16.64
zimbra-logger...FOUND zimbra-logger-8.7.11.GA.1854.UBUNTU16.64
zimbra-mta...FOUND zimbra-mta-8.7.11.GA.1854.UBUNTU16.64
zimbra-dnscache...FOUND zimbra-dnscache-8.7.11.GA.1854.UBUNTU16.64
zimbra-snmp...FOUND zimbra-snmp-8.7.11.GA.1854.UBUNTU16.64
zimbra-store...FOUND zimbra-store-8.7.11.GA.1854.UBUNTU16.64
zimbra-apache...FOUND zimbra-apache-8.7.11.GA.1854.UBUNTU16.64
zimbra-spell...FOUND zimbra-spell-8.7.11.GA.1854.UBUNTU16.64
zimbra-convertd...NOT FOUND
zimbra-memcached...FOUND zimbra-memcached-1:1.4.37-2.u16
zimbra-proxy...FOUND zimbra-proxy-8.7.11.GA.1854.UBUNTU16.64
zimbra-archiving...NOT FOUND
zimbra-core...FOUND zimbra-core-8.7.11.GA.1854.UBUNTU16.64
ZCS upgrade from 8.7.11 to 8.7.11 will be performed.
Validating ldap configuration
Unknown Error: It should be impossible to reach this statement.

The contents of the log file created are simply:

COMMAND: ldap start
Started slapd: pid 1649

I am unable to find anything referencing this error with a resolution, does anyone have any ideas?
Last edited by rdlarkin on Mon Sep 25, 2017 9:06 pm, edited 1 time in total.


wryfi
Posts: 11
Joined: Sat Sep 13, 2014 1:53 am

Re: Error moving from Ubuntu 14.04 to 16.04: It should be impossible to reach this statement.

Postby wryfi » Sun Sep 10, 2017 2:19 am

I had a similar problem when I tried to move my 8.7.11 instance from ubuntu-12.04 to ubuntu-16.04.

I created my new 16.04 machine and installed the correct version of zcs on it. Then I stopped zimbra and mounted my existing installation of the same version at /opt/zimbra, then tried to run ./install.sh.

I got a similar error, but in my case, the message was more specific in mentioning some missing perl:

Code: Select all

> sudo ./install.sh

Operations logged to /tmp/install.log.pAatGaDu
Checking for existing installation...
    zimbra-chat...FOUND zimbra-chat-1.0.6-1zimbra8.7b1.u16
    zimbra-drive...FOUND zimbra-drive-1.0.6-1zimbra8.7b1.u16
    zimbra-suiteplus...NOT FOUND
    zimbra-ldap...FOUND zimbra-ldap-8.7.11.GA.1854.UBUNTU16.64
    zimbra-logger...FOUND zimbra-logger-8.7.11.GA.1854.UBUNTU16.64
    zimbra-mta...FOUND zimbra-mta-8.7.11.GA.1854.UBUNTU16.64
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...FOUND zimbra-snmp-8.7.11.GA.1854.UBUNTU16.64
    zimbra-store...FOUND zimbra-store-8.7.11.GA.1854.UBUNTU16.64
    zimbra-apache...FOUND zimbra-apache-8.7.11.GA.1854.UBUNTU16.64
    zimbra-spell...FOUND zimbra-spell-8.7.11.GA.1854.UBUNTU16.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-1:1.4.37-2.u16
    zimbra-proxy...FOUND zimbra-proxy-8.7.11.GA.1854.UBUNTU16.64
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.7.11.GA.1854.UBUNTU16.64
ZCS upgrade from 8.7.11 to 8.7.11 will be performed.
Validating ldap configuration
/usr/bin/perl: symbol lookup error: /opt/zimbra/common/lib/perl5//x86_64-linux-gnu-thread-multi/auto/Socket/Socket.so: undefined symbol: Perl_xs_apiversion_bootcheck
Unknown Error: It should be impossible to reach this statement.


I was able to resolve this be reinstalling all of the zimbra perl modules into my old zimbra installation:

Code: Select all

for pkg in $(dpkg -l | grep zimbra | grep perl | awk '{print $2}'); do sudo apt-get install --reinstall $pkg; done


After this, running ./install.sh succeeded successfully, detecting my previous install and "upgrading" it to the same version.
rdlarkin
Posts: 2
Joined: Mon Sep 04, 2017 5:32 pm

Re: (SOLVED) Error moving from Ubuntu 14.04 to 16.04: It should be impossible to reach this statement.

Postby rdlarkin » Mon Sep 25, 2017 9:08 pm

Thank you wryfi, that code worked and fixed the issue. I should note that if using rsync to copy the data the code must be run after the final rsync, any further rsync will require you to run the code provided by wryfi again.
johnroberts
Posts: 31
Joined: Sat Sep 13, 2014 2:43 am

Re: Error moving from Ubuntu 14.04 to 16.04: It should be impossible to reach this statement.

Postby johnroberts » Mon Jan 28, 2019 4:50 pm

wryfi wrote:I had a similar problem when I tried to move my 8.7.11 instance from ubuntu-12.04 to ubuntu-16.04.

I created my new 16.04 machine and installed the correct version of zcs on it. Then I stopped zimbra and mounted my existing installation of the same version at /opt/zimbra, then tried to run ./install.sh.

I was able to resolve this be reinstalling all of the zimbra perl modules into my old zimbra installation:

Code: Select all

for pkg in $(dpkg -l | grep zimbra | grep perl | awk '{print $2}'); do sudo apt-get install --reinstall $pkg; done

After this, running ./install.sh succeeded successfully, detecting my previous install and "upgrading" it to the same version.

A massive thank you wryfi. I was doing the same upgrade (8.7.11 from ubuntu-12.04 to ubuntu-16.04) which almost came to a sad end until I saw your post here. You saved a long and mission critical upgrade.

Thank you very much for taking the time to post your solution!

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests