8.8.12 Proxy+MTA install - proxy and mta won't start, no config and wrong paths

Ask questions about your setup or get help installing ZCS server (ZD section below).
Posts: 6
Joined: Tue May 21, 2019 7:12 am
Location: Canada
ZCS/ZD Version: Release 8.8.12.GA.3794.UBUNTU16.64

8.8.12 Proxy+MTA install - proxy and mta won't start, no config and wrong paths

Postby loadaccess_jt » Wed Jun 26, 2019 5:42 am

I just tried doing a new install of 8.8.12 on Ubuntu 16.04, with MTA, SNMP, MEMCACHED and PROXY, but proxy and mta won't start because the folders / configs don't exist.

Starting proxy...failed. /opt/zimbra/conf/nginx.conf is missing.

And in zimbra.log...
fatal: chdir(/opt/zimbra/postfix/sbin): No such file or directory

I did the install a week or two ago in a lab setup and it worked perfectly. Can't figure out what's different here. I followed the guides exactly as I did before.
I even tried doing install.sh -s, and removing/re-installing to see if the install buggered up, but get the same result.

When I do a 'which postfix' it shows me the correct path (same as in my lab) '/opt/zimbra/bin/postfix', but it appears that some where the configs are pointing to the old locations.

All the older installs have symlinks to the /opt/zimbra/postfix-<version> location, but that doesn't exist in my lab env, so I'm assuming that's been changed.

I have 4 more proxies to install and don't want to just copy things from my lab if it's something that actually needs to be fixed.

I figured out the nginx.conf issue, so that's resolved (had to remove an old ProxyLookupTarget https://wiki.zimbra.com/wiki/Nginx_fails_to_start). But I'm still not sure what to do about postfix.

I've narrowed it down to /opt/zimbra/common/conf/main.cf
command_directory = /opt/zimbra/postfix/sbin
daemon_directory = /opt/zimbra/postfix/libexec
I tried manually changing them but the file gets overwritten when I restart the service (zmmtactl restart). Where do I go to change these permanently?

Getting closer, I've found the following in Global Config
zimbraMtaCommandDirectory: /opt/zimbra/postfix/sbin
zimbraMtaDaemonDirectory: /opt/zimbra/postfix/libexec
zimbraMtaMailqPath: /opt/zimbra/postfix/sbin/mailq
zimbraMtaManpageDirectory: /opt/zimbra/postfix/man
zimbraMtaNewaliasesPath: /opt/zimbra/postfix/sbin/newaliases
zimbraMtaSendmailPath: /opt/zimbra/postfix/sbin/sendmail
After changing these I can now get the new install to work. Looks like my Global Config was still holding values from the old 8.7.5 versions, having been upgraded to 8.8.12 recently.

I was going to delete the post, but maybe this will help someone else in a similar situation.

User avatar
Outstanding Member
Outstanding Member
Posts: 533
Joined: Fri Sep 12, 2014 11:18 pm
Location: Victoria, BC
ZCS/ZD Version: 8.8.15_P16 RHEL6 Network Edition

Re: 8.8.12 Proxy+MTA install - proxy and mta won't start, no config and wrong paths

Postby JDunphy » Mon Jul 08, 2019 3:15 pm

I was looking at my 8.7 postinstall notes when I came from 8.6 and saw this:

Code: Select all

1) Verify this.

zmprov mcf zimbraMtaCommandDirectory /opt/zimbra/common/sbin
zmprov mcf zimbraMtaDaemonDirectory /opt/zimbra/common/libexec
zmprov mcf zimbraMtaMailqPath /opt/zimbra/common/sbin/mailq
zmprov mcf zimbraMtaManpageDirectory /opt/zimbra/common/share/man
zmprov mcf zimbraMtaNewaliasesPath /opt/zimbra/common/sbin/newaliases
zmprov mcf zimbraMtaSendmailPath /opt/zimbra/common/sbin/sendmail

I remember seeing this in a zimbra wiki article before moving to 8.7 about that upgrade process ... I can't find that link now... But google did bring this link:


They ask again to verify these settings when upgrading from 8.7 if you scroll down a few pages... You might want to double check all those manual steps they list. It wasn't clear to me you were doing an upgrade until you mentioned 8.7.5. ... Nice detective work on your part. You might want to re-edit your title of this post and put solved at the beginning to help others in the future. That would make your solution stand-out on subsequent searches and save future admins sometime.

Note: /opt/zimbra/.install_history is pretty useful log to track what your install has seen. All patches and upgrades are listed, etc
Elite member
Elite member
Posts: 2378
Joined: Mon Dec 16, 2013 11:35 am

Re: 8.8.12 Proxy+MTA install - proxy and mta won't start, no config and wrong paths

Postby Klug » Mon Jul 08, 2019 4:13 pm

I had this issue too on a customer multi-servers setup.
The two LDAPs were out of sync.

If the MTA server was asking the "correct" LDAP (the one that handled the MTA upgrade fro 8.6 to 8.8), everything was ok.
If it was asking the wrong LDAP (that was not aware of the upgrade because out of sync), we had these errors.

Once LDAP replication was fixed, it went well.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests