ZCS OSE cannot start after upgrade to 8.8.15

Ask questions about your setup or get help installing ZCS server (ZD section below).
rosole
Posts: 26
Joined: Thu Jul 05, 2018 4:45 pm

Re: ZCS OSE cannot start after upgrade to 8.8.15

Postby rosole » Tue Jul 30, 2019 7:34 pm

Hello Mark.

I do not have any firewall or other selinux on this machine.

zimbra@zimbra:~$ zmprov -l gs `zmhostname` zimbraIPMode
# name zimbra.domain.pl
zimbraIPMode: ipv4


rosole
Posts: 26
Joined: Thu Jul 05, 2018 4:45 pm

Re: ZCS OSE cannot start after upgrade to 8.8.15

Postby rosole » Wed Jul 31, 2019 9:11 am

Hello Mark.

I've fixed it.

Two things:

1. error in /opt/zimbra/log/mailbox.log

ERROR [main] [] Versions - DB Version Mismatch: ours=111 from DB=109
FATAL [main] [] system - Data version mismatch. Reinitialize or upgrade the backend data store

I've fixed it by:

zimbra@zimbra:cd /opt/zimbra/libexec/scripts/
zimbra@zimbra:~/libexec/scripts$ ./migrate20190401-ZimbraChat.pl
Wed Jul 31 10:56:53 2019: Verified schema version 109.
Wed Jul 31 10:56:55 2019: Verified schema version 109.
Wed Jul 31 10:56:55 2019: Updating DB schema version from 109 to 110.
zimbra@zimbra:~/libexec/scripts$ ./migrate20190611-ZimbraChat.pl
Wed Jul 31 10:57:04 2019: Verified schema version 110.
Wed Jul 31 10:57:06 2019: Verified schema version 110.
Wed Jul 31 10:57:06 2019: Updating DB schema version from 110 to 111

2. update zmlocalconfig to below:

zimbra@zimbra:zmlocalconfig -e mailboxd_java_options="-server -Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djdk.tls.client.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djava.awt.headless=true -XX:+UseG1GC -Dsun.net.inetaddr.ttl=${networkaddress_cache_ttl} -Dorg.apache.jasper.compiler.disablejsr199=true -XX:+UnlockExperimentalVMOptions -XX:G1NewSizePercent=15 -XX:G1MaxNewSizePercent=45 -XX:SoftRefLRUPolicyMSPerMB=1 -XX:-OmitStackTraceInFastThrow -verbose:gc -Xlog:gc*=info,safepoint=info:file=/opt/zimbra/log/gc.log:time:filecount=20,filesize=10m -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:CompileCommandFile=.hotspot_compiler -XX:HeapDumpPath=/opt/zimbra/log -XX:ErrorFile=/opt/zimbra/log/hs_err_pid%p.log"

Thank you for help.
User avatar
L. Mark Stone
Elite member
Elite member
Posts: 2100
Joined: Wed Oct 09, 2013 11:35 am
Location: Portland, Maine, US
ZCS/ZD Version: 8.8.15 Network Edition
Contact:

Re: ZCS OSE cannot start after upgrade to 8.8.15

Postby L. Mark Stone » Wed Jul 31, 2019 4:13 pm

Glad that got sorted for you.

All the best,
Mark
___________________________________
L. Mark Stone
Mission Critical Email - Zimbra VAR/BSP/Training Partner https://www.missioncriticalemail.com/
Zeta Alliance http://www.zetalliance.org/
giovanni.lovato
Posts: 4
Joined: Wed Oct 02, 2019 8:04 am

Re: ZCS OSE cannot start after upgrade to 8.8.15

Postby giovanni.lovato » Wed Oct 02, 2019 12:38 pm

I've the same issue but the migrate script throws an error:

Code: Select all

zimbra@zimbra:~/libexec/scripts$ ./migrate20190401-ZimbraChat.pl
Can't locate Migrate.pm in @INC (you may need to install the Migrate module) (@INC contains: /opt/zimbra/common/lib/perl5/x86_64-linux-gnu-thread-multi /opt/zimbra/common/lib/perl5/x86_64-linux-gnu-thread-multi /opt/zimbra/common/lib/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.26.1 /usr/local/share/perl/5.26.1 /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at ./migrate20190401-ZimbraChat.pl line 20.
BEGIN failed--compilation aborted at ./migrate20190401-ZimbraChat.pl line 20.


I'm on Ubuntu 18.04. Any idea?
giovanni.lovato
Posts: 4
Joined: Wed Oct 02, 2019 8:04 am

Re: ZCS OSE cannot start after upgrade to 8.8.15

Postby giovanni.lovato » Wed Oct 02, 2019 12:43 pm

Nevermind, this worked:

Code: Select all

export PERL5LIB=/opt/zimbra/libexec/scripts

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 6 guests