LDAP screwed after upgrade from 8.8.11 to 8.8.15

Ask questions about your setup or get help installing ZCS server (ZD section below).
giovanni.lovato
Posts: 4
Joined: Wed Oct 02, 2019 8:04 am

LDAP screwed after upgrade from 8.8.11 to 8.8.15

Postby giovanni.lovato » Wed Oct 02, 2019 8:09 am

I've done many updates without any error, but this time I'm not that lucky. Upgrading from 8.8.11 to 8.8.15, LDAP is not starting anymore and Zimbra refuses to do anything.

I've tried changing the password with

Code: Select all

zmldappasswd -b 'newpass'
but it fails:

Code: Select all

Updating local config and LDAP
Died at /opt/zimbra/bin/zmldappasswd line 99, <DATA> line 755.


This does not seem good! How can I proceed? I have the system down right now :(


giovanni.lovato
Posts: 4
Joined: Wed Oct 02, 2019 8:04 am

Re: LDAP screwed after upgrade from 8.8.11 to 8.8.15

Postby giovanni.lovato » Wed Oct 02, 2019 9:20 am

I tried to install over the existing /opt/zimbra but then I get

Code: Select all

Checking ldap status....not running.
Starting ldap...failed with exit code: 256.


How can I get past this?
User avatar
Rony
Posts: 22
Joined: Fri Jan 27, 2017 3:50 pm
Location: Canada
ZCS/ZD Version: 8.8.15 Network
Contact:

Re: LDAP screwed after upgrade from 8.8.11 to 8.8.15

Postby Rony » Sun Feb 16, 2020 9:34 pm

I have the same issue after reinstalling Zimbra 8.8.15
User avatar
fs.schmidt
Outstanding Member
Outstanding Member
Posts: 262
Joined: Sat Sep 13, 2014 3:37 am
Location: Brazil
Contact:

Re: LDAP screwed after upgrade from 8.8.11 to 8.8.15

Postby fs.schmidt » Sun Feb 16, 2020 10:09 pm

Hello,

You could try this as root:

Code: Select all

/opt/zimbra/libexec/zmfixperms -verbose -extended


Then run the installation again to see if this solves the ldap issue.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests