zmmailboxdctl failing to run after most recent apt-get

Ask questions about your setup or get help installing ZCS server (ZD section below).
mgmailadmin
Posts: 10
Joined: Wed Jun 15, 2022 3:18 am

zmmailboxdctl failing to run after most recent apt-get

Postby mgmailadmin » Wed Jun 15, 2022 5:37 am

Hi
We are running a single Zimbra FOSS 9.0 server based on the Zextras port: (Release 9.0.0.ZEXTRAS.20220402.UBUNTU18.64 UBUNTU18_64 FOSS edition) on an Ubuntu 18.04.6 TLS AWS instance. So far it has been pretty stable and painless.

We did a system update this morning using apt-get update/upgrade and noted updates to Zimbra were downloaded. Some time later in the day we did a zmcontrol restart and now find that zmmailboxdctl does not run.
I have looked at zmmailboxd.out but I'm not sure what I should be looking for.

I did notice that there was a warning message: "OpenJDK 64-Bit Server VM warning: .hotspot_compiler file is present but has been ignored. Run with -XX:CompileCommandFile=.hotspot_compiler to load the file." So I added "-XX:CompileCommandFile=.hotspot_compiler" to zmlocalconfig mailboxd_java_options. The warnings have gone away but zmmailboxdctl still doesn't load.

I have searched zimbra and zextras forums for relevant info and been unable to find anything that seems to apply.

Tried to Include zmmailboxd.out for reference but it wouldn't let me upload the file complaining of invalid file extension. Happy to include them If I can find a way to do it.

Not sure where to go from here. Any help would be appreciated.


-Kent I.


phoenix
Ambassador
Ambassador
Posts: 27018
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: zmmailboxdctl failing to run after most recent apt-get

Postby phoenix » Wed Jun 15, 2022 10:59 am

If you wish to upload a large file to the forums you should first upload it to fo a file sharing site then post the link here.

Try an internet search for the following terms and see if they help with your problem:

Code: Select all

zimbra OpenJDK 64-Bit Server VM warning
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
mgmailadmin
Posts: 10
Joined: Wed Jun 15, 2022 3:18 am

Re: zmmailboxdctl failing to run after most recent apt-get

Postby mgmailadmin » Wed Jun 15, 2022 11:37 am

Thanks @phoenix,

I did the search you suggested and found all the items I've already checked out. Unfortunately they don't seem to apply.

As a fall back I provisioned a new server Ubuntu 18.04.6 LTS instance and did a clean install of zimbra 9 FOSS and zmmailboxd still does not run.

The following is a snippet from the top of the zmmailboxd.out file for the install. This section gets repeated many times in the file.

Code: Select all

[0.021s][info][gc] Using G1
OpenJDK 64-Bit Server VM warning: .hotspot_compiler file is present but has been ignored.  Run with -XX:CompileCommandFile=.hotspot_compiler to load the file.
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
JettyMonitor monitoring thread pool QueuedThreadPool[qtp2023938592]@78a2da20{STOPPED,10<=0<=250,i=0,r=-1,q=0}[NO_TRY]
Zimbra server reserving server socket port=7110 bindaddr=null ssl=false
Zimbra server reserving server socket port=7995 bindaddr=null ssl=false
Zimbra server reserving server socket port=7143 bindaddr=null ssl=false
Zimbra server reserving server socket port=7993 bindaddr=null ssl=false
Zimbra server reserving server socket port=7025 bindaddr=null ssl=false
java.lang.reflect.InvocationTargetException
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:568)
        at org.eclipse.jetty.start.Main.invokeMain(Main.java:218)
        at org.eclipse.jetty.start.Main.start(Main.java:491)
        at org.eclipse.jetty.start.Main.main(Main.java:77)
Caused by: java.security.PrivilegedActionException: java.lang.ClassNotFoundException: org.eclipse.jetty.setuid.SetUIDListener
        at java.base/java.security.AccessController.doPrivileged(AccessController.java:573)
        at org.eclipse.jetty.xml.XmlConfiguration.main(XmlConfiguration.java:1857)
        ... 7 more
Caused by: java.lang.ClassNotFoundException: org.eclipse.jetty.setuid.SetUIDListener
        at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:445)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:587)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:520)
        at org.eclipse.jetty.util.Loader.loadClass(Loader.java:64)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.newObj(XmlConfiguration.java:1006)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.itemValue(XmlConfiguration.java:1540)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.value(XmlConfiguration.java:1441)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.access$700(XmlConfiguration.java:395)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration$Args.<init>(XmlConfiguration.java:1699)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration$Args.<init>(XmlConfiguration.java:1686)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.call(XmlConfiguration.java:942)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.configure(XmlConfiguration.java:515)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.configure(XmlConfiguration.java:468)
        at org.eclipse.jetty.xml.XmlConfiguration.configure(XmlConfiguration.java:380)
        at org.eclipse.jetty.xml.XmlConfiguration.lambda$main$3(XmlConfiguration.java:1893)
        at java.base/java.security.AccessController.doPrivileged(AccessController.java:569)
        ... 8 more
java.lang.reflect.InvocationTargetException
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:568)
        at org.eclipse.jetty.start.Main.invokeMain(Main.java:218)
        at org.eclipse.jetty.start.Main.start(Main.java:491)
        at org.eclipse.jetty.start.Main.main(Main.java:77)
Caused by: java.security.PrivilegedActionException: java.lang.ClassNotFoundException: org.eclipse.jetty.setuid.SetUIDListener
        at java.base/java.security.AccessController.doPrivileged(AccessController.java:573)
        at org.eclipse.jetty.xml.XmlConfiguration.main(XmlConfiguration.java:1857)
        ... 7 more
Caused by: java.lang.ClassNotFoundException: org.eclipse.jetty.setuid.SetUIDListener
        at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:445)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:587)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:520)
        at org.eclipse.jetty.util.Loader.loadClass(Loader.java:64)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.newObj(XmlConfiguration.java:1006)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.itemValue(XmlConfiguration.java:1540)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.value(XmlConfiguration.java:1441)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.access$700(XmlConfiguration.java:395)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration$Args.<init>(XmlConfiguration.java:1699)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration$Args.<init>(XmlConfiguration.java:1686)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.call(XmlConfiguration.java:942)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.configure(XmlConfiguration.java:515)
        at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.configure(XmlConfiguration.java:468)
        at org.eclipse.jetty.xml.XmlConfiguration.configure(XmlConfiguration.java:380)
        at org.eclipse.jetty.xml.XmlConfiguration.lambda$main$3(XmlConfiguration.java:1893)
        at java.base/java.security.AccessController.doPrivileged(AccessController.java:569)
        ... 8 more

Usage: java -jar $JETTY_HOME/start.jar [options] [properties] [configs]
       java -jar $JETTY_HOME/start.jar --help  # for more information


Full file is here:https://www.dropbox.com/s/1pi4i22jo64f3yz/zmmailboxd.out?dl=0

Any help/insight would be appreciated.
Thanks
-Kent I.
Martinwiertz
Advanced member
Advanced member
Posts: 75
Joined: Sat Sep 13, 2014 3:55 am
Location: The Netherlands
ZCS/ZD Version: V9.0 Zextras

Re: zmmailboxdctl failing to run after most recent apt-get

Postby Martinwiertz » Wed Jun 15, 2022 12:32 pm

Hi,

Same issue at my end. Mailboxd not starting after latest update. Release 9.0.0.ZEXTRAS.20220402.UBUNTU18.64 UBUNTU18_64 FOSS edition.
I will follow advice Bill and start searching. If someone has more info please share.
Attachments
zimbra.jpg
zimbra.jpg (77.08 KiB) Viewed 4302 times
phoenix
Ambassador
Ambassador
Posts: 27018
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: zmmailboxdctl failing to run after most recent apt-get

Postby phoenix » Wed Jun 15, 2022 3:32 pm

I'm afraid I've now got a me too post, a failed server after an upgrade and no possibility to get it running. I have a different error message and I've posted my error on the Zextras forums here:

https://community.zextras.com/forum/zimbra-ose-9-by-zextras/mailbox-service-is-not-starting-after-os-update-this-morning/#post-3198

Let's hope something is forthcoming soon. :)
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
czv
Posts: 2
Joined: Wed Jun 15, 2022 3:32 pm

Re: zmmailboxdctl failing to run after most recent apt-get

Postby czv » Wed Jun 15, 2022 3:34 pm

it doesn't work for me after the upgrade:

Cleaning up 7 files from '/opt/zimbra/conf/ca'
** Removing /opt/zimbra/conf/ca/b0a45f62.0
** Removing /opt/zimbra/conf/ca/4042bcee.0
** Removing /opt/zimbra/conf/ca/8d33f237.0
** Removing /opt/zimbra/conf/ca/ca.pem
** Removing /opt/zimbra/conf/ca/ca.key
** Removing /opt/zimbra/conf/ca/commercial_ca_1.crt
** Removing /opt/zimbra/conf/ca/commercial_ca_2.crt
** Copying CA to /opt/zimbra/conf/ca
** Copying '/opt/zimbra/ssl/zimbra/ca/ca.key' to '/opt/zimbra/conf/ca/ca.key'
** Copying '/opt/zimbra/ssl/zimbra/ca/ca.pem' to '/opt/zimbra/conf/ca/ca.pem'
** Creating CA hash symlink 'b0a45f62.0' -> 'ca.pem'
** Creating /opt/zimbra/conf/ca/commercial_ca_1.crt
** Creating CA hash symlink '8d33f237.0' -> 'commercial_ca_1.crt'
** Creating /opt/zimbra/conf/ca/commercial_ca_2.crt
** Creating CA hash symlink '4042bcee.0' -> 'commercial_ca_2.crt'

Warning:
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/0moabupzxs.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/bkwovpzfpf.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/bxa9zyd1et.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/cgzfi9yc6d.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/fxwhxxevl1.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/nwzy226jtt.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/o1c9y9tgcu.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/oviepbozvc.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/pgi4sds2cj.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/t0dclkmbdn.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/tkmqgsimhx.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/ug_ybbhecf.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/vgfxlcbunt.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
Certificate stored in file </opt/zimbra/.saveconfig/zimbra-openjdk-cacerts-1.0.5-1zimbra8.7b1.18.04/my_ca.crt>
ERROR: Can't read file '/opt/zimbra/.saveconfig/zimbra-openjdk-cacerts-1.0.5-1zimbra8.7b1.18.04/my_ca.crt'
Certificate stored in file </opt/zimbra/.saveconfig/zimbra-openjdk-cacerts-1.0.5-1zimbra8.7b1.18.04/zcs-user-commercial_ca.crt>
ERROR: Can't read file '/opt/zimbra/.saveconfig/zimbra-openjdk-cacerts-1.0.5-1zimbra8.7b1.18.04/zcs-user-commercial_ca.crt'
Martinwiertz
Advanced member
Advanced member
Posts: 75
Joined: Sat Sep 13, 2014 3:55 am
Location: The Netherlands
ZCS/ZD Version: V9.0 Zextras

Re: zmmailboxdctl failing to run after most recent apt-get

Postby Martinwiertz » Wed Jun 15, 2022 5:59 pm

Hi CZV,

is this an error due to applying the latest patch via apt-get?


czv wrote:it doesn't work for me after the upgrade:

Cleaning up 7 files from '/opt/zimbra/conf/ca'
** Removing /opt/zimbra/conf/ca/b0a45f62.0
** Removing /opt/zimbra/conf/ca/4042bcee.0
** Removing /opt/zimbra/conf/ca/8d33f237.0
** Removing /opt/zimbra/conf/ca/ca.pem
** Removing /opt/zimbra/conf/ca/ca.key
** Removing /opt/zimbra/conf/ca/commercial_ca_1.crt
** Removing /opt/zimbra/conf/ca/commercial_ca_2.crt
** Copying CA to /opt/zimbra/conf/ca
** Copying '/opt/zimbra/ssl/zimbra/ca/ca.key' to '/opt/zimbra/conf/ca/ca.key'
** Copying '/opt/zimbra/ssl/zimbra/ca/ca.pem' to '/opt/zimbra/conf/ca/ca.pem'
** Creating CA hash symlink 'b0a45f62.0' -> 'ca.pem'
** Creating /opt/zimbra/conf/ca/commercial_ca_1.crt
** Creating CA hash symlink '8d33f237.0' -> 'commercial_ca_1.crt'
** Creating /opt/zimbra/conf/ca/commercial_ca_2.crt
** Creating CA hash symlink '4042bcee.0' -> 'commercial_ca_2.crt'

Warning:
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/0moabupzxs.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/bkwovpzfpf.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/bxa9zyd1et.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/cgzfi9yc6d.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/fxwhxxevl1.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/nwzy226jtt.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/o1c9y9tgcu.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/oviepbozvc.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/pgi4sds2cj.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/t0dclkmbdn.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/tkmqgsimhx.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/ug_ybbhecf.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
</home/build/git/87/packages/thirdparty/openjdk-cacerts/build/ubuntu18_64/dkggybsmr2/vgfxlcbunt.der> uses a 1024-bit RSA key which is considered a security risk. This key size will be disabled in a future update.
Certificate stored in file </opt/zimbra/.saveconfig/zimbra-openjdk-cacerts-1.0.5-1zimbra8.7b1.18.04/my_ca.crt>
ERROR: Can't read file '/opt/zimbra/.saveconfig/zimbra-openjdk-cacerts-1.0.5-1zimbra8.7b1.18.04/my_ca.crt'
Certificate stored in file </opt/zimbra/.saveconfig/zimbra-openjdk-cacerts-1.0.5-1zimbra8.7b1.18.04/zcs-user-commercial_ca.crt>
ERROR: Can't read file '/opt/zimbra/.saveconfig/zimbra-openjdk-cacerts-1.0.5-1zimbra8.7b1.18.04/zcs-user-commercial_ca.crt'
mgmailadmin
Posts: 10
Joined: Wed Jun 15, 2022 3:18 am

Re: zmmailboxdctl failing to run after most recent apt-get

Postby mgmailadmin » Wed Jun 15, 2022 6:31 pm

Hi Martin,

Can't speak for CZV but for us it absolutely started after the apt-get. Very disturbing that a clean install also suffers the same issue.

Again, any insight would be appreciated.

-Kent I.
livelace
Posts: 1
Joined: Wed Jun 15, 2022 6:27 pm

Re: zmmailboxdctl failing to run after most recent apt-get

Postby livelace » Wed Jun 15, 2022 6:58 pm

Just registered to inform you guys about the same problem.
My system is Centos 7. And for avoiding this problem I had to downgrade some packages:

Removed:
zimbra-core-components.x86_64 0:3.0.12-1zimbra8.8b1.el7
zimbra-jetty-distribution.x86_64 0:9.4.46.v20220331-2.r7
zimbra-ldap-components.x86_64 0:2.0.6-1zimbra8.8b1.el7
zimbra-openjdk.x86_64 0:17.0.2-1zimbra8.8b1.el7

Installed:
zimbra-core-components.x86_64 0:3.0.11-1zimbra8.8b1.el7
zimbra-jetty-distribution.x86_64 0:9.4.18.v20190429-2.r7
zimbra-ldap-components.x86_64 0:2.0.5-1zimbra8.8b1.el7
zimbra-openjdk.x86_64 0:13.0.1-1zimbra8.8b1.el7

Right now all services works as expected.
Martinwiertz
Advanced member
Advanced member
Posts: 75
Joined: Sat Sep 13, 2014 3:55 am
Location: The Netherlands
ZCS/ZD Version: V9.0 Zextras

Re: zmmailboxdctl failing to run after most recent apt-get

Postby Martinwiertz » Wed Jun 15, 2022 7:00 pm

Agree Kent. I am searching also for the last hours. I found this error happend several times over the last few years but can't find an 100% solution.
I didn't expected these update in the repos but they were there..... Especially update to P25 on v9.0 is more severe or more extensive updates.


mgmailadmin wrote:Hi Martin,

Can't speak for CZV but for us it absolutely started after the apt-get. Very disturbing that a clean install also suffers the same issue.

Again, any insight would be appreciated.

-Kent I.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 12 guests