com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Ask questions about your setup or get help installing ZCS server (ZD section below).
sigtrap
Posts: 16
Joined: Sat Sep 13, 2014 1:35 am

com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby sigtrap » Sun Jun 19, 2022 10:15 pm

Hi,

I am running a very small Zimbra instance on a Ubuntu 16.04.7 LTS (GNU/Linux 4.4.0-92-generic x86_64).
I have just upgraded a 8.7.11 to Release 8.8.15.GA.3869.UBUNTU16.64 UBUNTU16_64 FOSS edition, Patch 8.8.15_P32.

Upgrade reported OK and zmcontrol status is OK.
IMAP works but web interface for email and admin get errors. For admin interface I just get "internal server error" but for email web I get:
(update: No IMAP does not work after restart as I have other problems after upgrade)

Code: Select all

HTTP ERROR 500 java.lang.NoClassDefFoundError: Could not initialize class com.zimbra.soap.JaxbUtil
URI:   /zimbra/
STATUS:   500
MESSAGE:   java.lang.NoClassDefFoundError: Could not initialize class com.zimbra.soap.JaxbUtil
SERVLET:   default
CAUSED BY:   java.lang.NoClassDefFoundError: Could not initialize class com.zimbra.soap.JaxbUtil
Caused by:
java.lang.NoClassDefFoundError: Could not initialize class com.zimbra.soap.JaxbUtil


Please help before I mess anything more up.
I have read this viewtopic.php?f=15&t=68097&start=90#p305354 but it is for version 9.0.0 and I don't know how to downgrade or if that will mess up other things.
My installed versions is:

Code: Select all

zimbra-openjdk/unknown,now 17.0.2-1zimbra8.8b1.16.04 amd64 [installed,automatic]
zimbra-openjdk-cacerts/unknown,now 1.0.8-1zimbra8.7b1.16.04 all [installed,automatic]
zimbra-openjdk-dbg/unknown 17.0.2-1zimbra8.8b1.16.04 amd64


//Sigtrap
Last edited by sigtrap on Mon Jun 20, 2022 7:10 am, edited 1 time in total.


sigtrap
Posts: 16
Joined: Sat Sep 13, 2014 1:35 am

Re: com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby sigtrap » Mon Jun 20, 2022 5:07 am

No answers...

Nobody that can give me hints?

Today I will try Known Issues to see if that can help me with my other problems: https://wiki.zimbra.com/wiki/Current_Known_Issues

But if that does not help I will try to downgrade zimbra-openjdk from 17 to 13 before I give up and try to restore the old 8.7.11.

Need any help
//Sigtrap

Update 1: Current Know Issues didn't help. I was hoping that /opt/zimbra/common/lib/jylibs/commands.py and /opt/zimbra/libexec/zmconfigd was wrong but running a diff returned nothing. I have two domains on my server; sigtrap.org and zploit.com. But I configured zploit.com in admin web interface (that I now can not start) and I can't see that with 'zmprov gd zploit.com':

Code: Select all

zimbra@master:~$ zmprov gd sigtrap.org |grep -i virtual
zimbraVirtualHostname: master.sigtrap.org
zimbraVirtualIPAddress: 192.168.0.3
zimbra@master:~$ zmprov gd zploit.com |grep -i virtual
zimbra@master:~$


I don't know if I should see zploit.com zimbraVirtualHostname and if I could that before. I am not using SSO or SAML. Shall I try to do the "Changes required for SSO setup before patch upgrade" in https://wiki.zimbra.com/wiki/Zimbra_Releases/8.8.15/P32 ? If so, where should the zploit.com point to (the original server master.sigtrap.org) as I only running a single server?

Update 2: I now saw that my admin account was temporary locked out. I don't know when this has happened but I hope this not messed up the upgrade.
Update 3: Did a 'zmprov md zploit.com zimbraVirtualHostName master.sigtrap.org' accordingly https://wiki.zimbra.com/wiki/Zimbra_Releases/8.8.15/P32 but I only has zploit.com as an alias and don't use SSO. Restarted server with same error.
sigtrap
Posts: 16
Joined: Sat Sep 13, 2014 1:35 am

Re: com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby sigtrap » Tue Jun 21, 2022 12:19 am

Instead of trying to fix the server I bought a new server and installed Ubuntu 20.04 on it following the normal guides:
https://habibza.in/install-zimbra-8-8-1 ... ion-part1/
https://habibza.in/install-zimbra-8-8-1 ... -04-part2/

Then I just moved over the accounts using this guide:
https://habibza.in/zimbra-server-migrat ... ct-method/

So instead of solving the issue I migrated from Zimbra 8.8.15 on Ubuntu 16.04 to Zimbra 8.8.15 on Ubuntu 20.04.

Have some settings and tweaks to do but I am sure I will get it to work.

But I am worried that others that upgrades from 8.7.11 to 8.8.15 will have the same problems. My problem is over ;)

//Sigtrap
annahri
Posts: 2
Joined: Wed Jun 22, 2022 8:33 am

Re: com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby annahri » Wed Jun 22, 2022 8:38 am

Oh wow, I'm having the same exact issue.

I just installed a fresh zimbra 8.7.11 yesterday to test upgrading to 8.8.15 prior to doing it on the production system. Then I proceeded to upgrade to 8.8.15, and the installer says no error at all.

I've been looking for clues all day but this thread is the only one that addresses the issue, how strange.

Anyway, I just opened a case to Zimbra Support. Lets see how it goes.
phoenix
Ambassador
Ambassador
Posts: 27018
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby phoenix » Wed Jun 22, 2022 11:42 am

One thing you should always do is post the full details of the version that you're using, use the following command and post the details:

Code: Select all

su - zimbra
zmcontrol -v
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
MariaJoseYD82
Posts: 4
Joined: Wed Oct 22, 2014 8:30 am

Re: com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby MariaJoseYD82 » Wed Jun 22, 2022 2:01 pm

Hi,We are experimenting the same issue after upgrading our Zimbra Open Source version 8.8.15 on our production environment.

The error we are getting when trying to access Zimbra web:


[bug]
Caused by: javax.el.ELException: Cannot convert [java.lang.NoClassDefFoundError: Could not initialize class com.zimbra.soap.JaxbUtil] of type [class java.lang.NoClassDefFoundError] to [class java.lang.Exception]
at org.apache.el.lang.ELSupport.coerceToType(ELSupport.java:578)Zimbra version:
[/bug]

zmcontrol -v

Code: Select all

Release 8.8.15_GA_3869.RHEL7_64_20190917004220 RHEL7_64 FOSS edition, Patch 8.8.15_P32.OS:


cat /etc/centos-release

Code: Select all

CentOS Linux release 7.9.2009 (Core)

Any help to solve this problem is highly appreciated.

Many thanks, regards.
sigtrap
Posts: 16
Joined: Sat Sep 13, 2014 1:35 am

Re: com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby sigtrap » Wed Jun 22, 2022 8:43 pm

I tried to warn other of the upgrade in the thread viewtopic.php?f=15&t=70865 but the post got deleted and thread locked.
//Sigtrap
saket.patel
Zimbra Employee
Zimbra Employee
Posts: 25
Joined: Mon Apr 11, 2022 8:39 pm

Re: com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby saket.patel » Wed Jun 22, 2022 9:29 pm

Can someone provide output of below command, who are experiencing this issue?

Code: Select all

zmlocalconfig mailboxd_java_options
jackyho
Posts: 12
Joined: Wed Sep 12, 2018 6:11 am

Re: com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby jackyho » Thu Jun 23, 2022 3:56 am

saket.patel wrote:Can someone provide output of below command, who are experiencing this issue?

Code: Select all

zmlocalconfig mailboxd_java_options

I had the same issue after upgrade to 8.8.15 P32

Zimbra Version

Code: Select all

zimbra@mail:~$ zmcontrol -v
Release 8.8.15.GA.3869.UBUNTU16.64 UBUNTU16_64 FOSS edition, Patch 8.8.15_P32.


The output

Code: Select all

zimbra@mail:~$ zmlocalconfig mailboxd_java_options
mailboxd_java_options = -server -Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djdk.tls.client.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djava.awt.headless=true -Dsun.net.inetaddr.ttl= -Dorg.apache.jasper.compiler.disablejsr199=true -XX:+UseG1GC -XX:SoftRefLRUPolicyMSPerMB=1 -XX:-OmitStackTraceInFastThrow -verbose:gc -Xlog:gc*=debug,safepoint=info:file=/opt/zimbra/log/gc.log:time:filecount=20,filesize=10m -Djava.net.preferIPv4Stack=true
Edx2Eu7
Posts: 11
Joined: Tue Jun 21, 2022 7:57 pm

Re: com.zimbra.soap.JaxbUtil error after upgrade to 8.8.15

Postby Edx2Eu7 » Thu Jun 23, 2022 6:01 am

looks highly similar to this issue https://forums.zimbra.org/viewtopic.php?f=15&t=70741 and this one that I'm experiencing as well https://forums.zimbra.org/viewtopic.php?f=15&t=70897

Difference in old Java mailboxd options and the newer ones is the removal of the old TLS ciphers. All other options remained the same.
Applying the options does fix the error. Trying to downgrade the Zimbra Open JDK Debian package does not work, as this would uninstall pretty much all Zimbra packages due to dependency problems between the old Java 13 package and the newer packages.

Here's a sorted output of the old Java options

Code: Select all

--add-opens java.base/java.lang=ALL-UNNAMED
-Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2
-Djava.awt.headless=true
-Djava.net.preferIPv4Stack=true
-Djava.security.egd=file:/dev/./urandom
-Djdk.tls.client.protocols=TLSv1,TLSv1.1,TLSv1.2
-Dorg.apache.jasper.compiler.disablejsr199=true
-Dsun.net.inetaddr.ttl=${networkaddress_cache_ttl}
-server
-verbose:gc
-Xlog:gc*=info,safepoint=info:file=/opt/zimbra/log/gc.log:time:filecount=20,filesize=10m
-XX:G1MaxNewSizePercent=45
-XX:G1NewSizePercent=15
-XX:-OmitStackTraceInFastThrow
-XX:SoftRefLRUPolicyMSPerMB=1
-XX:+UnlockExperimentalVMOptions
-XX:+UseG1GC


and here's the more recent options

Code: Select all

--add-opens java.base/java.lang=ALL-UNNAMED
-Dhttps.protocols=TLSv1.2
-Djava.awt.headless=true
-Djava.net.preferIPv4Stack=true
-Djava.security.egd=file:/dev/./urandom
-Djdk.tls.client.protocols=TLSv1.2
-Dorg.apache.jasper.compiler.disablejsr199=true
-Dsun.net.inetaddr.ttl=${networkaddress_cache_ttl}
-server
-verbose:gc
-Xlog:gc*=info,safepoint=info:file=/opt/zimbra/log/gc.log:time:filecount=20,filesize=10m
-XX:G1MaxNewSizePercent=45
-XX:G1NewSizePercent=15
-XX:-OmitStackTraceInFastThrow
-XX:SoftRefLRUPolicyMSPerMB=1
-XX:+UnlockExperimentalVMOptions
-XX:+UseG1GC



Best regards
Edx2Eu7

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 15 guests