NGINX listen port to 80?

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
kdiamond
Posts: 29
Joined: Mon Apr 12, 2021 12:52 am

NGINX listen port to 80?

Postby kdiamond » Wed Apr 21, 2021 10:56 am

Hi.

For many hours I'm struggling to set NGINX listening port to 80.

root@mail:/home/dali# netstat -lntp | egrep "80|443"
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN 3790/java
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 12810/nginx: master
tcp 0 0 0.0.0.0:8443 0.0.0.0:* LISTEN 3790/java
tcp6 0 0 :::7780 :::* LISTEN 5652/httpd


HTTPS redirect from HTTP does not work. It's clear as NGINX is not listening to port 80.

Global settings
global.jpg
global.jpg (182.22 KiB) Viewed 290 times


Server setting
server.jpg
server.jpg (199.58 KiB) Viewed 290 times


After any change I restart
zmproxyctl restart
zmcontrol restart

but nothing changes. Nginx will always listen only to port 443

Any help would be most welcome as I run out of options to try,

Thank you
Br,
kd


Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 31 guests