Page 1 of 1

Zimbra 7.1.1: High CPU spikes every 5 minutes

Posted: Fri Jun 17, 2011 6:25 am
by mrcoffee11
Hi,

Just upgraded from 7.0.1 to 7.1.1. Now my server has these high cpu spikes every 5 minutes. Almost just like in Zimbra version 6!

Before ugrade load average was less then 1. Now the load average is: 1.49, 1.97, 1.64 with 90 to 99% cpu spikes every 5 minutes.
I did some things to change this like I was used to in Zimbra 6 but it did not make a difference:

- zimbra user crontab adjustments so jobs have a longer interval

- as zimbra

$ zmlocalconfig -e zmmtaconfig_interval=6000

$ zmprov mcf zimbraLogRawLifetime 7d

$ zmprov mcf zimbraLogSummaryLifetime 30d

- /etc/logrotate.d/zimbra comment out all logger related start / reload commands
Watching top I see the java processes are taking up 99% cpu every 5 m inutes for a few seconds.

14924 zimbra 20 0 1113m 269m 11m S 62.5 17.4 0:52.31 java
And these come back every time:

900 7476 2460 S 0.3 0.5 0:00.43 zmstat-proc

3971 zimbra 20 0 46636 7168 2452 S 0.3 0.5 0:00.11 zmstat-cpu


Anyone any suggestions?
Grtz,

Roderick

zimbra_before_and_after_upgrade_7.1.1.jpg


Zimbra 7.1.1: High CPU spikes every 5 minutes

Posted: Tue Jun 21, 2011 1:37 am
by PhD
registering my acknowledgment for this too - we are experiencing the same thing
PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND

18816 zimbra 18 0 4830m 4.4g 14m S 124.3 28.2 327:22.95 java

Zimbra 7.1.1: High CPU spikes every 5 minutes

Posted: Tue Jun 21, 2011 6:30 am
by drb
I have what is probably the same problem, although I can't tie it to 5-min intervals.
Response from my lightly-used (only about 5 active accounts) server has gone through the floor since I "upgraded" to v7.1.1 and at the times it is performing poorly the loadavg climbs to 13 or higher. The process soaking up cycles seems to be java.
And no, I've checked the logs and it hasn't been cracked into as a spam remailer.
Version is Release 7.1.1_GA_3196.DEBIAN5_64 DEBIAN5_64 FOSS edition.

Hardware is Athlon x2 4800+ with 1GB RAM
Ross

Zimbra 7.1.1: High CPU spikes every 5 minutes

Posted: Tue Jun 21, 2011 11:49 am
by xeon
[quote user="drb"]I have what is probably the same problem, although I can't tie it to 5-min intervals.
Response from my lightly-used (only about 5 active accounts) server has gone through the floor since I "upgraded" to v7.1.1 and at the times it is performing poorly the loadavg climbs to 13 or higher. The process soaking up cycles seems to be java.
And no, I've checked the logs and it hasn't been cracked into as a spam remailer.
Version is Release 7.1.1_GA_3196.DEBIAN5_64 DEBIAN5_64 FOSS edition.

Hardware is Athlon x2 4800+ with 1GB RAM
Ross[/QUOTE]

You upgraded from version 6.x to 7.1.1 with 1GB of RAM? That's probably your issue is the lack of RAM. Zimbra recommends minimum of 2GB.

Zimbra 7.1.1: High CPU spikes every 5 minutes

Posted: Thu Jun 23, 2011 2:04 am
by MichaelB12
I fixed a similar problem.. it exist a patch for 7.1.1 GA..
See my last post.. may be it will resolve your problem.
http://www.zimbra.com/forums/administrators/50266-solved-very-high-cpu-usage-7-1-1-a.html
>

Michael