Ubuntu Upgrade, Perl Version Broke ZImbra

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
juhenriquez1
Posts: 1
Joined: Fri Sep 26, 2014 6:31 am

Ubuntu Upgrade, Perl Version Broke ZImbra

Postby juhenriquez1 » Fri Sep 26, 2014 6:34 am

Kind of in a bind here, since I heard about the bash bugs last night I decided on upgrading all off my server, not just the packages but the complete OS, it worked fine on all my servers, except my mail server, which was running Ubuntu 12.04 and I upgrade to 14.04. Everything seem running correctly but when I try to get the Zimbra service running I get the Following:



Perl API version v5.14.0 of Socket does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 92. Compilation failed in require at /usr/lib/perl/5.18/Sys/Syslog.pm line 10. BEGIN failed--compilation aborted at /usr/lib/perl/5.18/Sys/Syslog.pm line 10. Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 21. BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 21. Compilation failed in require at /opt/zimbra/bin/zmcontrol line 27. BEGIN failed--compilation aborted at /opt/zimbra/bin/zmcontrol line 27.



I was kind of guessing it was problems with my Perl Version, So I downloaded perlbrew, but when I try to change the version from 5.18.0 to 5.14.0 I get the following:



Perl API version v5.14.0 of List::Util does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 92. Compilation failed in require at /usr/local/share/perl/5.18.2/App/perlbrew.pm line 22. BEGIN failed--compilation aborted at /usr/local/share/perl/5.18.2/App/perlbrew.pm line 22. Compilation failed in require at /usr/local/bin/perlbrew line 6. BEGIN failed--compilation aborted at /usr/local/bin/perlbrew line 6.



Can't see my Zimbra Version, cause from zmcontrol -v I get the following:



Perl API version v5.14.0 of Socket does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 92. Compilation failed in require at /usr/lib/perl/5.18/Sys/Syslog.pm line 10. BEGIN failed--compilation aborted at /usr/lib/perl/5.18/Sys/Syslog.pm line 10. Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 21. BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 21. Compilation failed in require at /opt/zimbra/bin/zmcontrol line 27. BEGIN failed--compilation aborted at /opt/zimbra/bin/zmcontrol line 27.



Quite the large bind for me, any help would be appreciated.



User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2778
Joined: Thu May 22, 2014 4:47 pm

Ubuntu Upgrade, Perl Version Broke ZImbra

Postby jorgedlcruz » Fri Sep 26, 2014 7:54 am

Hi juhenriquez1,


Other member of the Forum writes a workaround, take a look and I hope that will works smooth for you - https://community.zimbra.com/zforums914/f/1928/p/1076316/1400613#1400613


Best regards

Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
User avatar
tonster
Zimbra Employee
Zimbra Employee
Posts: 312
Joined: Fri Feb 21, 2014 10:14 am
Location: Ypsilanti, MI
ZCS/ZD Version: Release 8.7.0_GA_1659.RHEL6_64_2016

Ubuntu Upgrade, Perl Version Broke ZImbra

Postby tonster » Fri Sep 26, 2014 6:15 pm

You don't specify what version you're running, but you can't simply upgrade the version of the OS without also downloading and installing the binaries of ZCS for that version. Each version of ZCS is compiled specifically for the OS which it's to be installed on. If you were running Ubuntu 12 I hope you were also running ZCS 8.5 or you're going to have a mess on your hands, as only ZCS 8.5 supports Ubuntu 14.
cppetrie
Posts: 3
Joined: Thu Dec 25, 2014 9:19 pm

Ubuntu Upgrade, Perl Version Broke ZImbra

Postby cppetrie » Thu Dec 25, 2014 11:52 pm

You need to install zimbra using the package for Ubuntu 14.04. This will fix the Perl issue. If you're already running Zimbra 8.6, running the 14.04 install for 8.6 will cause this same error with Perl versions due to some upgrade checks that are run. The workaround is to run the install script with the --skip-upgrade-check option to disable the checks that cause the problem.


./install.sh --skip-upgrade-check


You should also skip the mail database integrity check as it uses an existing script from the 12.04 installation on your system to perform the check (which will fail in this scenario). This fixed my issue and got me running Zimbra v8.6 on Ubuntu 14.04 after having upgraded from Zimbra v8.6 on Ubuntu 12.04.


Hope it helps!

User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2778
Joined: Thu May 22, 2014 4:47 pm

Ubuntu Upgrade, Perl Version Broke ZImbra

Postby jorgedlcruz » Mon Dec 29, 2014 1:34 pm

Hi juhenriquez1,

Did this answer from cppetrie helps you?



Best regards
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
juresimsic
Posts: 25
Joined: Fri Sep 12, 2014 11:47 pm

Ubuntu Upgrade, Perl Version Broke ZImbra

Postby juresimsic » Mon Jan 12, 2015 2:56 pm

Hi Jorge,

the above link is unfortunately broken now..



Cheers

Jure
juresimsic
Posts: 25
Joined: Fri Sep 12, 2014 11:47 pm

Ubuntu Upgrade, Perl Version Broke ZImbra

Postby juresimsic » Mon Jan 12, 2015 3:00 pm

Thanks cppettrie,



this helped me though as I understand it shouldn't have happened in the first place as I was upgrading from ZCS 8.6.0 on ubu12LTS, upgraded ubu to 14LTS so it was zcs 8.6.0 to 8.6.0 upgrade.. But hey, life would be boring otherwise ;)



Cheers,

Jure
metux
Advanced member
Advanced member
Posts: 146
Joined: Mon Jul 28, 2014 6:21 pm

Ubuntu Upgrade, Perl Version Broke ZImbra

Postby metux » Sat Feb 21, 2015 6:56 am

Such things happen if comlex software isn't properly packaged for the target distro ...

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 15 guests