Page 1 of 2

Network service error all across the server

Posted: Wed Apr 05, 2017 2:03 pm
by crnjaz
Ok, so, a little backstory. We had a bunch of stuff going on last month or so, the guys that were payed to setup our backup mail server <moderator removed> up a bit, and in the process of setting up our backup server, the main one suddenly stopped working.
After few weeks of "fixing it", they gave us a barely working server, where we can just access accounts (to export them manually), but "the server cant be fixed" and "the only possible solution is to virtualise all your servers, and when we do that we can fix the mail server too".

Im, honestly, not buying this, and, with my limited linux/zimbra knowledge I'd like to try and fix the server by my self.

So, the symptoms.
zmcontrol status is telling me that everything is running ok.
I can log in in most user accounts (we found one where its impossible to login, but lets fix the whole server first), and i can browse trough mail, but when i try to send a mail, i get the following error:

Code: Select all

method:   [unknown]
msg:   system failure: writing new object of type 5
code:   service.FAILURE
detail:   soap:Receiver
trace:   btpool0-2://192.168.19.50/service/soap/SendMsgRequest:1491399894349:d1fbc9d4d21de4af
request:   
Body: {
  SendMsgRequest: {
    _jsns: "urn:zimbraMail",
    m: {
      e: [
        0: {
          a: "dusan.raf@mydomain",
          add: "0",
          p: "Dusan Raf",
          t: "t"
         },
        1: {
          a: "nikola.martinovic@mydomain",
          p: "Nikola Martinovic",
          t: "f"
         }
       ],
      idnt: "967e01bd-9e57-4bfa-89d0-81959cb39f35",
      mp: [
        0: {
          ct: "multipart/alternative",
          mp: [
            0: {
              content: {
                _content: "11

Nikola Martinović

"
               },
              ct: "text/plain"
             },
            1: {
              content: {
                _content: ".........."
               },
              ct: "text/html"
             }
           ]
         }
       ],
      su: {
        _content: "11"
       }
     },
    suid: 1491399893757
   }
 },
Header: {
  context: {
    _jsns: "urn:zimbra",
    account: {
      _content: "...",
      by: "name"
     },
    authToken: "(removed)",
    session: {
      _content: 1100,
      id: 1100
     },
    userAgent: {
      name: "ZimbraWebClient - GC56 (Win)",
      version: "7.1.4_GA_2555"
     }
   }
 }


Also, any unread mails, read trough out the session, show up unread next time I log in as given user.

Going trough the admin console, changing most settings give us the following error:

Image

So, can any of you help me, and point me to how to fix the server?

edit: i forgot to add... Incoming and outgoing mails are not working on the server. We can only go trough the data, as if it is static.

Re: Network service error all across the server

Posted: Mon Apr 10, 2017 8:12 pm
by DualBoot
Hello,

try as zimbra user the following command : zmupdateauthkeys

Regards,

Re: Network service error all across the server

Posted: Tue May 16, 2017 2:48 pm
by crnjaz
I did that. (did it again now nevertheless)
Still not working, still same symptoms.

Re: Network service error all across the server

Posted: Wed May 17, 2017 7:28 am
by crnjaz
Also, i guess this is the right spot to ask another question.
We can access all accounts, basically in "read only" mode. I can access the mailboxes, view and export them (but nothing more), so Im exporting them 1 by 1 (since imapsync dont work), except for one account.
When i try to login - Image
When i try to open it from admin console - i get "message: system failure: updating mailbox statistics for mailbox67 Error code: service.failure Details:soam:Reciever".
Solving that would be very helpful too.

Re: Network service error all across the server

Posted: Wed May 17, 2017 8:17 am
by crnjaz
cant edit replies, sorry for spamming.
i cant export the given account from console (with zmmailbox) too, it gives me:

Code: Select all

ERROR: service.FAILURE (system failure: GET from http://mail.smederevo.org.rs/home/user@smederevo.org.rs/?fmt=tgz failed, status=404.  no such item)

i can export other accounts with it tho.

Re: Network service error all across the server

Posted: Wed May 17, 2017 5:01 pm
by DualBoot
can you post a working command and a non working one ?

Re: Network service error all across the server

Posted: Wed May 17, 2017 5:37 pm
by crnjaz

Code: Select all

  zmmailbox -z -m user@domain getRestURL “//?fmt=tgz” > /tmp/user.tar.gz

works, giving me the output file.

same thing, for that one user gives me:

Code: Select all

ERROR: service.FAILURE (system failure: GET from http://mail.smederevo.org.rs/home/andjelka.bajcic@smederevo.org.rs/?fmt=tgz failed, status=404.  no such item)


I know that there is a store and index folder for that mailbox, i've extracted them, to access some mails manually.

Re: Network service error all across the server

Posted: Wed May 17, 2017 6:28 pm
by DualBoot
So I checked this http://mail.smederevo.org.rs and this not a Zimbra server but , this url httpS://mail.smederevo.org.rs is a Zimbra server .
I think you have to force your zmmailbox comand to use localhost instead of the public service hostname or to set the public service protocol to https
for the domain you want to extract your account.

Regards,

Re: Network service error all across the server

Posted: Thu May 18, 2017 5:18 pm
by crnjaz
could you tell me how? what command?

Re: Network service error all across the server

Posted: Thu May 18, 2017 5:43 pm
by DualBoot
zmmailbox , what else ?
you can force the url to use.