Page 1 of 1

Update Url Working?

Posted: Mon Apr 15, 2019 9:10 am
by CarlCox

I don't get any Zimbra Updates.
Is this URL correct?

Ubuntu 16.04.5 LTS (GNU/Linux 4.4.0-145-generic x86_64)
Zimbra 8.8.10_GA_3039.FOSS (build 21080928094617) 28. Sep 2018

Thank You!

Re: Update Url Working?

Posted: Mon Apr 15, 2019 10:05 am
by pup_seba

I'm sorry for the ignorance, but I did not know about the existance of that URL. When I want to upgrade/update Zimbra, I either:

- Update via Zimbra repositories
- Update by downloading the binaries for the new version and run an /

What are you expecting to see in that url?

Re: Update Url Working?

Posted: Mon Apr 15, 2019 10:46 am
by DualBoot

this URL is used by Zimbra server to show if there is a new version of Zimbra and displays it into the admin web interface.


Re: Update Url Working?

Posted: Mon Apr 15, 2019 11:42 am
by pup_seba
Ohh ok, thanks.

Right now I'm using 8.8.12 but now that you mention it, I don't remember when it was the last time I saw an update notification.

For what I can see in "zmprov gacf", everything seems to be allright at least from server and the response it gets, but again, i am using the last avaialble version so my tests are kind of not useful, sorry.

[zimbra@zimbrastore01 ~]$ zmprov gacf | grep -i versioncheck
zimbraReverseProxyExactServerVersionCheck: on
zimbraVersionCheckInterval: 1d
zimbraVersionCheckLastAttempt: 20190415113030.381Z
zimbraVersionCheckLastResponse: <?xml version="1.0"?>
<versionCheck status="0">

zimbraVersionCheckLastSuccess: 20190415113030.381Z
zimbraVersionCheckNotificationSubject: ${IS_CRITICAL} updates are available for your Zimbra server
zimbraVersionCheckSendNotifications: TRUE
zimbraVersionCheckServer: cf1d47c5-2b49-4227-b093-794efcb3a10c

Re: Update Url Working?

Posted: Mon Apr 15, 2019 12:02 pm
by CarlCox
Thanks we download 8.8.12 and run the
It works now.

But in the Admincenter we dont get any notifications. is that normal?

Re: Update Url Working?

Posted: Tue Apr 23, 2019 6:38 am
by pup_seba

In another post viewtopic.php?f=15&t=65932&start=30, user halfgaar reported (out of topic i think) that running this command does not work.
/opt/zimbra/libexec/zmcheckversion -c. As I did not see the "c" option in the help of the command (and have no willing to see the actual code to read what's in it), i also ran "-m", which shows the same result as with "-c". In both I have "too early".

So yeap, it seems from this and from what you say, that the checkversion is not working as expected?

Re: Update Url Working?

Posted: Tue Apr 23, 2019 6:57 pm
by halfgaar
pup_seba, you mention repos. I have apt sources:

Code: Select all

deb     [arch=amd64] trusty zimbra
deb-src [arch=amd64] trusty zimbra

But I don't seem to get the application updates that way. I still have to run the monolithic installer. And even then, patches are sometimes an additional tarball, like for this critical cve-2019-9670 (which is being exploited!).

Anyway, I can't seem to find the official source code for it, but I found source of a fork of In it, you can see that you need '-c' to check the version.

You can also see that it says 'Too early' when the last check was too recent. So, I changed the check interval to one second and ran '/opt/zimbra/libexec/zmcheckversion -c'. No output, no e-mail. I tried '-r' and '-m' too, to no avail.

Re: Update Url Working?

Posted: Wed Apr 24, 2019 6:39 am
by pup_seba
Ohh ok. So the "too early" is meant to not overwhelm their servers with continous version check requests. Good to know, I wasn't aware of that! Thank you!!!

Regarding the repos, for upgrading versions (major or minor), they don't work as you will still need to deploy from binaries. For patching they do work or at least they should. They are indeed some times (i can only remember one) for which in the patch release notes a specific file should be deployed from outside the patch.

Re: Update Url Working?

Posted: Sun May 05, 2019 10:57 am
by halfgaar
I submitted a bug report about the updater not working. No response so far.