Page 1 of 1

Blocking domains

Posted: Thu Sep 05, 2019 4:05 pm
by yellowhousejake
Release 8.8.9.GA.3019.UBUNTU16.64 UBUNTU16_64 NETWORK edition, Patch 8.8.9_P8

Good morning,

On our previous Zimbra install we blocked many domains using a pcre table and setting a property for to use that table as a sender restriction. That does not work with 8.8.9 so I changed our file to lmdb format, but I am not able to get it loaded into

I created the file properly and placed in in /opt/zimbra/common/conf
I ran postmap on that file
-- postmap /opt/zimbra/common/conf/cog-reject
I ran zmprov to add that file as a restriction
-- zmprov mcf +zimbraMtaRestriction 'check_client_access lmdb:/opt/zimbra/common/conf/cog-reject.lmdb'
I checked to see that the restriction was in place, and it was listed in the output
-- zmprov gcf zimbraMtaRestriction

Restarting or reloading the mta does not add the restriction to and the domains in the file are not being rejected.

I next looked at the cf files in /opt/zimbra/conf/zmconfigd finding the file containing the line
%%contains VAR:zimbraMtaSmtpdSenderRestrictions check_sender_access lmdb:/opt/zimbra/conf/postfix_reject_sender%%

So I renamed my reject file to 'postfix_reject_sender', ran postmap on the file, and reloaded the zimbra mta again. Still no entry in the postfix

Obviously I am doing something wrong, but what I do not know.

Any suggestion would appreciated.


Re: Blocking domains

Posted: Thu Sep 05, 2019 6:50 pm
by slacker1337
Try this one:

zmprov ms `zmhostname` +zimbraMtaSmtpdSenderRestrictions "check_sender_access lmdb:/opt/zimbra/conf/postfix_reject_sender"

Reference: ... g_of_users

Re: Blocking domains

Posted: Thu Sep 05, 2019 7:00 pm
by yellowhousejake
Arrrrrg! How did I miss that in my searches?

Thank you, changes made and it is working again.