Disabling IM/XMPP in ZCS 7.x

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
Crayz9000
Advanced member
Advanced member
Posts: 65
Joined: Sat Sep 13, 2014 2:27 am

Disabling IM/XMPP in ZCS 7.x

Postby Crayz9000 » Tue Jun 26, 2012 3:12 pm

I HAVE A BIT OF A STRANGE ISSUE. BACK WHEN I WAS PLAYING WITH ZCS 6 ON OSX, I HAD ENABLED IM TO TRY. NOW THAT I'VE ALREADY MIGRATED AND UPGRADED TO ZCS 7 (FIRST IT WAS 7.1.4, NOW 7.2.0) I FIND THAT I CAN'T MAKE THE IM USER INTERFACE ELEMENTS GO AWAY:

BEFORE UPGRADING FROM 7.1.4 TO 7.2.0 YESTERDAY, I READ THROUGH AJCODY-INSTANT-MESSAGING-TOPICS - ZIMBRA :: WIKI AND DISABLED XMPP AS DESCRIBED. TO BE SAFE, I ALSO MADE SURE THAT ZIMBRAFEATUREINSTANTNOTIFY AND ZIMBRAFEATUREIMENABLED WERE ALSO TURNED OFF:
ZIMBRA@MAIL:~/LIBEXEC$ ZMPROV GC DEFAULT ZIMBRAFEATUREIMENABLED

# NAME DEFAULT

ZIMBRAFEATUREIMENABLED: FALSE
ZIMBRA@MAIL:~/LIBEXEC$ ZMPROV GC DEFAULT ZIMBRAFEATUREINSTANTNOTIFY

# NAME DEFAULT

ZIMBRAFEATUREINSTANTNOTIFY: FALSE
ZIMBRA@MAIL:~/LIBEXEC$ ZMPROV GACF ZIMBRAXMPPENABLED

ZIMBRAXMPPENABLED: FALSE

AND BEFORE ANYONE ASKS, I HAVE NOT CREATED ANY ADDITIONAL COS ENTRIES -- THERE IS ONLY THE DEFAULT COS.
HOWEVER, I STILL CAN'T GET THE UI ELEMENTS TO GO AWAY... ANY IDEAS?

IM_ZCS7.png



ewilen
Elite member
Elite member
Posts: 1429
Joined: Fri Sep 12, 2014 11:34 pm

Disabling IM/XMPP in ZCS 7.x

Postby ewilen » Wed Jun 27, 2012 12:41 pm

Hm, most people have the opposite problem, wanting to keep IM even though it's disabled by default in ZCS 7. In fact I'm surprised it didn't just go away for you.
When I restored IM in ZCS 7, I turned on all the properties you mention above, but also zimbraPrefIMAutoLogin. So maybe if you turn that off, it would help.
Another shot in the dark. As root:

mv /opt/zimbra/lib/ext/zimbraiminterop /some/other/place/
As zimbra (if ZCS is running):

zmmailboxdctl restart
Crayz9000
Advanced member
Advanced member
Posts: 65
Joined: Sat Sep 13, 2014 2:27 am

Disabling IM/XMPP in ZCS 7.x

Postby Crayz9000 » Wed Jun 27, 2012 7:59 pm

Autologin was already off:
zimbra@mail:~$ zmprov gc default zimbraPrefIMAutoLogin

# name default

zimbraPrefIMAutoLogin: FALSE

And the zimbraiminterop folder doesn't even exist...
zimbra@mail:~$ ls /opt/zimbra/lib/ext/zimbraiminterop

ls: cannot access /opt/zimbra/lib/ext/zimbraiminterop: No such file or directory
zimbra@mail:~/lib/ext$ ls

clamscanner nginx-lookup zimbraldaputils

com_zimbra_bulkprovision zextras

com_zimbra_cert_manager zimbraadminversioncheck


Still stumped, but thanks for the suggestions.

Return to “Administrators”

Who is online

Users browsing this forum: MSN [Bot] and 9 guests