SLAPD Port Set to 7389, Should be Set to 389

Have a great idea for extending Zimbra? Share ideas, ask questions, contribute, and get feedback.
PotatoBob
Posts: 16
Joined: Fri Sep 12, 2014 9:59 pm

SLAPD Port Set to 7389, Should be Set to 389

Postby PotatoBob » Thu Oct 27, 2005 6:49 pm

I keep getting ldap errors on my install which was trying to acces port 389, but I find out that /opt/zimbra/bin/ldap starts slapd on port 7389 instead of 389 and the /opt/zimbra/conf/localconfig.xml also sets to 389 so therefore 7389 was a mistake by someone?
so line 66 on /opt/zimbra/bin/ldap should be changed from

/opt/zimbra/openldap/libexec/slapd -4 -u zimbra -h "ldap://:7389/" 



to

/opt/zimbra/openldap/libexec/slapd -4 -u zimbra -h "ldap://:389/" 


so the port was changed from 7389 to 389


17629anand
Zimbra Alumni
Zimbra Alumni
Posts: 273
Joined: Fri Sep 12, 2014 9:53 pm

SLAPD Port Set to 7389, Should be Set to 389

Postby 17629anand » Thu Oct 27, 2005 6:56 pm

in the version that is out there we have iptables mapping port 389 -> 7389.
So check your iptables settings and or firewall settings.
Also search the forums for zmiptables
PotatoBob
Posts: 16
Joined: Fri Sep 12, 2014 9:59 pm

SLAPD Port Set to 7389, Should be Set to 389

Postby PotatoBob » Thu Oct 27, 2005 7:02 pm

why is port 25 mapped to 7075?


Explain to me eventhough I ran this it did not work right?

here are my mappings

Port Mappings

-------------

25 --> 7075

993 --> 7993

443 --> 7443

995 --> 7995

389 --> 7389

80 --> 7070

110 --> 7110

143 --> 7143
so should this be installed on localhost or to the outgoing ip
PotatoBob
Posts: 16
Joined: Fri Sep 12, 2014 9:59 pm

SLAPD Port Set to 7389, Should be Set to 389

Postby PotatoBob » Thu Oct 27, 2005 7:12 pm

Ok I just now found out them when I run zmiptables to install is installs, but inturn disables my nat on my test server so no internet...
Funny thing my iptables wont save...

[edit]
Silly rabit, I didn't know that zmiptables deletes my current iptable settings...
PotatoBob
Posts: 16
Joined: Fri Sep 12, 2014 9:59 pm

SLAPD Port Set to 7389, Should be Set to 389

Postby PotatoBob » Thu Oct 27, 2005 8:13 pm

Ok my iptables just doesnt map port 389 to 7389 and so on with the other ports, any suggestions?
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

SLAPD Port Set to 7389, Should be Set to 389

Postby 14319KevinH » Thu Oct 27, 2005 10:33 pm

[quote user="PotatoBob"]Ok my iptables just doesnt map port 389 to 7389 and so on with the other ports, any suggestions?[/QUOTE]
Do you mean it DOES map that port? We need all the mappings to work for this build. In the next release we removed the need to do port mapping so all the iptables problems should go away.

Return to “Developers”

Who is online

Users browsing this forum: No registered users and 3 guests