Zimbra Soap API SendMsgRequest with Attachment

Have a great idea for extending Zimbra? Share ideas, ask questions, contribute, and get feedback.
chads
Posts: 39
Joined: Sat Sep 13, 2014 1:26 am
ZCS/ZD Version: ZCS 8.7.0 ZD 7.2.7

Zimbra Soap API SendMsgRequest with Attachment

Postby chads » Thu Jun 19, 2014 5:14 pm

Okay, for the past couple of days I have been investigating the user of the Zimbra Soap API, and so far I have been fairly successful. I can authenticate a user and send a message using SendMsgRequest with no problems. My problem occurs when I attempt to send a message with an attachment, it fails with the error NO SUCH ITEM. Not sure what I am doing wrong. According to the soap.txt file for SendMsgRequest, it has ... I have tried this and I get an error.
The code is from a C# .Net application running on Windows 7 x64. Like I said, everything works except the attaching of the file. I am assuming that document-path is the LOCAL path and file name. Here is what my soap string looks like:
http://www.w3.org/2003/05/soap-envelope"> xmlns="urn:zimbra">MYAUTHTOKENTest email - with attachmentMail with attachment and CC
Essentially, if I pull the attach stuff out the email sends no problem, but with it I get the error.


n.sossonko
Advanced member
Advanced member
Posts: 68
Joined: Sat Sep 13, 2014 2:14 am

Zimbra Soap API SendMsgRequest with Attachment

Postby n.sossonko » Fri Jun 27, 2014 12:10 pm

[quote user="chads"][/QUOTE]
This can't be right, how could the server possibly get to this file on your local "E" drive? I think you want to put the MIME-formatted upload directly between the tags, but I'm not very familiar with this.

Return to “Developers”

Who is online

Users browsing this forum: No registered users and 3 guests