Page 1 of 1

[SOLVED] Login hangs with FF, not with Edge

Posted: Mon Sep 03, 2018 9:58 am
by michelv
Hey,

On Zimbra 8.8.5_GA_1894 (build 20171026035615) Ubuntu, since this weekend I have a weird problem with current Firefox login (ajax, not html). Only with FF the login hangs at 'Loading...'. Edge ajax login works fine, for me ruling out the issues described here: https://wiki.zimbra.com/wiki/Troublesho ... ing_screen

FireFox version: 61.0.2 64 bit.

log do not show any errors (at least not the obvious).
last entry in log when login with FF (hangs)
2018-09-03 11:52:42,176 INFO [qtp1684106402-21571:https:https://localhost:7071/service/admin/soap/GetDomainInfoRequest] [name=SENSOR;mid=16;ua=ZCS/8.8.5_GA_1894;] soap - GetDomainInfoRequest elapsed=0

With edge this looks like:
2018-09-03 11:54:34,149 INFO [qtp1684106402-21588:https:https://localhost:7071/service/admin/soap/GetDomainInfoRequest] [name=SENSOR;mid=8;ua=ZCS/8.8.5_GA_1894;] soap - GetDomainInfoRequest elapsed=0
2018-09-03 11:54:35,369 INFO [qtp1684106402-21588:https:https://SENSOR/service/soap/BatchRequest] [ip=SENSOR;port=47886;] SoapEngine - Only BatchRequest does not have a handler mapped to it. Request: /service/soap/BatchRequest, does not have a handler, log for future handling.

Anybody any hint?

Re: Login hangs with FF, not with Edge

Posted: Mon Sep 03, 2018 1:16 pm
by DualBoot
Hello,

try to clean all possible caches :
- FireFox (using privacy mode may help)
- stop zimbra store and delete content of /opt/zimbra/jetty/work/ then restart the store

Regards,

Re: Login hangs with FF, not with Edge

Posted: Mon Sep 03, 2018 1:46 pm
by pup_seba
Ohh...i did not know about that "work" directory :)

But I see that is for temporary jetty files (https://www.eclipse.org/jetty/documenta ... ories.html)

Any reason/advantage for deleting that folder instead of using "zimbra fc all" command if the intention is to clean the cache?

Re: Login hangs with FF, not with Edge

Posted: Mon Sep 03, 2018 2:55 pm
by DualBoot
It does not clean the file system cache.

Re: Login hangs with FF, not with Edge

Posted: Mon Sep 03, 2018 3:00 pm
by pup_seba
Great! good to know that. Thx!

Re: Login hangs with FF, not with Edge

Posted: Mon Sep 03, 2018 3:20 pm
by michelv
Hey,

Thanks for the response. Cleaning firefox cache, going incognito nor removing content of the work directory did help.

I tried on another computer, there FF responds well. Will look further into this.

Re: Login hangs with FF, not with Edge

Posted: Mon Sep 03, 2018 3:31 pm
by michelv
Hey,

DualBoot wrote:Hello,
try to clean all possible caches :
- FireFox (using privacy mode may help)
- stop zimbra store and delete content of /opt/zimbra/jetty/work/ then restart the store

Thanks for the hints. These did not help unfortunately. I tried on another computer, with FF, and there login does work. Will investigate a bit further.

Re: [SOLVED] Login hangs with FF, not with Edge

Posted: Tue Sep 04, 2018 11:00 am
by michelv
I ended up refreshing FireFox completely. Lost a lot of weight (and addons), but it solved the problem.

https://support.mozilla.org/en-US/kb/re ... d-settings